Undefined array key "isStoreCode"

  • Affected App
    WoltLab Suite Core

    Ich bekomme beim Updateversuch vom Viecode Shop 8.0.8 auf. 8.0.9 eine Fehlermeldung. Anzumerken ist, dass ich das Plugin nicht über den WoltLab Store erworben habe. Als Fehlermeldung würde ich also eher ein "Zugriff verweigert" erwarten. Im Einsatz ist die neuste Version der WoltLab Suite 5.5.

    Entwicklung und Design moderner Webapplikationen

    kostenloser Support • Vorschläge teilen • Plugins kaufen

    Darkwood.Design

  • Bekomme nach dem Update immer noch den Fehler

    Display Spoiler

    Tue, 19 Jul 2022 14:05:36 +0000

    Message: Undefined array key "isStoreCode"

    PHP version: 8.0.21

    WoltLab Suite version: 5.5.2

    Request URI: POST /wcf/acp/index.php?ajax-proxy/&t=30529b45eb4a0c0941a2e98bed746e014452f4f85fbfe3f01d8be4b9bc9109f3-mri3w3vCgLEwTVbx9EFWWQ==

    Referrer: https://www.bus-community.eu/w…index.php?package-update/

    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.5 Safari/605.1.15

    Peak Memory Usage: 4760240/524288000

    ======

    Error Class: wcf\system\exception\ErrorException

    Error Message: Undefined array key "isStoreCode"

    Error Code: 0

    File: /var/www/vhosts/bus-community.eu/httpdocs/wcf/lib/system/WCF.class.php (341)

    Extra Information: -

    Stack Trace: [{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/data\/package\/update\/PackageUpdateAction.class.php","line":749,"function":"handleError","class":"wcf\\system\\WCF","type":"::","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/data\/package\/update\/PackageUpdateAction.class.php","line":675,"function":"createQueue","class":"wcf\\data\\package\\update\\PackageUpdateAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/data\/AbstractDatabaseObjectAction.class.php","line":216,"function":"prepareUpdate","class":"wcf\\data\\package\\update\\PackageUpdateAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/action\/AJAXProxyAction.class.php","line":92,"function":"executeAction","class":"wcf\\data\\AbstractDatabaseObjectAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/action\/AJAXInvokeAction.class.php","line":111,"function":"invoke","class":"wcf\\action\\AJAXProxyAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/action\/AbstractAction.class.php","line":57,"function":"execute","class":"wcf\\action\\AJAXInvokeAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/action\/AJAXInvokeAction.class.php","line":65,"function":"__run","class":"wcf\\action\\AbstractAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/system\/request\/Request.class.php","line":90,"function":"__run","class":"wcf\\action\\AJAXInvokeAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/lib\/system\/request\/RequestHandler.class.php","line":107,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/bus-community.eu\/httpdocs\/wcf\/acp\/index.php","line":11,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":[]}]


  • Sehe gerade, gibt keine Fehlermeldung.

    Bekomme nur oben das angezeigt, egal was ich mache, das Update läuft nicht durch.

    Hatte gestern den Marcel angeschrieben, er sagte es läge an diesem Fehler wie Darkwood es gemeldet hat.

    Plugin habe ich über den Store damals gekauft.

  • Steht ja auch da. Daran hat sich seit jeher nichts geändert. Ebenso wenig an der Notwendigkeit, einen Authentifizierungscode zu hinterlegen, wenn man gedenkt, kommerzielle Pakete von anderen Servern zu beziehen, als den offiziellen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!