Unterforen werden nicht mehr angezeigt seit dem Upgrade der Suite auf 5.5.9

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Hallo,

    ich hoffe das mir jemand helfen kann,

    Bevor jemand fragt warum ich jetzt erst das Upgrade auf die neueste Forenversion gemacht habe es war deshalb weil es vorher wegen der PHP Version meines Servers nicht möglich war die PHP wurde jetzt erhöht und nun konnte ich endlich das Upgrade durchführen.

    Jedenfalls habe ich von 5.3 auf 5.4. und dann auf 5.5 das Upgrade laufen lassen und jetzt habe ich folgendes Problem die Unterforen werden nicht mehr angezeigt,

    wenn ich ein Forum betrete wo unterforen sind sieht es so aus:

    Kann mir bitte jemand sagen was genau hier schief gelaufen ist??

    Es gibt auch keine Fehlermeldungen die Unterforen sind hier einfach n ur nicht sichtbar, wenn ich allerdings vom Forum index direkt auf eines der Unterforen klicke sind dann die Beiträge da , habe auch schon alle Cache geleert, Anzeigen Aktualisierung durchlafen lassen , Cronjobs auch alle ausgeführt , aber es hat leider alles nichts gebracht.

    Das war vor dem Upgrade nicht, da war alles so wie es sein sollte.

    Ich hoffe es kann mir jemand helfen und ja die Rechte sind alle eingestellt und sonst habe ich auch nichts geändert.

    Hier der Link zum Forum https://www.sims3dreams.at/Forum/Home/

    Danke und Lg

    Sonja

    Edited once, last by SunnySims (March 12, 2023 at 9:42 PM).

  • Der Link ist leider wenig hilfreich, da man als Gast die relevanten Inhalte nicht sieht.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Der Link ist leider wenig hilfreich, da man als Gast die relevanten Inhalte nicht sieht.


    Gruß norse

    Bei mir ist es aber so eingestellt das Gäste zugriff haben , die Foren und Themen können betreten und gelesen werden!

    Ich habe es selber auch gerade nochmals überprüft.

    Es funktioniert ja sonst auch alles es gibt auch wie gesagt keine Fehlermeldungen das einzige was ist das die unterforen Unsichtbar sind. Sie sind aber nicht ausgeblendet das habe ich schon mehrfach überprüft sie werden nicht angezeigt im "Mutterforum" obwohl sie das eigentlich müssten!

    Das Problem besteht wie gesagt erst seit Donnerstag dem 09.3 wo ich das Upgrade durchgeführt hatte. Vorher war alles ok, es funktioniert auch sonst alles einwandfrei, nur das Problem mit den " unsichtbaren Unterforen" in den Hauptforen war vorher nicht !

    Edited once, last by SunnySims (March 12, 2023 at 10:15 PM).

  • Sorry, vor lauter Boxen habe ich die Forenübersicht zunächst nicht gefunden. Es liegt übrigens am Stil. Im anderen Stil "Lunatic" ist alles wie üblich sichtbar. Kontrolliere mal das Template im Standardstil.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Tim Düsterhus March 13, 2023 at 10:05 AM

    Added the Label Not a bug
  • In diesem Zusammenhang mal eine Verständnisfrage: Ist es nicht üblich oder vielleicht sogar für die Freischaltung im Pluginstore erforderlich, in der package.xml eines Stilpakets die Folgeversion des WSC auszuschließen, um so etwas zu vermeiden? Wenn keine Anpassungen erforderlich sind, lässt sich das dann doch mit einem minimalen Eingriff und einer weiteren Updateanweisung regeln.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Die älteren Stile nutzen die API 2018, ein Exlude gibt es standardmäßig nur für Version 6.x.x, da die Version 5.5 radikal verändert wurde sind diese Probleme vorprogrammiert wenn ältere Installationen bei einem Softwareupdate auf den neuesten Stand gebracht werden.

    - Wenn bei Dummheit & Arroganz Federn wachsen sollten, so würden hier einige wie Vögel durch die Luft fliegen -

    - Powerstylez.de -

  • Hallo,

    Ist es nicht üblich oder vielleicht sogar für die Freischaltung im Pluginstore erforderlich, in der package.xml eines Stilpakets die Folgeversion des WSC auszuschließen, um so etwas zu vermeiden?

    bei Stilen ist das in der Prüfung historisch ziemlich inkonsistent geprüft worden.

    Rein CSS-basierte Stile sollten problemlos mit allen 5.x-er-Versionen kompatibel sein und vermutlich auch in 6.0 noch akzeptabel aussehen. Sobald ein Template dabei ist, kann ein Stil bereits nach einem Bugfix-Update veraltet sein. Beispielsweise ist es denkbar, dass die Sicherheitskorrektur in WoltLab Suite 5.5.8 aufgrund eines veralteten Stil-Templates nicht konsequent angewendet wird.

    Für Stile mit eigenen Templates versuchen wir mittlerweile im Rahmen der Prüfung darauf hinzuweisen, dass ein Exclude der nächsten Version (statt 6.0/7.0/8.0) erfolgen soll, aber auch das kann mal vergessen werden.

  • Hallo,

    Bugfix-Versionen (Stelle 3) auszuschließen würde die Installation von Bugfix-Updates unnötig blockieren, insbesondere dann, wenn es sich um Sicherheitsupdates handelt. Bei Bugfix-Updates sind Template-Inkompatibilitäten auch unwahrscheinlich(er), aber das Beispiel oben zeigt, dass sie nicht komplett auszuschließen sind (je nachdem welche Templates im Stil verändert wurden).

    Mit dem nächsten Funktionsupdate (d.h. Stelle 1 oder Stelle 2) sind Inkompatibilitäten aber in aller Regelmäßigkeit zu erwarten – und wenn es nur ist, dass eine neue Funktion nicht zur Verfügung steht, weil das entsprechend modifizierte Template nicht angepasst wurde, um die entsprechende Funktion zu integrieren. Das hat auch nichts mit den „radikalen Veränderungen“ am Seitenmenü in 5.5 zu tun. Auch zwischen 5.3 und 5.4 haben sich allein in WoltLab Suite Core insgesamt 139 Frontend-Templates verändert, darunter im Rahmen des neuen Session-Systems beispielsweise pageHeaderUser zur Entfernung der Checkbox für den dauerhaften Login. Ein Template, das nicht angepasst wurde, stellt dann ein nicht-funktionales UI-Element zur Verfügung.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!