Dauer Import

  • Affected App
    WoltLab Suite Forum

    Hallo,


    ist es normal das der Import nun schon über 24 Stunden dauert?


    Ist zwar ein recht grosses Forum mit über 4000 Usern und knapp 390000 Beiträgen aber es kommt mir dann doch etwas lange vor, besonders weil Quell- und Zielforum auf derselben Maschine liegen.


    Läuft auf einem eigenen Rootie mit Octacore und 48 GB Ram, Leistung ist demnach genug vorhanden.

    • Official Post

    Das klingt eher, als ob der Import durch einen Fehler abgebrochen ist, allerdings hätte es dann eine Fehlermeldung geben müssen. Ein paar mehr Informationen wären an dieser Stelle hilfreich.

  • Bei mir hat der Import auch auf einem Root Server geschlagene 5 Stunden inkl. dem Updaten der Anzeigen gedauert:



    Mitglieder
    66
    Benutzer online
    3
    Themen
    1 745 (0,59 Themen pro Tag)
    Beiträge
    52 449 (17,63 Beiträge pro Tag)
    Dateianhänge
    500 (84,53 MB)
    Private Nachrichten
    8 242
    Datenbankeinträge
    155 473
    Datenbankgröße
    101,05 MB



    Das kommt mir für die für ein Forum recht wenigen Daten doch etwas lang vor, oder?

  • Der Import läuft aktuell immernoch brav weiter, kein Abbruch, kein Fehler - nur quälend langsam.


    Vor 8 Stunden als ich den 1. Beitrag schrieb war der Import der Beiträge bei 15%, im Moment sind es 44%.
    Fehlermedungen gibt es keine und auch die Serverlogs sind sauber.


    edit
    25 min später bei 46%:


    Edited once, last by GnArZ ().

  • Ich glaub ich warte noch ein wenig mit dem Umstieg und dem Testen, der importiert sich hier den Wolf.
    Da sollte nachgebessert werden.

  • 390000 Beiträge ist schon ne Menge Holz - aber da dürfte noch Luft für Optimierungen sein...


    Beispiel:
    das erstmalige der Schreiben der Hashwerte für die installierten Dateien in die installed_file_log dauert in der ersten Version knapp 25 Sekunden, nachdem ich dann eine temporäre MemoryTabelle als Zwischenspeicher benutzte und von diesen mit einem SQL-Kommando die installed_file_log beschrieb lag der Wert unter einer Sekunde..

    Der Kopf ist rund, damit das Denken die Richtung wechseln kann (Francis Picabia)

  • Und das machst du woran fest?
    Während des Importes lag die CPU Auslastung z.b. bei 0,1%, sprich, der hat sich gelangweilt.


    Das ist doch hier die Standardantwort :D


    Bei mir dauerte der Import (278 User, 319 000 Beiträge) 5 1/2 Stunden, allerdings im 6. oder 7. Anlauf; auf einem Hostingpaket.

  • Da ich grade aktuell dasselbe Forum (WBB 3.1.8, 4700 User, 11700 Themen und 380000 Beiträge) auf denselben Server (auf dem ich WBB 4 testete) umgezogen habe was superschnell und ganz ohne Probleme klappte kann ich nicht wirklich glauben das es an der Maschine liegen soll.
    Es wäre schon komisch wenn die neue Evolutionsstufe des WBB um so vieles langsamer wäre als die aktuelle Version.

  • Bei mir sieht der Import so aus =O



    Edited once, last by Mario101 ().

  • @Mario101 Da Deine Fehlermeldung im Forum - laut Suche - noch nicht gemeldet wurde, wäre sie in einem eigenen Thema wohl besser aufgehoben. ;) Hat ja jetzt nicht direkt etwas mit diesem Thema zu tun.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!