Upgrade auf 5.4 schlägt fehl

  • Affected Version
    WoltLab Suite 5.4

    Hallo,


    ich habe gerade auf meinem Integrationssystem das Upgrade auf 5.4 getestet, was leider mit einem Fehler abbricht, da eine Datenbanktabelle nicht gelöscht werden kann:

    Requested URL
    POST /acp/index.php?install-package/&t=1ef8bbaf8cab59c73eb53c0a5c6ea2c051daa0c26f13ad59d1eca76f4e7176dc-NDVlZmZlZmYwMTQ1YWYyM2RiZDgyOGVmNmI5NWZkYjc%3D
    Referrer
    https://XXXXXXXXXXXXXXXX.de/acp/index.php?package-update/
    Error Message
    Das Datenbanklayout konnte aufgrund folgender Fehler nicht aktualisiert werden: Die unbekannte Tabelle wcf1_acp_session_virtual kann nicht gelöscht werden.
    Type
    RuntimeException
    File (Line)
    /www/htdocs/w01537c5/temp/lib/system/database/table/DatabaseTableChangeProcessor.class.php (1116)
    Stacktrace
    1. /www/htdocs/w01537c5/temp/lib/system/package/plugin/DatabasePackageInstallationPlugin.class.php (78): wcf\system\database\table\DatabaseTableChangeProcessor->process(…)
    2. /www/htdocs/w01537c5/temp/lib/system/package/plugin/DatabasePackageInstallationPlugin.class.php (48): wcf\system\package\plugin\DatabasePackageInstallationPlugin->updateDatabase(…)
    3. /www/htdocs/w01537c5/temp/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (76): wcf\system\package\plugin\DatabasePackageInstallationPlugin->install(…)
    4. /www/htdocs/w01537c5/temp/lib/system/package/PackageInstallationDispatcher.class.php (792): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    5. /www/htdocs/w01537c5/temp/lib/system/package/PackageInstallationDispatcher.class.php (153): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    6. /www/htdocs/w01537c5/temp/lib/acp/action/InstallPackageAction.class.php (82): wcf\system\package\PackageInstallationDispatcher->install(…)
    7. /www/htdocs/w01537c5/temp/lib/action/AbstractDialogAction.class.php (73): wcf\acp\action\InstallPackageAction->stepInstall(…)
    8. /www/htdocs/w01537c5/temp/lib/action/AbstractAction.class.php (53): wcf\action\AbstractDialogAction->execute(…)
    9. /www/htdocs/w01537c5/temp/lib/system/request/Request.class.php (89): wcf\action\AbstractAction->__run(…)
    10. /www/htdocs/w01537c5/temp/lib/system/request/RequestHandler.class.php (119): wcf\system\request\Request->execute(…)
    11. /www/htdocs/w01537c5/temp/acp/index.php (11): wcf\system\request\RequestHandler->handle(…)

    Hat jemand einen Tipp?


    Vielen Dank, Eckhard

    • Official Post

    Hallo,

    Ich gehe davon aus, dass dies mit einer neuen Version gefixt wird.

    ich möchte, wie im anderen Thema schon angedeutet, bemerken, dass das kein grundsätzlicher Fehler im Update oder der Software ist, sondern, dass aus irgendeinem Grund fehlerhafte Informationen über den Systemzustand in der Datenbank vorliegen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!