Fehlerhafte Darstellung einer Codebox in der Vorschau

  • Affected Version
    WoltLab Suite 5.3
    Affected App
    WoltLab Suite Core

    Fügt man ausschließlich eine Codebox mit beispielsweise folgendem Inhalt in einen Beitrag ein und öffnet die Vorschau, dann sieht das ein wenig korrekturbedürftig aus.

    PHP
            $userList = new UserList();
            $userList->getConditionBuilder()->add('user_table.banned = ?', [1]);
            $userList->getConditionBuilder()->add('user_table.userID IN (SELECT userID FROM wcf'.WCF_N.'_user_to_group WHERE groupID = ?)', [4]);
            $userList->sqlOrderBy = 'user_table.username ASC';
            $userList->readObjects();


    Reproduzierbar mit Safari Version 14.0 (15610.1.28.1.9, 15610) unter macOS Catalina 10.15.7 (19H2).


    Edit #1:

    Und klickt man etwas überhalb der Überschrift, dann erscheint folgende Fehlermeldung in einem neuen Tab mit folgender aufgerufener URL:

    Code: https://community.woltlab.com/index.php?ajax-proxy/&t=339b575afe22ee84a93788423495a866bc966a17#codeLine_1_com_woltlab_wbb_post_0_baa4a9
    {"code":412,"file":null,"line":null,"message":"Der Parameter \u201eclassName\u201c fehlt oder ist ung\u00fcltig.","previous":[],"returnValues":{"errorMessage":"Der Parameter \u201eclassName\u201c fehlt oder ist ung\u00fcltig.","errorType":"empty","fieldName":"className","realErrorMessage":"Bitte f\u00fcllen Sie dieses Eingabefeld aus."},"exceptionID":""}

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!