"Es sind Aktualisierungen für installierte Pakete verfügbar" im Frontend ausblenden

  • Ich habe mittlerweile eine Idee, was ich machen könnte und versuche auch schon etwas in der Richtung.

    Ich hänge jetzt erst einmal meine "Übergangslösung" an, mit dessen Hilfe zumindest (sehr dreckig) die Update-Info im Frontend (vorerst vollständig) deaktiviert wird.

    Wer's braucht, darf es sich installieren. Ansonsten wird die Entwicklung eines richtigen Plugins erst einmal ein wenig Zeit beanspruchen.

    Download

  • Ich muss mir noch ein paar Gedanken zum Layout machen. Aber die Grundidee bisher (ohne einzelne Versionen):

    Wird am Ende wahrscheinlich eh vollkommen anders aussehen, aber das ist in etwa, was ich mir vorgestellt habe, nämlich dass man Paket-Aktualisierungen für jeden einzelnen Update-Server (de-)aktivieren kann, wobei dies sowohl für ganze Pakete, als auch für einzelne Versionen funktionieren soll.

    Wann ich fertig bin, vermag ich gegenwärtig nicht zu sagen. Es dauert so lang, wie es dauert.

  • Meldung ist weg,

    danke schön an SC.

    ---------------

    und bei Woltlab noch mal überlegen den Unterschied von

    - Paket aktualisieren
    - Update (kostenfpflichtig)

    auf der Updateseite darzustellen.
    Als Neukunde bin ich über das Thema gestolpert

  • So einfach, wie ihr euch das vorstellt, ist es halt nicht. Für die Paketverwaltung ist Update gleich Update (= neuere Version als die derzeit installierte) und es spielt keine Rolle, wer der Hersteller ist. Es hätte also genau so gut ein @VieCode, ein @Christopher Walz oder ein @DevLabor sein können, die ein "neues", kostenpflichtiges Paket in den Store gestellt hätten mit dem Bezeichner eines "alten" Pakets. Der Effekt wäre derselbe.

    Soll heißen: Es ist keine Maßnahme seitens WoltLab, um euch zum Erwerb des Updates zu zwingen. Es sind die Gegebenheiten, die es aktuell nicht anders zulassen und euch über Updates informieren, die ihr u.U. bezahlen müsst.

  • Ich hänge jetzt erst einmal meine "Übergangslösung" an, mit dessen Hilfe zumindest (sehr dreckig) die Update-Info im Frontend (vorerst vollständig) deaktiviert wird.

    ich mußte das Plugin leider wieder entfernen, da sobald ich in meinem Forum ein Thema eröffnet hatte, ich eine error Meldung bekam. Ging ich zurück war das Forum wieder da und das Thema gepostet.

  • @SoftCreatR deine package.xml ist übrigens invalid :P

    Code
    <packagedescription><![CDATA[Allows you to ignore package updates to be displayed in the frontent.]]></packagedescription>n>


    Edit: Und was hälst du den von so einer CSS-Regel, dann musst du nicht schauen, ob das Ding offline ist, sondern hast immer den ersten Hinweis:

    CSS
    .userNotice > .info:first-of-type {
        display: none;
    }

    Grüße :P

  • So einfach, wie ihr euch das vorstellt, ist es halt nicht. Für die Paketverwaltung ist Update gleich Update (= neuere Version als die derzeit installierte) und es spielt keine Rolle, wer der Hersteller ist. Es hätte also genau so gut ein @VieCode, ein @Christopher Walz oder ein @DevLabor sein können, die ein "neues", kostenpflichtiges Paket in den Store gestellt hätten mit dem Bezeichner eines "alten" Pakets. Der Effekt wäre derselbe.

    Soll heißen: Es ist keine Maßnahme seitens WoltLab, um euch zum Erwerb des Updates zu zwingen. Es sind die Gegebenheiten, die es aktuell nicht anders zulassen und euch über Updates informieren, die ihr u.U. bezahlen müsst.

    Das leuchtet ja ein aber eine Prüfung auf Berechtigungen könnte es ja geben da man ja auch bei der Installation ein Fehler Meldung bekommt das man nicht das Recht hat.

  • Ich habe die Woltlabserver wieder angestellt und das Update durchlaufen lassen.
    Kam das Galerieupdate.
    Dann habe ich das Plugin 2 oder 3 Beiträge über mir installiert, den Cache geleert aber die Meldung wird trotzdem noch im Frontend angezeigt, irgendwas läuft bei mir falsch.
    @SoftCreatR magst du mal gucken? Wenn ja, schicke ich dir die Zugangsdaten?

  • Und ich soll jetzt raten, welche? ;)

    @All

    Mir ist gerade aufgefallen, dass ich das falsche Paket hochgeladen habe :D Das Template war völliger Mist, weshalb auch die Anmerkung von @Josh gar nicht so verkehrt war. Daher im Anhang die richtige Version :D Habs oben auch nochmal korrekt verlinkt.

    installiert; unverändert funktionsfähig

  • Und ich soll jetzt raten, welche?

    ich dachte ^^

    Ich habe eben Deine neue Version installiert, ein Testthema eröffnet und wieder eine error Meldung und zwar folgende :

    Display Spoiler

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!