Anmeldung schlägt fehl

  • Affected Version
    WoltLab Suite 5.4
    Affected App
    WoltLab Suite Forum

    Hallo,


    leider habe ich in meinem Forum das Problem das sich kein User mehr richtig anmelden kann. Sie bekommen keine Mail mit dem Aktivierungscode. Nun habe ich gesehen das in der Systemüberprüfung die Fehlermeldung PHP Anforderungen nicht erfüllt kommt. Weiterhin in der * Verwaltung - Protokoll - Emails * sind massig EMails als * vorübergehendes Protokoll * gekennzeichet. Da ich ehrlich gesagt nicht soviel Ahnung von der ganzen Sache habe stehe ich vor einen für mich nicht lösbaren Problem. Email Versand an einzelne User geht auch nicht, habe ich mit meinen eigenen Konto getestet. Woran könnte das liegen? Vielen Dank im voraus.


  • Die Meldung "PHP - Anforderungen nicht erfüllt" rührt daher, dass die Woltlab Suite 5.4 offiziell bis max. PHP 8.0.x kompatibel ist.

    Siehe: https://manual.woltlab.com/de/php-compatibility/


    Ob dies der Grund dafür ist, dass keine Mail mit Aktivierungscode ankommt, kann ich nicht sagen.


    Hast du die Möglichkeit auf PHP 8.0.x umzustellen, um dann zu testen ob die Aktivierungsmail empfangen wird?

    Gruß Markus


    WoltLab Suite 5.4.25

  • Hast du die Möglichkeit auf PHP 8.0.x umzustellen, um dann zu testen ob die Aktivierungsmail empfangen wird?

    wie mache ich das? 8) :saint: Habe es jetzt erstmal deaktiviert mit der Mail und alle manuell freigeschaltet. Es betraf alle seit Anfang Dezember.

  • Je nach Webhoster stehen über die Administration verschiedene PHP-Versionen zur Auswahl.

    Gruß Markus


    WoltLab Suite 5.4.25

  • Welche Versandmethode ist eingestellt ? PHP oder SMTP ?

    Auch wenn die Suite 5.4 ofiziell nur bis PHP 8.0 läuft, funktioniert die auch mit PHP 8.1 ohne Probleme.

    • New
    • Official Post

    Bei mir funktioniert der Versand via PHP stets einwandfrei.

    Das ist absolut nichtssagend, denn der Versand via PHP ist am Ende ein "Der Server macht irgendeine Magie" und je nach eingesetzter Magie ist das Ergebnis okay, mies oder unbrauchbar. In der Regel halt letzteres und nach außen ist alles nur "PHP".


    Deswegen ist SMTP allgemeingültig die bessere Wahl.

  • Und welchen Server muss ich da eintragen?

    Am besten bei Hosteurope nachfragen, wie die SMTP Server Einstellungen für dein Hosting sind.

    Am besten auch gleich die DNS Einträge der Domain prüfen, ob die Einträge für Dmarc, SPF und Dkim vorhanden sind um evtl. weitere Probleme bei der Mailzustellung vorzubeugen.

    Greetz

    Dark


    Mit dem Ende naht der Anfang mit etwas Neuen, um dann wieder zu sagen „Nach dem Update ist vor dem Update“. :S

    • New
    • Official Post

    Hallo,

    sind massig EMails als * vorübergehendes Protokoll * gekennzeichet

    als Tipp für alle Mitleser noch: Man kann den Fehler-Status anklicken und erhält dann einen Dialog mit Details. Beim PHP-Versand sind die vermutlich recht nichtssagend, bei SMTP aber sehr nützlich.

    Auch wenn die Suite 5.4 ofiziell nur bis PHP 8.0 läuft, funktioniert die auch mit PHP 8.1 ohne Probleme.

    Das stimmt nicht. Die Kernfunktionalität mag funktionieren, aber WoltLab Suite 5.4 ist nicht vollumfänglich („ohne Probleme“) mit PHP 8.1 kompatibel. Damit meine ich auch nicht „wir haben es nicht getestet“, sondern „es gibt tatsächlich Fehler“.

    Bei mir funktioniert der Versand via PHP stets einwandfrei.

    Neben der völlig korrekten Aussage von Alexander, ist der PHP-Versand konzeptionell fehlerbehaftet. Ich verweise auf diesen Beitrag von mir:


  • SMTP alles eingetragen. Verbindungstest ist erfolgreich, aber es gehen trotzdem keine Mails raus.. :(



    Status-Nachricht: strtolower(): Passing null to parameter #1 ($string) of type string is deprecated

    • New
    • Official Post

    Hallo,

    Status-Nachricht: strtolower(): Passing null to parameter #1 ($string) of type string is deprecated

    Dieser Fehler kann dadurch verursacht worden sein, dass du PHP 8.1 verwendest, WoltLab Suite 5.4 aber nicht mit PHP 8.1 kompatibel ist. Die Fehlermeldung ist nämlich neu mit PHP 8.1.


    Den genauen Ort der Fehlermeldung erhältst du, wenn du temporär den Debug-Modus aktivierst, dann eine E-Mail versendest und dann den Debug-Modus wieder deaktivierst. Dann solltest du direkt einen Eintrag im Fehlerprotokoll erhalten, sonst erst, wenn der Versand der E-Mail endgültig fehlgeschlagen ist (nach derzeit 14 Tagen).

    • New
    • Official Post

    Hallo,


    vielen Dank. Die Fehlermeldung zeigt, dass der Fehler irgendwo im „Emogrifier“ auftritt. Dieser ist dafür zuständig das CSS E-Mail-kompatibel zu machen.


    In diesem Fall ist es dann entweder notwendig auf WoltLab Suite 5.5 zu aktualisieren oder alternativ temporär zurück auf PHP 8.0 zu stellen, bis das Upgrade auf WoltLab Suite 5.5 durchgeführt wird.

  • WoltLab Suite 5.5 zu aktualisieren

    und daran scheiterts. Das traue ich mir nicht alleine zu, da ich Bedenken habe das wenn da was schief geht is alles hin. Hab die großen Updates immer von WoltLab machen lassen.. X/


    Also mal sehen was ich nun mache.. Danke trotzdem :thumbup:

    • New
    • Official Post

    Hallo,

    Hab die großen Updates immer von WoltLab machen lassen.. X/

    gerne machen wir ein Angebot zur Aktualisierung auf WoltLab Suite 5.5. Erstelle dazu ein Ticket oder schreib' uns eine E-Mail an woltlab@woltlab.com.


    Alternativ bietet sich womöglich auch ein Umzug in die WoltLab Cloud an? Dort kümmern wir uns um alle technischen Aspekte, inklusive Updates, Datensicherungen und einer passenden Serverkonfiguration für den E-Mail-Versand.

  • Alternativ bietet sich womöglich auch ein Umzug in die WoltLab Cloud an

    Naja das bekomme ich nicht finanziert. Is ja nur ein Hobby wo ab und zu welche paar Euro geben um wenigstens die Host Kosten zu decken. Aber das andere frage ich an. Danke dir

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!