Update von 3.1 auf 5.2

  • Affected Version
    WoltLab Suite 3.1
    Affected App
    WoltLab Suite Forum

    Hallo zusammen,

    habe die Lizenz soeben mit dem Kauf verlängert und möchte von 3.1 auf mindestens 5.2 oder höher Updaten.

    Serveradressen habe ich lt. Handbuch auch Installiert und es werden 12 erforderliche Updates angezeigt. Aber es Installiert sich nichts und es kommen zahlreiche Fehlermeldungen. Wie z.B. :

    Installierte Pakete

    Die folgenden installierten Pakete sind mit den zu installierenden Versionen nicht kompatibel

    • „jQuery CookieLib“ in Version „3.1.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Language Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Style Helper Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „WoltLab Suite Calendar“ in Version „3.1.21“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „WoltLab Suite Calendar: Event Threads“ in Version „3.1.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Foren-Box“ in Version „1.1.1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Community Bot 3“ in Version „3.1.14“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“

    Und andere Zahlreiche Fehlermeldungen von PlugIns. Müssen die alten erst Deinstalliert werden bevor das Forum Update Installiert werden kann? Sorry...habe leider nicht soo die Ahnung von der Materie.

    Wo habe ich da einen Fehler gemacht?

    Beste Grüße

    Norbert

  • Einige Plugins muss man leider deinstallieren.

    • „jQuery CookieLib“ in Version „3.1.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Language Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Style Helper Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“

    Diese 3 auf jeden fall. Sowie den Stile.

    Bei den anderen bin ich mir unsicher.

    MfG

  • Leider möchte Woltlab das Updatevorgehen mit PlugIns nicht ins Handbuch aufnehmen, so dass sich diese und ähnliche Fragen fortwährend wiederholen :rolleyes: .

    Du musst bei jedem PlugIn erstmal die letzte verfügbare Version installieren. Einige sind dann schon mit 5.2 kompatibel. Den Calender musst du auch in den neuen Version kaufen.

    Kommen dann immer noch Fehlermeldungen schaue auf die Seiten der Entwickler von den PlugIns. Wenn man das Plugin updaten kann, gibt es auch dort neue Paketserver die einzutragen sind. Oder man muss es deinstallieren und ggf. nach dem Upgrade wieder neu installieren. Solange die PlugIns keine Daten erfassen ist kein Problem.

    Liebe Grüße
    Susi

    Edited once, last by Susi (August 20, 2022 at 10:30 AM).

  • oha... komplizierter wie ich dachte. Vielen Dank für die Antworten.

    Also werde ich erstmal versuchen alle Plugins mit Fehlermeldungen versuchen Upzudaten. Wenn das mal gutgeht =O

  • Na ja, eine Sicherung musst du ohnehin vorher machen und sinnvoll wäre es das Upgrade erst einmal auf einer Testumgebung zu machen, also die gesamte Umgebung zu spiegeln/kopieren und das dort zu machen.

    Ach so, falls du alle PlugIns im PluginStore von Woltlab gekauft hast, dann reicht es natürlich diesen Paketserver für die neue Version einzutragen. Aber alles vorher upzudaten steht ja auch im Handbuch, daher denke ich mal, du hast auch woanders gekauft.

    Liebe Grüße
    Susi

  • Habe hier und woanders einige PlugIns gekauft.

    Daher wurde ich die Tage nach einem Kauf von einem PlugIn drauf hingeweisen das mein Forensystem veraltet ist (lief Fehlerfrei seit 2019...davor das alte BurningBoard über 10 Jahre) .

    Fehlermeldung bei der Installation "Benötigt das Paket „WoltLab Suite Core“ in Version „5.2.0 RC 1“ oder höher, es ist aber nur Version „3.1.29“ installiert.!

    Deswegen habe ich gestern die Linzenz verlängert bzw. gekauft.

    Ich weiss.... man sollte sich um Updates kümmern... aber es lief.

    Wenn ich das alles so lese dann kann ich mich Ärgern das ich die Lizenz und das PlugIn gekauft habe. Es wäre Ärgerlich wenn ich alles zerschiessen würde.

    Mit dem Spiegeln und Testen mit einem Clone Forum traue ich mir nicht zu.

  • Mit dem Spiegeln und Testen mit einem Clone Forum traue ich mir nicht zu

    Wenn du aber einen Fehler machst, oder etwas nicht klappt, sind alle deine Daten und dein Forum kaputt.

    Spiegeln/lokal testen ist nicht schwer, beziehungsweise zuvor ein Backup von Daten und Datenbank zu erstellen um in Notfall es zurück zu spielen.

    Projekte:

    XIVDATA - Eorzea Database

    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...

  • Also, wenn du eigenen Webspace hast, dann kannst du das System so spiegeln, sobald du eine Umgebung mit Subdomain angelegt hast

    Susi
    June 19, 2020 at 5:47 PM

    Wenn du irgendwomit Probleme hast, kannst du gerne nochmal fragen.

    Und ja, schon aus Sicherheitsgründen sind regelmäßige Updates und Upgrades wichtig! Das nützt nichts und die Software macht es einem inzwischen wirklich immer einfacher. Also, nur Mut.

    Liebe Grüße
    Susi

  • Der oder die Stile verfallen nicht, da kannst du bis WoltLab Suite 5.4 updaten:

    • „jQuery CookieLib“ in Version „3.1.0“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Language Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“
    • „Style Helper Package“ in Version „3.1.2“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.2.21“

    Für WoltLab Suite 5.5 ist ein kostenpflichtiges Update notwendig.

    Wäre aber einfacher wenn du das komplett deinstallierst und neu installierst wenn du fertig ist.

    Ich steh' zwischen großen Bergen auf 'nem Felsvorsprung
    Blick' auf eine zusammenbrechende Weltordnung
    Ich kam grad noch weg, schon
    Beginnt in jedem Winkel der Welt da draußen das Armageddon 😵‍💫

  • Wäre aber einfacher wenn du das komplett deinstallierst und neu installierst wenn du fertig ist.

    Dazu noch die Anmerkung, dass man vorher schauen sollte, ob man den Stil bearbeitet hat (eigenes CSS / SCSS, eigene Grafiken, etc.), die man dort ggf. noch sichern möchte. Ansonsten ist dem Vorschlag 100% zuzustimmen.

  • Sooo... Datenbank ist eine neue Erstellt. Mein Webhoster ist Allinkl und da konnte man die alte Datenbank einfach in die neue Kopieren.

    Die Dateien vom Forum habe ich via FTP gesichert und in einem neuen Verzeichnis geladen... das Problem ist nun das wenn ich die Testseite aufrufe immer wieder im Originalforum lande.... Verstehe ich nicht

  • Hallo Susi,

    ich befürchte ich bin zu blöd oder zu alt dafür. Wenn ich die Kopie nicht hinbekomme wie soll ich da noch mit dem Update klarkommen :)

    Also Datenbank und Daten sind kopiert. Die Daten in der Datenbank config und aplication ist geändert.
    Das originale Forum liegt z.B. bei http://www.12345.de/wbb5 . Die Kopie liegt bei http://www.12345.de/testforum/wbb5

    Ich bekomme nicht die Seite zum Testforum auf ...es wechselt immer wieder zum Originalen als ob da irgendwo eine Umleitung drin ist. Habe ich da einen Denkfehler?

  • Das ist aber keine Subdomain, sondern ein anderes Verzeichnis. Da musst du unbedingt auch die Cookiedomain ändern, falls du das nicht gemacht haben solltest.

    Liebe Grüße
    Susi

  • Die Cookiedomain habe ich auch angepasst

    Eigentlich war ich im glauben das die 1:1 Kopie nun steht und wollte mich heute mit den Updates beschäftigen. Konnte eben ganz kurz mich im Testforum einloggen. Aber direkt wieder raus und es kommt jedesmal die Fehlermeldung "Ihre Sitzung ist abgelaufen, bitte senden Sie das Formular erneut ab."

    Ich gebe es langsam auf... Danke das Ihr so Geduld mit mir habt :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!