Forum in Testinstalation

  • Affected Version
    WoltLab Suite 3.1

    Hallo zusammen,


    wie kann ich den Inhalt vom Forum, in mein Testforum hochladen, beide in wsc 3.1?

    Geht darum dass ich auf dem Testboard einige Sachen testen möchte, was mit leeren Testboard ja nciht so einfach geht wenn man schauen will wie sich etwas in Forum verhalten könnte.

    Zudem möchte ich dann das Update von wsc 3.1 auf das wsc 5.2 mit dem Testboard versuchen, bevor ich das in Forum mache und das dann zerschiesse. Mit leeren Testboard wird das Update auf 5.2 wohl nicht so schwierig werden aber geht ja darum das es als Testlauf für das Forum sein soll, wo einiges drin ist, sein soll.


    Habe in ACP bei Datenimport mal geschaut,a ber da kann man ja von anderen Versionen Iémportieren, nicht aber von wsc 3.1

    Gestern hate ich über FTP versucht, Inhalt vin Forum in Testboard zu packen, war nix, musste Testboard neu installieren.


    Kann mir da jemand weiterhelfen, eine Idee geben wie ich das machen könnte?

    Hoffe ich habe mich verständlich ausdrücken können, sonst fragt einfach nach.


    Liebe Grüsse

    Leandra

    Edited once, last by Leandra ().

  • Hallo Leandra,


    einfach eine leere neue Datenbank erstellen und dann den Datenbank-Dump vom Live Forum in diese neue DB einspielen.

    Damit hast Du eine exakte 1:1 Kopie.

    In die Config des Testforums trägst Du dann die Zugangsdaten dieser neuen DB ein und fertig.


    Ansonsten müssen natürlich auch die Pfade stimmen, also im Testforum entsprechend angepasst sein, inkl. Cookie-Domain.

    Gruß

    Jörg

    (Jaydee)

  • Dafür musst du dein Liveforum kopieren und nicht das WSC neu installieren. Das geht so:

    Serverumzug


    1. alle Files kopieren

    2. neue Datenbank anlegen und Daten dort aus der Sicherung deines Liveforums rein kopieren

    3. Datenbank Passwort anpassen von deinem Liveforum auf die Zugangsdaten der neuen Datenbank: confic.inc.php

    4. Cache im Filesystem löschen: /cache

    5. Pfade anpassen: PHPMyAdmin: wcf1_application oder im ACP unter: Konfiguration -> Apps verwalten - > hier die Domain anpassen auf deine Testdomain - im ACP muss man eine Reihenfolge einhalten, sonst wird man raus geworfen, deshalb mache ich es immer über die Datenbank

    6. Verzeichnisschutz für Zugang zur Testumgebung einrichten

    7. Im Forum anmelden und ein Testthema eröffnen - prüfen, dass es nicht in deinem Livesystem steht. Wenn das so ist, dann hat Punkt 3 nicht funktioniert

    8. Ich passe immer noch das Cookiepräfix an. Dann kommt da nichts durcheinander - Konfiguration -> Allgemein -> Präfix für Cookienamen

    Liebe Grüße
    Susi

  • einfach eine leere neue Datenbank erstellen und dann den Datenbank-Dump vom Live Forum in diese neue DB einspielen.

    Damit hast Du eine exakte 1:1 Kopie.


    Bist Du sicher, dass das fehlerfrei funktionieren kann? Bei unterschiedlichen Dateisystemen habe ich da so meine Zweifel.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Jup, das Filesystem muss mit, sonst fehlen auch zumindest die Dateianhänge u.ä. ein Teil des Styles usw.

    Liebe Grüße
    Susi

  • Nicht nur das, im Dateisystem einer neu angelegten Installation fehlen doch sämtliche von Plugins hinzugefügten Dateien. Nicht ohne Grund wird stets darauf hingewiesen, dass Dateisystem und DB auf dem gleichen Stand sein müssen.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Nicht ohne Grund wird stets darauf hingewiesen, dass Dateisystem und DB auf dem gleichen Stand sein müssen.

    DAs heisst also Forum und Testboard müssen alles gleich haben? Also alle Plugins/Stils in Testboard hochladen die auch im Forum sind?

    Betreffend Forenversion, da sind beide auf 3.1 also Forum wsc 3.1 und Testboard wsc 3.1


    Ich möchte einfach eine Kopie vom Forum auf dem Testboard haben, um da dann das Update auf wsc 5.2 zu probieren, kann ja schlecht im Forum ausprobieren ob es geht, dann ist es futsch wenn was schief läuft.

  • Dann mach es doch wie von Susi empfohlen. Eine identische Testumgebung ist die beste Voraussetzung dafür, Fehler und Probleme bei eigenen Anpassungen oder neuen Plugins frühzeitig zu entdecken. Was hilft es Dir, wenn etwas in einer "nackten" Grundinstallation funktioniert und in der im Liveforum gegebenen Konstellation dann doch Schwierigkeiten macht?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Nicht nur das, im Dateisystem einer neu angelegten Installation fehlen doch sämtliche von Plugins hinzugefügten Dateien.

    Jap, wenn man solche nutzt. Ehrlich gesagt habe ich noch nie versucht eine Datenbank meines Livesystems an eine frische Installation zu hängen. Es gibt Systeme, wo man das so macht und wo sich alles andere dann automatisch installiert, aber das ist hier nicht so.


    Ich möchte einfach eine Kopie vom Forum auf dem Testboard haben, um da dann das Update auf wsc 5.2 zu probieren, kann ja schlecht im Forum ausprobieren ob es geht, dann ist es futsch wenn was schief läuft.

    Genau, das ist auch richtig so :thumbup:. Und zu einer 1:1 Kopie gehört eben alles, was ich oben aufgeschrieben habe :) . Wenn du irgendwo Probleme hast, einfach nochmal melden.


    Vergiss auch nicht dir alles aufzuschreiben, was du nach und nach machst. Dann hast du für dein Liveupgrade einen guten Fahrplan.

    Liebe Grüße
    Susi

  • Also ich habe Backup gemacht vom Forum.

    Das Testboard hat noch nichts drin ausser die Core und Datenimport Dingens, Mitglieder ausser mir neimand, ansonsten ncihts erstellt.

    Dann habe ich das Backup der DAtenbank in Datenbank von Testboard einfügen wollen. Resultat Testboard futsch neu machen. Ich habe versucht über Importer wenigstens das von Testboard wbb4.1 rein zu kriegen, Resultzat Testboard 3.1 futsch neu machen.


    Es gäbe noch irgendwo ein Forum 4.1 habe Link dazu aber keinen Zugang mehr, komme da nicht mehr rein, kriege Fehlermeldung, versuchte dennoch datenbank in Testboard zu kriegen, Resultat kennen wir schon, Testboard futsch, neu machen.


    Ja ihr habt mir hier erklärt was ich tun kann, doch leider verstehe ich nur die Hälfte davon. Das Forum habe nicht ich von wbb 4.1 auf wsc 3.1 gestellt, weil ich mir das nicht zutraute. Hatte ganz tolle Hilfe die das für mich erledigte.

    Doch nun möchte ich, nachdem es ja heisst von 3.1 auf 5.2 sei nicht so schwer, das selber zu machen. Da ich aber nicht traue im Forum irgendwas auszuprobieren wollte ich das Zeug vom Forum, Packete, etc pp in Testboard bringen, was früher deutlich einfacher war, von Forum in Testbaord zu packen. Mit früher meine ich vor einigen Jahren, also nicht wbb 4 Zeiten, sondern deutlich weiter zurück.

  • Dann habe ich das Backup der DAtenbank in Datenbank von Testboard einfügen wollen. Resultat Testboard futsch neu machen.


    Hatte ich mich oben nicht verständlich genug ausgedrückt? Ich schrieb doch, dass das so nicht funktionieren wird.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Das war auch früher immer schon so. Files und Datenbank hat man immer schon beides gebraucht. Ich hatte auch schon ein wbb 2.

    Liebe Grüße
    Susi

  • Nochmal an Leandra: Verabschiede Dich bitte von der Idee, zu Testzwecken ein neues Forum aufsetzen/installieren zu wollen. Das ist für Dein Vorhaben nicht nötig. Du sollst anhand der von Susi erläuterten Schritte Sicherungen vom Dateisystem und der DB machen und diese dann als Testinstallation am gewünschten Ort wiederherstellen.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Hatte ich mich oben nicht verständlich genug ausgedrückt? Ich schrieb doch, dass das so nicht funktionieren wird.

    Ja hattest du, aber ich hatte das alles vorher versucht, bevor ich hier nachfragte.

    Ich gehe ja auch nicht gleich zum Elektromonteur, wenn Nachttischlampe nciht mehr brennt, dann schaue ich auch erst ob ich sie wieder zum brennen bringen kann.

  • Nochmal an Leandra: Verabschiede Dich bitte von der Idee, zu Testzwecken ein neues Forum aufsetzen/installieren zu wollen. Das ist für Dein Vorhaben nicht nötig. Du sollst anhand der von Susi erläuterten Schritte Sicherungen vom Dateisystem und der DB machen und diese dann als Testinstallation am gewünschten Ort wiederherstellen.

    Ok nun hats du mich falsch verstanden. Zu Testzwecken.... neee eben nicht einfach nur zu Testzwecken, sondern ganz einfach weil ich werde das nicht im Forum selber machen, weil ein kleiner falscher klick und das ganze Forum, gut 9 Jahre ist futsch. Darum das Wort testen, im Tesztforum, nicht weil ich einfach nur irgendwas testen will.


    Es geht schlicht und einfach darum das ich kein Profi bin, und nciht bereit bin irgendwas am Foruzm rumzubasteln, sondern das dort zu machen wo nicht viel passeiren kann, im Testboard. Bisher wurde immer geasgt man soll sich eine Tstinstallation machen, dort alles ausprobieren bevor man im Forum rumwurstelt und nun wo ich genau das machen will mit dem Update ist es nicht richtig, oder wie jetzt? KAnn sein das ich dich da falsch vertshe aber klingt für mich so wenn du sagst soll mich von der Idee verabschieden.

  • Ok nun hats du mich falsch verstanden.


    Nein, Du verstehst anscheinend die Bedeutung und Auswirkungen meiner Vorschläge nicht. Wenn Du eine Sicherung des Liveforums (Dateien und DB) erstellst und diese dann in einem anderen Ordner/Pfad wieder herstellst, hast Du eine zweite vom Liveforum völlig unabhängige Installation, in der Du Dich austoben kannst. Ich weiß langsam wirklich nicht mehr, wie ich es Dir noch anders erklären soll.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Bist Du sicher, dass das fehlerfrei funktionieren kann? Bei unterschiedlichen Dateisystemen habe ich da so meine Zweifel.

    Jepp, bin ich. Unterschiedliche Dateisysteme würde ich jetzt auf ein und demselben Server unter derselben (Haupt-)Domain nicht unbedingt unterstellen.

    Ob das Ganze jetzt FAT, NTFS oder sonstwie basiert ist, halte ich dabei aber für völlig unerheblich.

    Zumindest sind mir da in vielen Jahren bisher keinerlei Probleme bekannt.


    DAs heisst also Forum und Testboard müssen alles gleich haben?


    Wenn das Liveforum bereits komplexer eingerichtet ist, also Styles, Dateianhänge, Template-Änderungen und Plugins enthält, muss all das natürlich mit, klar.


    Du willst ja nicht "irgendein" Forum testen und dort spielen, sondern DEIN Forum. :)

    Insofern sollte die Umgebung natürlich schon identisch sein.

    Meine Antwort oben war nur auf den reinen Datenbank-Teil und Deine Frage bezogen

    Gruß

    Jörg

    (Jaydee)

  • Wenn das Liveforum bereits komplexer eingerichtet ist, also Styles, Dateianhänge, Template-Änderungen und Plugins enthält, muss all das natürlich mit, klar.


    Genau das meinte ich doch. Im konkreten Fall hat die TE ein neues Forum aufgesetzt. Das kann man doch nicht ohne Fehler mit einer DB aus einer umfangreicheren Installation verbinden.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Achso, das meinst Du. Nee klar, das ginge natürlich bzw. würde keinen Sinn machen. :)

    1:1 sollte es natürlich schon sein.


    Im "Normalfall" macht man es ja auch eher umgekehrt, also bevor man mit einem Forum an den Start geht, Testforum aufsetzen, einrichten und dann "den ganzen Quatsch" 1:1 auf das Liveforum übertragen.

    Da es in diesem Fall nicht geschehen war, führt der gleiche Weg nun halt anders herum.

    Gruß

    Jörg

    (Jaydee)

  • Du würdest das so machen, da Du über entsprechende Erfahrungen verfügst. Viele eher unbedarfte Benutzer hören erst hier im Forum von den Vorteilen einer Testinstallation, wenn ihre produktive Seite längst in Betrieb gegangen ist.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!