Videos direkt in Artikel einbinden (ohne YouTube oder ähnliches)

  • Affected Version
    WoltLab Suite 5.4

    Moin vom Deich,


    kann ich in einen Artikel ein Video direkt (ohne YouTube oder ähnliches) einbinden, so dass es mit Player angezeigt wird? Wenn ich es über die Medien mache, wird nur ein Link angezeigt, aber nicht das Video. Es gab wohl mal ein Plugin von SoftCreatR, aber wenn ich den Links in älteren Threads folge, lande ich im Nirvana. Das Seltsame ist, dass mir das Video im Artikel-bearbeiten-Fenster als Video angezeigt wird, im Artikel selbst aber nicht - mache ich irgendwas falsch?


    Wenn ich das Video auf den Server lade und per media-Code einbinde, klappt es auch nicht.


    Wie immer wäre ich für Hilfe sehr dankbar.

  • Ich habs per FTP hochgeladen und per HTML (Unsicheres HTML) so eingebunden:

    HTML
    <video controls style="width: 100%; height: auto;">
    <source src="https://www.domain.net/videos/video.mp4" type="video/mp4">
    Your browser does not support the video tag.
    </video>

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Hundiiiiiiiiii : Vielen Dank für Deinen Tipp, der klappt super. Allerdings ist ja eine unsichere html-Einbindung nicht unbedingt die optimale Lösung. Aber wenn es anders gar nicht machbar ist, werde ich gerne darauf zurück kommen.


    Throwholics: Dankeschön, die Galerie wäre ein Weg, der mir gefällt. Ich habe mir gerade eine Demo einrichten lassen, um das Vorgehen und Aussehen auszuprobieren, aber ich hänge und habe deshalb mal einen eigenen Thread dazu aufgemacht.

  • Der Code an sich ist sicher, da brauchst du dir keine Gedanken machen. "Unsicheres HTML" heißt das weil es potentiell möglich ist an der Stelle im Editor Schadecode einzufügen. Aber das tust du ja nicht.


    Das mit der Galerie geht natürlich auch.


    …die zum Teil ein knappes GB groß sind, von meinem Server mit Player in Artikel einzubinden.

    Ein direktes Einbinden kannst du machen wenn es um kurze Filme geht, aber im Bereich ein GB sollte sowas immer gestreamt werden. Dafür ist eine direkte Einbindung nicht geeignet.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Hundiiiiiiiiii : Dankeschön für Erklärung.


    Das mit dem direkten Einbinden wäre aber ideal; ich habe eine Seite, die vollkommen werbefrei ist - und das soll auch so bleiben. YouTube packt aber an den Anfang meiner Videos Werbung, was mich extremst stört.

  • Du kannst doch deinen Server als Medienanbieter eintragen.


    External Videofiles


    Regulärer Ausdruck


    Code
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[mM][oO][vV])).*
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[mM][pP][gG])).*
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[wW][mM][vV])).*
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[mM][pP]4)).*
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[mM]4[vV])).*
    (?P<ID>https?://[^/]*/.*\.(?<FORMAT>[wW][eE][bB][mM])).*

    HTML-Code-

    Code
    <div class="videoContainer ExternalVideofiles"><video controls="controls" preload="none" src="{$ID}" type="video/{$FORMAT}"></video></div>

    dann einfach https://deine URL/dein VideoFile.mp4

  • Wo kommt der obere Quellcode rein?

  • Danke,


    dann könnte ich Theoretisch, im Beitrag ein Video rauf laden und es als Link nur im Beitrag einfügen und dann wird es als Player angezeigt, sehe ich das richtig ?

  • Im Forum brauchst du das gar nicht. Du mußt nur die entsprechenden Dateiendungen in der Benutzergruppe einfügen: mp3, mp4 usw. Dann kannst du Videos hochladen und im Beitrag einfügen, die werden dann in einem Player abgespielt. Das geht seit 5.3 wenn ich mich richtig erinnere.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Ne braucht man nicht. 5.3 Standardinstallation ohne Plugins:




    Apple iPhone Insurance Made Simple - cls-design Demoforum
    Find My Device is normally turned on. Figure out how to ensure that your gadget can be found on the off chance that it gets lost how to track lost phone with…
    cls-design-demo.com

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • mipu : Vielen Dank für den Code; das funktioniert wunderbar.


    @alle hilfreichen Menschen: Ich hab' es aber inzwischen doch noch anders gelöst, über ein ein Abo bei Vimeo. Da werden die Videos dann gestreamt, aber sie sehen so aus, als wären sie auf meiner Seite, weil ich einstellen kann, wie der der Player aussieht. Bei Vimeo sind sie ausgeblendet, so dass man sie tatsächlich nur auf meiner Seite findet; woanders kann man sie auch nicht einbinden.

  • Seltsam, warum wird der Player bei mir nicht dargestellt


    Edit: Kann es sein, dass es nur Mobil mit dieser Methode funktioniert und nicht am Desktop?

  • Ich wollte dieses Plugin mal probieren, aber:


    Dieses Paket ist inkompatibel mit den folgenden, installierten Paketen:

    • „WoltLab Suite Core“ (com.woltlab.wcf)

    Suit Core installiert 5.4.4 - Wird es ein Update für dieses Plugin geben?

  • Frage:


    gibt es verschiedene einstellungen die man treffen muss, das jeder Link zu einem Vimeo Film angezeigt/ abgespielt werden kann im Forum.


    Habe Links zu verschiedenen Vimeo Filme gepostet die man dann abspielen kann und es gibt welche da steht "Es tut uns Leid, das Video gibt es gar nicht"

    Füge ich diesen Link in den Browser ein, funktioniert es.



    Kann mir wer helfen?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!