Upgrade von 3.0 auf 5.3

  • Affected Version
    WoltLab Suite 5.3

    Hallo,

    wir sind auf einer uralten Version 3.0 und wollen nun zum neusten upgraden. Beim Vorgehen nach folgendem Tutorial: https://manual.woltlab.com/de/…d-41-auf-woltlab-suite-30 würde ich vermuten, dass ich erst von 3.0 auf 3.1 auf 5.2 auf 5.3 upgraden muss.


    Beim Upgraden sagt mir die Forensoftware jedoch, dass einige Plugins nicht damit funktionieren, da sie offensichtlich nicht auf die neue Version updated sind. Wie gehe ich jetzt vor?

    Um die Forensoftware 5.3 zu installieren müssen die Plugins für 5.3 bereit sein. Diese lassen sich jedoch nicht aktualisieren, wenn ich nicht 5.3 installiert habe. Der Prozess ist also nicht möglich (oder mache ich etwas falsch?)

    Der einzige Weg der mir noch einfallen würde wäre, die genannten Plugins manuell zu deinstallieren und beim erfolgreichen Upgrade wieder zu reinstallieren. Mir ist jedoch wichtig, dass ich die Plugins nicht wieder von null aufsetzen muss, da einige sehr viele Konfigurationen beinhalten. Werden diese bei einer Reinstallation nach dem Forumupgrade wiederhergestellt oder muss ich sie neu einrichten?


    Liebe Grüße

    Demo

  • Werden diese bei einer Reinstallation nach dem Forumupgrade wiederhergestellt oder muss ich sie neu einrichten?


    Letzteres ist der Fall. Bei Deinstallation des alten Pakets und Neuinstallation in der aktuellen Version gehen auch alle eventuell im Plugin generierten Inhalte verloren.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Ich habe schon mehrfach bei Woltlab angeregt den Prozess mit PlugIns auch im Handbuch zu beschreiben, was sie aber scheinbar nicht wollen. Warum auch immer. So sollte man dich wohl besser an Woltlab verweisen, damit sie merken, wie oft diese Frage kommt ... na ja, dann kriegst du aber heute eventuell keine Antwort mehr ...


    Beim Upgraden sagt mir die Forensoftware jedoch, dass einige Plugins nicht damit funktionieren, da sie offensichtlich nicht auf die neue Version updated sind. Wie gehe ich jetzt vor?

    Du musst erst einmal schauen, ob es Versionen gibt, die für die jeweils höhere Version funktionieren. Das siehst du im PlugInStore oder auf den Plattformen der Entwickler.


    Wenn es eine Version für die Version gibt, dann ist es möglich, dass du die neue Version ebenso kaufen musst wie den Core. Das macht jeder Entwickler anders.


    Falls du sie kaufen musst, musst du das erst einmal machen und dann die entsprechenden Paketserver einrichten, wenn sie nicht aus dem PlugInStore sind. Wenn doch ist nichts zusätzlich einzurichten.


    Du kannst sie möglicherweise schon vor dem Upgrade installieren, aber nicht immer. Kannst du es nicht vorher installieren, musst du es deinstallieren, sonst kannst du nicht updaten.



    Werden diese bei einer Reinstallation nach dem Forumupgrade wiederhergestellt oder muss ich sie neu einrichten?

    Nein, bei den von mir genutzten PlugIns war das nicht der Fall. Da fragst du am besten den Entwickler des PlugIns, ob er dafür etwas anbietet oder ob es einen Umweg gibt oder du tatsächlich alles per Hand neu einstellen musst.


    Es empfiehlt sich daher das Upgrade vorher auf einer Testumgebung zu testen.

    Liebe Grüße
    Susi

    • Official Post

    Hallo,

    Um die Forensoftware 5.3 zu installieren müssen die Plugins für 5.3 bereit sein. Diese lassen sich jedoch nicht aktualisieren, wenn ich nicht 5.3 installiert habe. Der Prozess ist also nicht möglich (oder mache ich etwas falsch?)

    falls eine passende Version existiert und der Entwickler sich darum gekümmert hat, dass die notwendigen Update-Anweisungen enthalten sind, aktualisiert das Upgrade automatisch auch die Plugins. Unsere Anwendungen sind technisch letztlich auch Plugins (bzw. korrekterweise Pakete) und werden nicht speziell behandelt.

  • Kannst du es nicht vorher installieren, musst du es deinstallieren, sonst kannst du nicht updaten.

    Tim hat natürlich recht. Es gibt auch PlugIns, die sich mit dem Update aktualisieren, wenn du die nötigen Paketserver eingerichtet hast.

    Liebe Grüße
    Susi

    Edited once, last by Susi ().