Fehlermeldung bei Upgrade WBB4.1.21 auf WBB5.0.25

  • Hallo zusammen


    nach vielen Problemlosen Jahren muss unser Forum von WBB4.1 auf eine aktuelle Version migriert werden.


    Unser Hosting Anbieter wird in kürze eine servermigration vornehmen ab welcher nur noch PHP 7.2 uns höher angeboten wird.


    Aktuell läuft unser Forum seit 7 Jahren ohne grössere Probleme, eine aktuelle Sicherung aller Daten ist erstellt.


    Das Forum wurde im ACP in den Wartungsmodus versetzt und die Update Pakete welche vom Server vorgeschlagen wurden angestossen.


    Leider bricht der Update vorgang sofort ab mit der folgenden Fehlermeldung:


    Sun, 04 Apr 2021 14:13:46 +0000

    Message: Can't overwrite unknown table 'wcf1_page'

    File: /home/www/web366/html/wbb/wcf/lib/system/package/plugin/SQLPackageInstallationPlugin.class.php (74)

    PHP version: 7.1.1

    WCF version: 2.1.24 pl 3 (Typhoon)

    Request URI: /wbb/acp/index.php?install-package/&t=fbef6c8f137f27dce499c7d0862d4940b1c9521a&s=2b87037bc8f4a89f86b6cc0d1ac1b353eb616d75

    Referrer: https://www.rcpanzer.ch/wbb/ac…f86b6cc0d1ac1b353eb616d75

    User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0

    Information: ""

    Stacktrace:

    #0 /home/www/web366/html/wbb/wcf/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php(72): wcf\system\package\plugin\SQLPackageInstallationPlugin->install()

    #1 /home/www/web366/html/wbb/wcf/lib/system/package/PackageInstallationDispatcher.class.php(571): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update()

    #2 /home/www/web366/html/wbb/wcf/lib/system/package/PackageInstallationDispatcher.class.php(139): wcf\system\package\PackageInstallationDispatcher->executePIP(Array)

    #3 /home/www/web366/html/wbb/wcf/lib/acp/action/InstallPackageAction.class.php(73): wcf\system\package\PackageInstallationDispatcher->install('e2f7a2a9')

    #4 /home/www/web366/html/wbb/wcf/lib/action/AbstractDialogAction.class.php(70): wcf\acp\action\InstallPackageAction->stepInstall()

    #5 /home/www/web366/html/wbb/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AbstractDialogAction->execute()

    #6 /home/www/web366/html/wbb/wcf/lib/system/request/Request.class.php(58): wcf\action\AbstractAction->__run()


    Wenn ich es richtig verstehe hat das Update Paket ein Problem mit einem Schreibrecht aber ich kann nicht ermitteln um welches Recht es geht.


    Das Forum wurde vorgängig bereinigt, sprich alle PlugIn von Drittanbieter entfernt.


    Stehe gerade etwas vor der Wand und blicke gerade nicht durch was hier fehlt.


    Wäre natürlich sehr Dankbar für heure Hilfe da ich das ganze Forum auf die aktuelle Version 5.3 migrieren möchte.


    Der Zeitplan sieht vor dies bis Mitte April durchgeführt zu haben.


    Besten Dank im Voraus


  • Laut Fehlermeldung wurde bereits ein Upgrade-Vorgang gestartet, der nach kurzer Zeit fehlschlug, davor aber noch neue Tabellen in der Datenbank angelegt hatte, die er jetzt nicht mehr entfernen kann.


    Spiele ein Backup von vor dem ersten Versuch ein und versuche es dann erneut.

  • Hallo Black Rider


    besten Dank für die schnelle Antwort.


    Ich habe seit über drei Jahren kein Update durchgeführt, das letzte war der Umstieg auf die aktuelle Version 4.1.21 welche bei dessen Freigabe ausgeführt wurde.


    Daher habe ich auch kein Backup zur Verfügung welches ich einspielen könnte, das Backup welches ich heute erstellt habe entspricht ja dem gleichen Zustand da seither das Forum im Wartungsmodus war.


    Zum einen war lange Zeit auf dem Server keine aktuelle Version des PHP zur Verfügung zum anderen war das Forum ohne Probleme in Betrieb.

    Gibt es ein Verzeichnis auf dem Server in welchem Update Pakete abelegt werden welche ich löschen müsste?


    Ursprünglich wurde das Forum mit der Version 3.1.7 aufgesetzt und immer wieder im Rahmen des Upgrade Vertrag hochgerüstet.


    Könnte das Problem vom aktuellen installierten Framwork 2.1.24 pl 3 kommen dieses wurde Ende März installiert, hatte aber keinen Abbruch bei dessen Installation.



    Zumindest kommt die Fehlermeldung während der Installation des neuen Framework


  • Schau doch mal in der aktuellen Installation, bevor du ein Upgrade startest, ob die Tabelle wcf1_page schon vorhanden ist.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Hallo Lucas


    Ja in der aktuellen Datenbank gibt es eine Tabelle wcf1_page, sollte es diese in einer WBB4.1 Version noch nicht geben?

  • Ich bin mir ziemlich sicher das es die da nicht gab. Hast du mal ein CMS installiert gehabt? Fürs 4er gab es da ja einige, eventuell ist da mal was hängen geblieben. Was steht denn in der Tabelle drin?

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Hallo LucasBox


    Hier einmal die Struktur und den Inhalt der Tabelle wcf1_page



    Ich hatte einige PlugIn in diesem Forum installiert gehabt welche ich aber alle für das Upgrade deinstalliert habe.


    Ich hatte den Style WBB Notorious Gray installiert welchen wir eingesetzt haben, auch dieser ist deinstalliert derzeit ist der WBB Style aktiv.


    Gestern habe ich mal zum Versuch eine Neuinstallation des WBB 5.0.25 auf dem Hosting Server mit einer neuen Datenbank durchgeführt und mit dem Importer die Datenbank und Daten des WBB 4.1 ausgelöst, das hat mit Ausnahme der Galerie alles funktioniert.


    Bei der Galerie ist es zu einem Gateway Timeout gekommen beim Importieren der Bilder, somit hat das noch nicht vollständig funktioniert.


    Benutzer / Forum und Kalender waren aber vollständig und korrekt importiert worden.


    Jetzt bin ich noch nicht am Ende der Reise aber immerhin schon einmal etwas näher am Ziel.


    Ich denke am besten wird eine Neuinstallation einer WBB V5.x Version sein, ich habe eine Vertragsverlängerung gemacht und könnte daher auch gleich die aktuelle Version installieren.


    Wobei ich noch keine gesicherte Information habe ob ich da auch ohne Probleme die Daten aus der aktuellen Version WBB 4.1 importieren kann.


    Wenn ich hier mit der Suchfunktion nachgesehen habe, so habe ich alle möglichen Aussagen gefunden.


    Ich habe die Pakete Forum/Galerie und Calender im Einsatz zu welchen ich natürlich auch gerne die Daten übernehmen möchte.


    Im gesamten sind 11685 Bilder in der Galerie, von welchen ich selber ca. 50% eingestellt haben und diese auch für eine Neuinstallation zur Verfügung hätte.

    Die restlichen 50% sind Bilder der Benutzer welche natürlich nicht so einfach wieder eingepflegt werden können.

  • Sieht aus wie die Tabelle aus WoltLab Suite:



    Die stammt also von einem abgebrochenen Update. Vermutlich wurde die Datenbank beim Einspielen des Backups nicht vorher geleert? So wurden die angelegten Tabellen nicht entfernt und sind immer noch da. Du kannst die Tabelle also löschen und ein erneuten Versuch starten würde ich sagen.


    Und dann schauen wo es wirklich hängt.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Hallo zusammen


    ich habe heute eine Neuinstallation des Forum mit der aktuellen Version 5.3.5 sowie der Gallery und Calendar vorgenommen und alle bestehenden Daten aus dem laufenden Forum mit der Version 4.1.21 importiert.


    Das hat super Funktioniert, alle Daten konnten erfolgreich importiert werden.


    Einzig das aktualisieren der vielen Bilder in der Galerie ist abgebrochen, hier werde ich nun meine Bilder entfernen danach sind es 70% weniger welche ich aktualisieren muss.


    Kommende Woche werde ich das Finale Update durchführen damit ich das Forum unter der gleichen Adresse wie bis jetzt betreiben kann.


    Ich denke dies ist die beste Variante so werde ich den unnötigen Balast aus den Version 3.1.7 - 4.1.21 auch gleich los.


    Ich danke euch für eure Unterstützung bei den Fehlermeldungen und freue mich das Forum hoffentlich viele weitere Jahre betreiben zu können.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!