PHP 8 - Bereits unterstützt?

    • Official Post

    Ich sehe keinen trifftigen Grund, um um jeden Preis als "early adopter" auf PHP8 zu schwenken. Bis jetzt ist der Performance-Vorteil überschaubar und ImageMagick ist weiterhin nicht offiziell für PHP8 verfügbar. Selbst wir verwenden aktiv noch PHP 7.4, weil uns Stabilität wichtiger ist, als "das Neuste vom Neusten" einzusetzen. Gerade die ersten Versionen einer neuen PHP-Major würde ich eher mit etwas Vorsicht genießen.


    Grundsätzlich ist die WoltLab Suite 5.3 schon seit Monaten mit PHP 8 kompatibel, wir garantieren es aber zum aktuellen Zeitpunkt nicht.

  • Da die Frage wohl noch offen ist, würde ich Mal auf PHPUnit verweisen um sein Sachen zu testen, natürlich müsste man dann Tests anlegen ;) .

    Ansonsten, zweiten vHost anlegen, PHP8 dort aktivieren und austesten.

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


  • Danke, ich werde das grüne Licht von Woltlab abwarten und wenn es dann soweit ist meine eigene Scripte und phpmyadmin auf php8 testen (phpmyadmin in ubuntu 20.01 ist noch ne ältere Version in der repo, werde hier dann manuell updaten).

    ┌П┐(◉_◉)┌П┐

  • Bei mir läuft es rund mit PHP8. Habe eine library auch selbst patchen müssen 😅

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Welche denn? :)


    TS3 PHP Framework: https://github.com/planetteamspeak/ts3phpframework


    Bis ich dann eine Woche später festgestellt hatte, dass die das schon auf Github hatten :D


    Und ansonsten hing nur Adminer hinterher, da hatte Tim ja ein PR gemacht und ne abfuhr erhalten https://github.com/vrana/adminer/pull/401 :D


    Aber ich find das trotzdem interessant, wo man Tim noch überall sieht^^

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

    Edited once, last by Xopez ().

  • Und ansonsten hing nur Adminer hinterher, da hatte Tim ja ein PR gemacht und ne abfuhr erhalten https://github.com/vrana/adminer/pull/401 :D

    Wobei ich dort schön folgenden Kommentar schön finde:

    Quote

    It would be nice to drop support for older versions of PHP at some point. PHP7 is now five years old.

    Prinzipiell sollte man m.M.n. veraltete PHP-Versionen sowieso nicht mehr unterstützen. Also aktuell nur noch PHP 7.3+ unterstützen. Aber die Diskussion hatten wir ja schon öfters hier im Forum :D

  • So Leute nach einigen Tests in einer VM habe ich jetzt doch schon PHP8 im Einsatz, scheint soweit alles sauber zu funktionieren sogar die eigenen PHP Scripte laufen nach einem kleinen Composer Update :D


    Habe jedoch in der FPM.log folgende Einträge:

    Alles läuft jedoch sauber und schon einige Zeit jetzt keine Notice mehr in der Log, liegt das eventuell an APC Cache?

    Oder an was könnte das liegen? Ignorieren? Oder ist das nur ein Hinweis wenn der Parent Process neu spawnt?

    EDIT: Seit ner Stunde keine Notice mehr, denke das läuft, habe alle Werte der Conf von php7.4 übernommen, läuft rund, aber was Geschwindigkeit angeht merke ich relativ wenig :D


    EDIT: Hab jetzt kein PHP7.4 im gebrauch, wie kann man dies jetzt temporär deaktivieren, sodass es keine Resourcen mehr verbraucht?

    ┌П┐(◉_◉)┌П┐

    Edited 2 times, last by TeRRible__KHONS ().

  • EDIT: Hab jetzt kein PHP7.4 im gebrauch, wie kann man dies jetzt temporär deaktivieren, sodass es keine Resourcen mehr verbraucht?

    sudo service php7.4-fpm stop


    Falls du noch den autostart deaktivieren willst, sollte das gehen:

    sudo systemctl disable php7.4-fpm

    und falls du den wieder aktieren möchtest machst du ein enable statt disable.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Super danke dir, mache ich morgen muss jetzt pennen, in paar Stunden muss ich raus :D


    PS. Die NOTICE oben kann ich ignorieren oder? Kam bisher auch nicht wieder.

    ┌П┐(◉_◉)┌П┐

  • PS. Die NOTICE oben kann ich ignorieren oder? Kam bisher auch nicht wieder.

    Natürlich, das ist ja nur ein Hinweis. Erst bei Warn oder mehr sollte man aktiv werden.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Verschwinden die Prozesse von 7.4 nicht irgendwann automatisch wenn diese nicht mehr gebraucht werden? Eigentlich verbrauchen die wie ich sehe kaum resouren.

    ┌П┐(◉_◉)┌П┐

  • Xopez


    Mir ist gerade aufgefallen dass die Mails im Forum nicht versendet werden, weder Benachrichtiungen noch Kontaktformular.

    SMTP-Test im ACP war jedoch erfolgreich, hast das Problem auch?


    Keine Fehlermeldung im ACP.


    PS. Mail-Server ist in Ordnung weil alle anderen Mails kommen erfolgreich an.


    Weiß nicht ob das was damit zu tun hat:

    Code
    2020/12/15 20:50:42 [error] 6966#6966: *19313 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 92.72.177.217, server: community.domain.tld, request: "POST /background-queue-perform/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php8.0-fpm-community.domain.tld.sock", host: "community.domain.tld", referrer: "https://community.domain.tld/thread/13940-wo-XXX-testen-lassen/"

    ┌П┐(◉_◉)┌П┐

  • Warte, ich probier mal mail aus.


    EDIT:

    Geht bei mir zumindest mal via Kontaktformular und "Kennwort vergessen"-Funktion:



    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • SMTP-Test im ACP war jedoch erfolgreich, hast das Problem auch?

    Der SMTP-Test ist nur rudimentär. Auch wenn der sagt "ok", kann es sein, dass du keine E-Mails versenden kannst.


    upstream timed out

    Dein Upstream (vermutlich dein PHP-FPM, außer du hast noch einen Webserver als Proxy) braucht für den Request zu lange.

    Eventuell ist auch proxy_read_timeout zu niedrig eingestellt.


    Soweit ich weiß, kümmert sich die "Background Queue" bzw. "background-queue-perform" um den Versand von E-Mails. (RE: Fehler mit den sofortigen E-Mail Benachrichtigungen ?)

  • Die Queue ist aber leer:

    https://domain.tld/background-queue-perform => 0


    Ich vermute hier ein generelles Problem mit php8 und woltlab beim versenden der Mails, hab eben mit phpmailer in meinem eigenen Script getestet dort funktionierts jedenfalls noch ohne Probleme.


    Außer den Update auf php 8 wurde nichts in den Configs geändert.


    Xopez Mist :/ an was kann das jetzt nur liegen ?


    Woodmen Die error war jetzt auch nur einmalig.*


    EDIT: Sobald ich wieder auf PHP 7.4.13 stelle werden die Mails wieder erfolgreich versendet, ich habe mail in den disable_functions, das sollte sich jedoch nur auf phpmail beziehen hat sich hier was vielleicht geändert in PHP8? <= (Daran liegt es nicht eben getestet) Liegt wohl an PHP8 dann funktioniert nicht, mit 7.4.13 funktionierts jedoch wieder :/


    Ist bestimmt ein Konflikt mit PHP8 und dem im Woltlab verbauten Mailer? Alexander Ebert


    EDIT: Mein FPM-Pool falls es hierdran liegen sollte:

    EDIT: Komisch es scheint an meinem POOL oder so zu liegen, hab es jetzt aus der VM raus probiert, dort funktioniert alles sofort :/

    ┌П┐(◉_◉)┌П┐

    Edited 5 times, last by TeRRible__KHONS ().

  • Also hab mir jetzt nochmals alles genau angeschaut und bin echt ratlos wieso es nicht geht :(


    Auf der VM läufts, in Produktion nicht, irgendwo muss der haken sein aber wo ? :/


    Hab nirgendwo eine Fehlermeldung oder sonst irgendwas? :(

    ┌П┐(◉_◉)┌П┐

  • Bei mir läuft der Mailversand.


    Habe heute den ganzen Tag schon Benachrichtigungen über neue Beiträge bekommen und ich habe es auch mit dem Kontaktformular getestet. Gestern Abend hat sich auch ein neuer User angemeldet und hat sich auch freischalten können.


    Bei mir laufen die Mails aber über SMTP und dem Port 587.

    Mir ist zumindest noch nichts negatives aufgefallen seit ich gestern gegen 11:00 Uhr umgestellt habe.

  • Es läuft bei ihm nun auch. Er hatte ein veraltetes Mailtemplate. ungefähr ab da: RE: PHP8 - Mailversand

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!