Server-Deaktivierung wird nicht beachtet

  • Affected Version
    WoltLab Suite 5.3

    Ich habe den Server http://store.woltlab.com/5.3/ deaktiviert und danach vorsorglich den Cache geleert. Das WSC zeigt sich jedoch unbeeindruckt, zählt nach der Update-Suche weiterhin Pakete auf diesem Server und listet diese in der Paket-Suche auch auf. Lediglich die Installation aus "offiziellen Paketquellen" ist hierdurch nicht möglich.

  • Ich hoffe, es funktioniert dann trotzdem noch Pakete per Paket-Server zu installieren, die man nicht im PluginStore gekauft hat, die man dort aber kaufen kann. Denn genau dafür musste ich bei bisherigen Updates den Woltlab Paketserver vom PlugIn Store zeitweise deaktivieren.

    Liebe Grüße
    Susi

  • Mir gefällt diese Zentralisierung auf WoltLab generell überhaupt nicht. 🤷


    Erhöht halt die Abhängigkeit und damit den Profit für die WoltLab GmbH.

    • Official Post

    Ich hoffe, es funktioniert dann trotzdem noch Pakete per Paket-Server zu installieren, die man nicht im PluginStore gekauft hat, die man dort aber kaufen kann. Denn genau dafür musste ich bei bisherigen Updates den Woltlab Paketserver vom PlugIn Store zeitweise deaktivieren.

    Tipp: Es gibt den so genannten Authentifizierungs-Code. Wenn dieser in der Konfiguration hinterlegt ist, kann das System erkennen, ob ein Plugin im Plugin-Store gekauft wurde oder nicht und bietet dann entsprechend auch keine Updates über den Paket-Server des Stores an.

    Siehe: Authentifizierungs-Code und Logindaten Paket-Server

  • Danke, aber der ist eingetragen :/ . Da muss ich beim nächsten Update mal genauer drauf achten.

    Liebe Grüße
    Susi

  • Es gibt den so genannten Authentifizierungs-Code. Wenn dieser in der Konfiguration hinterlegt ist, kann das System erkennen, ob ein Plugin im Plugin-Store gekauft wurde oder nicht und bietet dann entsprechend auch keine Updates über den Paket-Server des Stores an.

    Dies scheint dann aber nicht immer richtig zu funktionieren (jdf. in der Version 5.2).


    Mir gefällt diese Zentralisierung auf WoltLab generell überhaupt nicht. 🤷

    Dem kann ich mir nur anschließen.


    Dafür wird dann hoffentlich einer eine Erweiterung schreiben, damit dies wieder möglich ist.

  • Dies scheint dann aber nicht immer richtig zu funktionieren (jdf. in der Version 5.2).

    Das kann ich bestätigen. Ich habe bei Kunden immer wieder Probleme damit. Deshalb sehe ich diese Änderung auch als kritisch. Klar, ich kann das immer noch per Datenbank direkt machen, toll finde ich es dennoch nicht.

  • Denkt ihr diese Probleme kann Woltlab nicht bereinigen? Würde das sauber funktionieren wäre es ja kein Drama oder was spricht dann noch dagegen?

    Liebe Grüße
    Susi

    • Official Post

    Aus unserer Sicht ist die Abschaltung der offiziellen Paket-Server nicht sinnvoll. Beim Paket-Server für die offiziellen WoltLab-Pakete erklärt sich das wohl von selbst, uns ist es wichtig, dass Fehlerbehebungs- und natürlich vor allem Sicherheitsupdates zeitnah eingespielt werden. Das Gleiche gilt grundsätzlich für die Pakete aus dem Plugin-Store und selbst wenn man keine Pakete von diesem Paket-Server beziehen möchte, ist er trotzdem relevant, da über diesen Paket-Server zukünftig die Paket-Signaturen für die Drittanbieter-Plugins ausgeliefert werden sollen (siehe https://github.com/WoltLab/WCF/issues/3419).


    Dies scheint dann aber nicht immer richtig zu funktionieren (jdf. in der Version 5.2).

    Wäre mir neu, dass es hierbei ein Problem gibt. Mach doch bitte einen Bugreport dazu auf, wenn du das reproduzieren kannst.

    • Official Post

    Nach den uns vorliegenden Zahlen ist es doch eher selten (<1%), dass die Software ohne WoltLab-Konto bzw. ohne Lizenz genutzt wird. Wenn das wirklich in der Praxis ein Problem werden sollte, lässt sich das System auch leicht anpassen (kleinere Änderung an unserem API-Endpoint notwendig), dass man einen generischen Authentifizierungs-Code hinterlegen kann, wodurch das System erkennt, dass kein Konto bzw. keine Lizenz vorhanden ist.

  • Na ja, ich denke, bisher weiß eben kaum jemand, dass man das CMS auch ohne Lizenz nutzen kann. Nur diejenigen, die schon eine haben wissen das. Ich nutze das CMS in einer weiteren Installation z.B. für eine kleine Webseite. Dort nutze ich nur sehr wenige Plugins. Ich warte für diese Umgebung eigentlich auf eine Funktion in einem PlugIn, das ich dann kaufen würde. Und schon ist man Kunde und hat dennoch auf einer weiteren Umgebung das Problem, weil ich die gekaufte Forenlizenz da ja nicht dort nutze und auch sonst keine WoltlabApp.

    Liebe Grüße
    Susi

  • Wenn etwas nicht korrekt funktioniert, bitte ich um eine entsprechende Rückmeldung, damit wir uns damit befassen und das Problem lösen können.

    Durchaus verständlich. In diesem Moment habe ich allerdings dann andere Probleme, denn ich kann im Normalfall dann nicht längere Zeit darauf warten, dass ein Debugging stattfindet und der Fehler behoben werden kann.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!