Nach Domain Umzug funktionieren die Datei anhänge nicht mehr

  • Affected Version
    WoltLab Suite 3.1

    Hallo Leute,


    Wir sind heute mit unserer Seite von Strato zu Netcup gewechselt mit Domain Umzug und so weiter :)

    Es hat auch alles soweit funktioniert das einzige Problem das ich zur Zeit habe ist das die Dateianhänge nicht mehr funktionieren :(


    Ich habe die Datein alle mit FileZilla in Binär Heruntergeladen und danach auf dem neuen Webspace auch in Binär hochgeladen sowie auch alle Anzeigen Aktualliesiert und den Cache geleert aber keine verbesserung deswegen habe ich nun alle Dateianhänge gelöscht und wollte die wichtigsten Bilder neu hochladen aber die Bilder werden irgendwie denoch nicht angezeigt :(


    Statdessen kommt nun dieser fehler:

    Requested URL
    /acp/index.php?attachment/1042-dtm-banner-dubai-png/
    Referrer
    https://simracingverein.de/acp/index.php?attachment-list/
    Error Message
    Location of file is not set or invalid
    Type
    wcf\system\exception\SystemException
    File (Line)
    /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/util/FileReader.class.php (73)
    Stacktrace
    1. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AttachmentPage.class.php (154): wcf\util\FileReader->__construct(…)
    2. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AbstractPage.class.php (291): wcf\page\AttachmentPage->readData(…)
    3. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AttachmentPage.class.php (166): wcf\page\AbstractPage->show(…)
    4. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AbstractPage.class.php (114): wcf\page\AttachmentPage->show(…)
    5. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    6. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    7. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Leider ferstehe ich diesen fehler nicht :/


    Ich sehe nur das anscheined die datei nicht hochgeladen wurde im verzeichnis wo sie liegen soll :/ wie kann ich den diesen fehler beheben ? den egal welches Bild ich hochlade es kommt immer wieder der selbe fehler :(


    Vielen Dank für die Hilfe schon mal :)


    Lg Stefan

  • Oh shit ich habe das ganze im Falschen Thread geschrieben kann das jemand in den Bereich für das 4.1 WBB verschieben ?


    Lg Stefan

  • die Dateianhänge müssen bei dir in images/dateianhaenge liegen, du hast wohl einen anderen Pfad angegeben.

    evtl nicht schreibbar/lesbar der Ordner.

  • Hallo :)


    Ja alle anzeigen wurden Aktuallisiert.


    Ich habe jetzt auch mal die PHP Version auf die 7.2 umgestellt aber leider der selbe fehler.

    Requested URL
    /attachment/1023-dtm-banner-dubai-png/
    Referrer
    https://simracingverein.de/calendar/event/361-dubai-gp-termin-7/
    Error Message
    Location of file is not set or invalid
    Type
    wcf\system\exception\SystemException
    File (Line)
    /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/util/FileReader.class.php (73)
    Stacktrace
    1. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AttachmentPage.class.php (154): wcf\util\FileReader->__construct(…)
    2. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AbstractPage.class.php (291): wcf\page\AttachmentPage->readData(…)
    3. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AttachmentPage.class.php (166): wcf\page\AbstractPage->show(…)
    4. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/page/AbstractPage.class.php (114): wcf\page\AttachmentPage->show(…)
    5. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    6. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    7. /var/www/vhosts/hosting142981.a2e7f.netcup.net/httpdocs/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Lg Stefan

  • Ich weiß nicht was du hast, aber bei mir wird der Anhang 1033-dtm-banner-dubai-png geladen. Die einzige Fehlermeldung die ich erhalte ist der Statuscode 400 von Google Fonts.


    Der Anhang 1023-dtm-banner-dubai-png/ ist physisch auf dem Webspace nicht vorhanden.

    Da scheint beim Import etwas schief gelaufen zu sein.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!