gelöst - Fehler beim Laden des PDF-Dokuments. / Anhang nicht zugreifbar / Umzugsproblem?

  • Affected Version
    WoltLab Suite 3.1

    Guten Tag,


    ich habe ein Problem mit alten Anhängen und bin mir unsicher,
    ob es ein Folgeproblem des Umzuges des Forums von vor 2 Monaten auf einen neuen Provider ist.
    der Umzug selber ging reibungslos, die Forumsbeiträge sind auch alle zu sehen.,

    ob ich damals zum Testen einen Anhang aufgerufen habe, weis ich nicht mehr.


    Problem: wenn ich auf Anhänge klicke, bekomme ich entweder den Hinweis "Fehler beim Laden des PDF-Dokuments."

    oder eine umfangreiche Fehlermeldung (siehe unten).

    Es gibt zwar das benannte Verzeichnis /home/www/c42-berlin.de/attachments

    Code
    \/home\/www\/c42-berlin.de\/attachments\

    Aber ein Unterverzeichnis 31 gibt es nicht

    Habe auf dem alten Server geschaut, da gab es das Verzeichnis 31 auch nicht

    Code
    \/home\/www\/c42-berlin.de\/attachments\/31\/40-31fcec70a5a6a6e0fb38f90ebed05b45cb7b0526"

    Wie wird denn der Zusammenhang zwischen dem Link / Anhang in einem Post
    und dem dazugehörigen Anhang hergestellt?

    Neue Anhänge funktionieren, ich kann also neu was posten,
    der Anhang wird gespeichert und kann abgerufen werden.

    Was habe ich für einen Ansatz, wo ich suchen kann?


    Requested URL
    /index.php?attachment/40-skizze-2014-20140613-151246-pdf/
    Referrer
    https://c42-berlin.de/forum/index.php?thread/10-entw%C3%A4sserungsplan-von-1909/
    Error Message
    Location of file is not set or invalid
    Type
    wcf\system\exception\SystemException
    File (Line)
    /home/www/c42-berlin.de/lib/util/FileReader.class.php (73)
    Stacktrace
    1. /home/www/c42-berlin.de/lib/page/AttachmentPage.class.php (154): wcf\util\FileReader->__construct(…)
    2. /home/www/c42-berlin.de/lib/page/AbstractPage.class.php (291): wcf\page\AttachmentPage->readData(…)
    3. /home/www/c42-berlin.de/lib/page/AttachmentPage.class.php (166): wcf\page\AbstractPage->show(…)
    4. /home/www/c42-berlin.de/lib/page/AbstractPage.class.php (114): wcf\page\AttachmentPage->show(…)
    5. /home/www/c42-berlin.de/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    6. /home/www/c42-berlin.de/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    7. /home/www/c42-berlin.de/index.php (9): wcf\system\request\RequestHandler->handle(…)
  • In welchem Transfermodus wurde anlässlich des Umzugs das Dateisystem gesichert und wieder hergestellt?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Ups: weis ich nicht . Was ist der Transfer Modus?

    Meiner Erinnerung: ich habe einen Dump der Datenbank gemacht
    und alle Dateien kopiert.
    Ich hatte eine Anleitung bei Woltlab gefunden und die abgearbeitet
    Serverumzug

    Der Zustand "Wartungsmodus" .. keine Erinnerung, das ich den gesetzt habe.
    das Forum wird nur von 1-2 Personen genutzt. Kann sein, das ich das
    nicht extra gemacht habe

  • Stellen Sie sicher, dass die Dateien im Binärmodus heruntergeladen werden, da diese andernfalls zerstört werden.


    Das könnte der entscheidende Punkt gewesen sein.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Transfermodus: .. oder bezieht sich das auf das Herunter laden?
    Mit FileZilla / FTP - Dateien kopiert (auf einen Windows-Rechner)
    und dann wieder hoch kopiert

  • ?? Bei FileZilla sehe ich keinen Punkt, wo ich was einstellen könnte
    4 Wochen habe ich den alten Server noch
    könnte also noch was nachholen.
    Alter Server ist Strato

  • Man kann im Filezilla zwischen verschiedenen Transfermodi wählen. Binär muss meines Wissens explizit aktiviert werden.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Gefunden. Bei Einstellungen kann ich was ändern

    FileZilla orientiert sich an der Dateiendung, ob Ascii oder binär.
    In dem Fall haben die Dateien keine Endung. Dann geht es schief


  • Hurra

    Das ist die Lösung

    Ich danke ganz herzlich für die schnelle und erfolgreiche Hilfe.


    Ursache des Problem: FileZilla hätte gerne eine Endung,
    ohne Endung wird automatisch ASCII gemacht

  • Hattest Du noch Zugriff auf die alte Installation?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!