Banner zentral für alle Stile nutzen?

  • Affected Version
    WoltLab Suite 5.2

    Ich frage mich, ob es möglich ist, ein Banner zentral auf dem Server zu platzieren, welches dann von allen Stilen genutzt wird.


    Aktuell nutze ich 17 Stilvariationen und bisher habe ich in jedem Stil das Banner manuell getauscht, wenn z.B. Weihnachten oder Halloween war. Dazu habe ich verschiedene Banner in \images\stil_xyz\ liegen, die ich dann im ACP in jedem Stil eintrage. Es ist dann im ACP auch direkt immer eine Vorschau des aktuellen Banners zu sehen.


    Nun habe ich bemerkt, dass das Banner für den Woltlab Stil direkt in \images\ auf dem Server liegt. Dummerweise hatte ich ein Banner in einem Stilverzeichnis umbenannt, so dass es eigentlich nicht mehr vorhanden war. Im ACP des Stils ist aber weiterhin "Banner.png" eingetragen und so nutzt dieser Stil nun ebenfalls das Banner direkt in \images\.


    Bedeutet das, dass ich gar nicht das Banner zig mal in die verschiedenen Stil-Ordner packen muss, sondern die Ablage unter \images\ ausreicht? Nur sehe ich bei dem betroffenen Stil keine Vorschau des Banners im ACP.


    Wie macht ihr das?

  • Go to Best Answer
  • Niemand eine Idee? Oder ist das vielleicht tatsächlich nur so möglich, wie ich es bisher gelöst habe?


    Jeder Stil erhält seine eigene Bannergrafik im jeweiligen Ordner und muss ggf. manuell in allen Stilen und Ordnern ersetzt werden?


    Aber dann ist das eben so. Gar kein Problem. Dachte nur, ich hätte hier vielleicht etwas übersehen. ;)

  • Aber wie soll mir das bei meinem Problem weiterhelfen? Ich muss dann ja trotzdem die Bannergrafiken in den jeweiligen Stilordner unter \images packen. :/

  • Nein, er möchte eine einzige Bilddatei in allen Stilen als Logo verwenden.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Wenn das so ist, könnte er ja auch auf das Event headerLogo im Template pageHeaderLogo zurückgreifen und die vorhandenen Logos ausblenden lassen. :/

  • Ich kann Dir ehrlich gesagt nicht folgen. Es geht doch einzig und allein um die Angabe einer Bilddatei als Logo im Stileditor. Ich habe es gerade ausprobiert und sowohl die Anzeige der Vorschau als auch der Grafik im Frontend funktioniert einwandfrei.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Es geht doch einzig und allein um die Angabe einer Bilddatei als Logo im Stileditor.

    Genau. Und hier soll dann nicht auf die Grafik im jeweiligen Stilordner unter \images zugegriffen sondern eine zentral abgelegte Grafik genutzt werden.


    Ich habe es gerade ausprobiert und sowohl die Anzeige der Vorschau als auch der Grafik im Frontend funktioniert einwandfrei.

    Was hast du im jeweiligen Stil eingegeben und wohin hast du verlinkt? Also wo liegt die Grafik?

  • Die Grafik liegt im Ordner ../images und ich habe nur den Dateinamen angegeben.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Hier mal in meinem Stil "Base Blue". Im Stilordner unter \images liegt die Bannergrafik nicht mehr. Ich habe sie in OLD umbenannt.



    Allerdings liegt die Grafik direkt im \images Ordner.



    Im Stil selbst habe ich die Grafik definiert.



    Wie zu sehen ist, wird die Vorschau der Grafik dort nicht angezeigt. Auf der Seite selbst wird die Grafik allerdings gezeigt.



    Die Verlinkung passt auch. Es wird die Grafik direkt im \images Ordner genutzt.



    Es fehlt eben nur die Vorschau im Stil. :/

  • Keine Ahnung, warum das bei Dir nicht funktioniert:






    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Okay. Vielleicht liegt es an meinem Test System...?! Ich probiere das mal in meinem Live System. Vielleicht hat sich das Problem dann ja schon gelöst.


    Du bist aber nicht im Standard Woltlab Stil unterwegs oder?

    • Best Answer

    Du bist aber nicht im Standard Woltlab Stil unterwegs oder?


    Bisher schon. In einem anderen Stil konnte ich das von Dir beschriebene Phänomen reproduzieren. Wenn Du hier den vollständigen Pfad, also https://www.compiware-forum.de/images/Banner.png angibst, funktioniert es aber.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Alternativ müsste es doch auch gehen, da gar keine Datei anzugeben und das im Stilübergreifenden CSS zu platzieren oder nicht? Ausprobiert habe ich es nicht.

    Liebe Grüße
    Susi

  • Wozu? Der Stileditor bietet doch die Möglichkeit, die gewünschte Datei anzugeben.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Weil man vielleicht keine Pfade mit Domain hinterlegen will, weil das bei einer Kopie zum testen dann vielleicht Ärger macht. Ich mag keine direkten Pfade.

    Liebe Grüße
    Susi

    Edited once, last by Susi ().

  • Ah okay, ich dachte, er wollte das außerdem vom Stileditor irgendwie angeben. :P

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!