PHP Fatal error: Allowed memory size

  • Affected Version
    WoltLab Suite 5.2

    Hallo,


    Wenn ich versuche unter 'account-management' meine Email-Adresse zu ändern kommt folgendes Fehler in der error.log des Servers:

    Code
    AH01071: Got error 'PHP message: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /var/www/vhosts/domain.tld/community.domain.tld/cms/lib/system/cache/source/DiskCacheSource.class.php on line 70', referer: https://community.domain.tld/cms/account-management/

    Memory-Limit ist auf 128M gestellt:

    memory_limit128M

    ┌П┐(◉_◉)┌П┐

  • Quote

    Zulässige Speichergröße von 134217728 Bytes erschöpft (versucht, 20480 Bytes zuzuweisen)


    Stell in der php.ini das memory_limit auf 256M.


    Habe das problem auch bei einem größeren Forum, dass dort selbst 256Mmanchmal knapp werden...


    Im Endeffekt fehlen 0.0195313M:D

    Lg Quatschecke

  • Stell in der php.ini das memory_limit auf 256M.


    Habe das problem auch bei einem größeren Forum, dass dort selbst 256Mmanchmal knapp werden...


    Im Endeffekt fehlen 0.0195313M :D

    Hmm, das aber komisch, das Forum ist eine Neuinstallation ohne irgendwelchen Import?? Das normal?

    ┌П┐(◉_◉)┌П┐

  • Hmm, das aber komisch, das Forum ist eine Neuinstallation ohne irgendwelchen Import?? Das normal?

    Bei einer Neuinstallation ohne jegliche Plugins oder Paketserver (Drittanbieter die Down sein könnten) finde ich das nicht normal.


    Am besten mal in den Log vom WSC schauen, ob dort was drin steht ohne das dir ein Fehler angezeigt wurde.

    Lg Quatschecke

  • Du solltest mal Prüfen was soviel Speicher frist.

    Ist nix drauf außer die Neuinstallation und die unten genannten Plugins.

    Welche Plugins sind installiert?

    Bei einer Neuinstallation ohne jegliche Plugins oder Paketserver (Drittanbieter die Down sein könnten) finde ich das nicht normal.


    Am besten die Komplette Fehlermeldung von Anfang bis Ende posten.

    Paketserver sind alle Online, Fehlermeldung gibs im ACP keine nur die im error.log die ich oben gepostet habe.

    ┌П┐(◉_◉)┌П┐

  • Deinstallier mal testweise das Plugin zur Benutzergruppen-Markierung. Ansonsten tust du sicher gut daran, alle Drittanbieter-Erweiterungen nach und nach zu deinstallieren um zu schauen, ob es dann besser wird.

  • Deinstallier mal testweise das Plugin zur Benutzergruppen-Markierung. Ansonsten tust du sicher gut daran, alle Drittanbieter-Erweiterungen nach und nach zu deinstallieren um zu schauen, ob es dann besser wird.

    Hab jetzt nach und nach die Plugins deinstalliert und immer wieder getestet, erst als ich folgendes Plugin deinstalliert habe ging es:


    Sonnenspeer Bitte schau mal bei deinem Plugin da scheint es unter der aktuellsten Version ein Problem zu geben.


    EDIT: Ne Fehlalarm es handelt sich um dein Plugin SoftCreatR (No Mail Username) was dort irgendwie Probleme macht.

    ┌П┐(◉_◉)┌П┐

    Edited once, last by TeRRible__KHONS ().

  • So Neuigkeiten:

    Auch nachdem ich die oben genannten Plugins deinstalliert hatte, kam es immer wieder zu dieser Fehlermeldung, nun hab ich das memory_limit auf 256M erhöht, nun ist das Problem nicht mehr vorhanden.


    Ich finde es jedoch komisch das 128M in einer Neuinstallation nicht reichten und das Problem nur im 'account-management' auftrat.


    Kann mir das irgendwie nicht erklären wo das ganze memory flöten geht.

    ┌П┐(◉_◉)┌П┐

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!