[WSC 5.2 RC 1] Fehler bei Upgrade zu WSC 5.2

  • Hallo,


    ich versuche gerade testhalber meine Homepage (WSC 3.1.11) in einer Testinstallation auf WSC 5.2 RC 1 zu upgraden. Ich habe dazu wie beschrieben den Paketserver (2019) hinzugefügt und auf Update geklickt.

    Allerdings erhalte ich jetzt folgende Fehlermeldung:

    Requested URL
    /acp/index.php?install-package/&t=898ce162f59b7e96f90a90154795dd7c42a21f5d
    Referrer
    https://example.com/acp/index.php?package-update/
    Error Message
    Unknown database table column type 'timestamp'.
    Type
    InvalidArgumentException
    File (Line)
    /home/hanashitest/www/httpsdocs/lib/system/database/table/DatabaseTable.class.php (175)
    Stacktrace
    1. /home/hanashitest/www/httpsdocs/lib/system/database/table/DatabaseTableChangeProcessor.class.php (1003): wcf\system\database\table\DatabaseTable::createFromExistingTable(…)
    2. /home/hanashitest/www/httpsdocs/lib/system/database/table/DatabaseTableChangeProcessor.class.php (958): wcf\system\database\table\DatabaseTableChangeProcessor->validate(…)
    3. /home/hanashitest/www/httpsdocs/acp/update_com.woltlab.wcf_5.2.php (212): wcf\system\database\table\DatabaseTableChangeProcessor->process(…)
    4. /home/hanashitest/www/httpsdocs/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72): include(…)
    5. /home/hanashitest/www/httpsdocs/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50): wcf\system\package\plugin\ScriptPackageInstallationPlugin->run(…)
    6. /home/hanashitest/www/httpsdocs/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70): wcf\system\package\plugin\ScriptPackageInstallationPlugin->install(…)
    7. /home/hanashitest/www/httpsdocs/lib/system/package/PackageInstallationDispatcher.class.php (673): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    8. /home/hanashitest/www/httpsdocs/lib/system/package/PackageInstallationDispatcher.class.php (144): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    9. /home/hanashitest/www/httpsdocs/lib/acp/action/InstallPackageAction.class.php (73): wcf\system\package\PackageInstallationDispatcher->install(…)
    10. /home/hanashitest/www/httpsdocs/lib/action/AbstractDialogAction.class.php (68): wcf\acp\action\InstallPackageAction->stepInstall(…)
    11. /home/hanashitest/www/httpsdocs/lib/action/AbstractAction.class.php (47): wcf\action\AbstractDialogAction->execute(…)
    12. /home/hanashitest/www/httpsdocs/lib/system/request/Request.class.php (83): wcf\action\AbstractAction->__run(…)
    13. /home/hanashitest/www/httpsdocs/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    14. /home/hanashitest/www/httpsdocs/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Was ich komisch finde, dass er sagt, dass timestamp ein unbekannter Datenbank-Typ sei.


    VG

    Hanashi


    Edit: sorry bin im falschen Bereich gelandet. Das soll natürlich keine Idee sein *facepalm*

  • Hanashi

    Changed the title of the thread from “[WSC 5.2 RC 1] Fehler bei Update zu WSC 5.2” to “[WSC 5.2 RC 1] Fehler bei Upgrade zu WSC 5.2”.