Label Dropdown

  • Affected App
    WoltLab Suite Core

    Wenn man Labels erstellt hat gibt es ja die möglichkeit im Frontend im Artikelsystem zum Beispiel nach Artikeln mit bestimmten Labels suchen zu lassen über ein Dropdown.

    Nun die Frage dazu. Geht das nur wenn man im Forum angemeldet ist? Habe dazu keine Einstellungen gefunden was das angeht. Denn ich würde es gerne auch für Gäste verfügbar machen. >Ist man als Gast auf der Seite erscheint diese Box nämlich nicht.


    Gruß mcburn

    Ich mache keine Fehler.......

    Ich erschaffe Katastrophen

  • Ich hab grad mal kurz getestet. Die Label-Filter werden bei den Artikeln scheinbar nur angezeigt, wenn der User die Labels setzen darf. Nicht nur sehen, sondern auch setzen. Das betrifft nicht nur Gäste, sondern jeden User. Das verhält sich also anders als bei den Label-Filtern im Forum. Denn im Forum ist es ausreichend, wenn ein User das Label sehen kann, damit der Label-Filter angezeigt wird.

    Ist die Frage, ob das bei den Artikeln so gewollt ist oder ob es sich um einen Fehler handelt. Ich hoffe mal auf einen Fehler, weil es sonst einfach inkonsistent ist und für Probleme sorgt.

    Man will ja nicht automatisch immer, dass ein User ein Label setzen darf, nur damit er danach filtern kann. Manchmal sollen Labels vielleicht auch nur von bestimmten Usern gesetzt werden, aber jeder soll sie sehen und danach filtern können. Im Forum ist das möglich. Bei Artikeln nicht.

    Besonders witzig wird es, wenn man z.B. die selbe Labelgruppe im Forum und in Artikeln anzeigen lassen will, jeder User filtern können soll, aber nicht jeder User die Labels setzen können soll. Dann kann im Forum jeder filtern, aber bei den Artikeln nicht. Obwohl es sich um die selbe Labelgruppe handelt. Das kann irgendwie nicht so gewollt sein.

    Vielleicht sollte man den Thread in den Fehler Bereich verschieben und schauen, was WoltLab dazu sagt.

  • Danke ReeN für deine ausführliche Bestätigung. Da ich für das WSF 5.1 keine Lizenz besitze konnte ich es soweit nicht testen. Kann es aber im WSF 5.0 leider nicht nachstellen da dort für das Artikelsystem keine Labels verfügbar sind.

    Ist die Frage, ob das bei den Artikeln so gewollt ist oder ob es sich um einen Fehler handelt. Ich hoffe mal auf einen Fehler, weil es sonst einfach inkonsistent ist und für Probleme sorgt.

    Dem kann ich nichts hinzufügen.


    Vielleicht sollte man den Thread in den Fehler Bereich verschieben und schauen, was WoltLab dazu sagt.

    Ich hoffe darauf einfach mal.


    Gruß mcburn

    Ich mache keine Fehler.......

    Ich erschaffe Katastrophen

  • Marcel Werk December 7, 2018 at 11:43 AM

    Added the Label Fixed

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!