Fehler beim Update von 5.0 auf 5.1

  • Affected Version
    WoltLab Suite 3.1

    Hallo ein Kollege hat ein riesen Problem beim Update von 5.0 auf 5.1, alle Plugins sind deinstalliert und es geht dennoch nicht.

    Jedes mal wenn er im ACP die Datei hochlädt und die Installation startet kommt folgender Fehler in der Logdatei.

    Und jedes mal muss er dann wieder das ganze FTP Backup und MYSQL Backup einspielen sonst geht rein gar nichts.

    Weiß jemand zu helfen?

    LG und danke :)


    Display Spoiler
    Requested URL
    /forum/
    Referrer
    WoltLab Suite
    3.0.12 pl 1
    PHP
    7.1.13
    Error Message
    Could not prepare statement 'UPDATE wcf1_user_option_value SET userOption31 = ?,userOption32 = ? WHERE userID = ?'
    Type
    wcf\system\database\exception\DatabaseQueryException
    File (Line)
    /home/elitegam/public_html/lib/system/database/Database.class.php (240)
    Stacktrace
    1. /home/elitegam/public_html/lib/data/user/UserEditor.class.php (157): wcf\system\database\Database->prepareStatement(…)
    2. /home/elitegam/public_html/lib/system/event/listener/UserOnlineTimerListener.class.php (34): wcf\data\user\UserEditor->updateUserOptions(…)
    3. /home/elitegam/public_html/lib/system/event/EventHandler.class.php (221): wcf\system\event\listener\UserOnlineTimerListener->execute(…)
    4. /home/elitegam/public_html/lib/system/WCF.class.php (164): wcf\system\event\EventHandler->fireAction(…)
    5. /home/elitegam/public_html/global.php (13): wcf\system\WCF->__construct(…)
    6. /home/elitegam/public_html/forum/global.php (13): require_once(…)
    7. /home/elitegam/public_html/forum/index.php (8): require_once(…)
    Error Message
    SQLSTATE[42S22]: Column not found: 1054 Unknown column 'userOption31' in 'field list'
    Type
    PDOException
    File (Line)
    /home/elitegam/public_html/lib/system/database/Database.class.php (235)
    Stacktrace
    1. /home/elitegam/public_html/lib/system/database/Database.class.php (235): PDO->prepare(…)
    2. /home/elitegam/public_html/lib/data/user/UserEditor.class.php (157): wcf\system\database\Database->prepareStatement(…)
    3. /home/elitegam/public_html/lib/system/event/listener/UserOnlineTimerListener.class.php (34): wcf\data\user\UserEditor->updateUserOptions(…)
    4. /home/elitegam/public_html/lib/system/event/EventHandler.class.php (221): wcf\system\event\listener\UserOnlineTimerListener->execute(…)
    5. /home/elitegam/public_html/lib/system/WCF.class.php (164): wcf\system\event\EventHandler->fireAction(…)
    6. /home/elitegam/public_html/global.php (13): wcf\system\WCF->__construct(…)
    7. /home/elitegam/public_html/forum/global.php (13): require_once(…)
    8. /home/elitegam/public_html/forum/index.php (8): require_once(…)
    Error Message
    Use of undefined constant FORCE_LOGIN - assumed 'FORCE_LOGIN'
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /home/elitegam/public_html/lib/system/WCF.class.php (324)
    Stacktrace
    1. /home/elitegam/public_html/lib/page/AbstractPage.class.php (194): wcf\system\WCF::handleError(…)
    2. /home/elitegam/public_html/lib/page/AbstractPage.class.php (114): wcf\page\AbstractPage->show(…)
    3. /home/elitegam/public_html/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    4. /home/elitegam/public_html/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    5. /home/elitegam/public_html/forum/index.php (9): wcf\system\request\RequestHandler->handle(…)
  • Das gibts doch nicht -.-

  • Requested URL
    /forum/
    Referrer
    WoltLab Suite
    3.1.0
    PHP
    7.2.1
    Error Message
    Unable to find template '__geekLabsUserSocialUser'
    Type
    wcf\system\exception\SystemException
    File (Line)
    C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (351)
    Stacktrace
    1. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (823): wcf\system\template\TemplateEngine->getSourceFilename(…)
    2. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    3. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    4. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    5. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    6. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    7. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    8. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    9. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    10. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    11. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    12. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    13. C:\xampp\htdocs\lib\system\template\TemplateCompiler.class.php (28): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    14. C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (462): wcf\system\template\TemplateCompiler->compile(…)
    15. C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (314): wcf\system\template\TemplateEngine->compileTemplate(…)
    16. C:\xampp\htdocs\lib\system\request\RequestHandler.class.php (88): wcf\system\template\TemplateEngine->display(…)
    17. C:\xampp\htdocs\forum\index.php (9): wcf\system\request\RequestHandler->handle(…)
    Error Message
    Unable to access 'C:/xampp/htdocs/style/shoutbox.scss', does not exist or is not readable
    Type
    wcf\system\exception\SystemException
    File (Line)
    C:\xampp\htdocs\lib\system\style\StyleCompiler.class.php (285)
    Stacktrace
    1. C:\xampp\htdocs\lib\system\style\StyleCompiler.class.php (343): wcf\system\style\StyleCompiler->prepareFile(…)
    2. C:\xampp\htdocs\lib\system\style\StyleCompiler.class.php (131): wcf\system\style\StyleCompiler->compileStylesheet(…)
    3. C:\xampp\htdocs\lib\data\style\StyleEditor.class.php (1008): wcf\system\style\StyleCompiler->compile(…)
    4. C:\xampp\htdocs\lib\data\style\StyleEditor.class.php (1001): wcf\data\style\StyleEditor->writeStyleFile(…)
    5. C:\xampp\htdocs\lib\data\style\StyleEditor.class.php (1045): wcf\data\style\StyleEditor->setVariables(…)
    6. C:\xampp\htdocs\lib\data\style\StyleEditor.class.php (550): wcf\data\style\StyleEditor::create(…)
    7. C:\xampp\htdocs\lib\system\package\plugin\StylePackageInstallationPlugin.class.php (35): wcf\data\style\StyleEditor::import(…)
    8. C:\xampp\htdocs\lib\system\package\plugin\AbstractPackageInstallationPlugin.class.php (70): wcf\system\package\plugin\StylePackageInstallationPlugin->install(…)
    9. C:\xampp\htdocs\lib\system\package\PackageInstallationDispatcher.class.php (667): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    10. C:\xampp\htdocs\lib\system\package\PackageInstallationDispatcher.class.php (144): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    11. C:\xampp\htdocs\lib\acp\action\InstallPackageAction.class.php (73): wcf\system\package\PackageInstallationDispatcher->install(…)
    12. C:\xampp\htdocs\lib\action\AbstractDialogAction.class.php (68): wcf\acp\action\InstallPackageAction->stepInstall(…)
    13. C:\xampp\htdocs\lib\action\AbstractAction.class.php (47): wcf\action\AbstractDialogAction->execute(…)
    14. C:\xampp\htdocs\lib\system\request\Request.class.php (83): wcf\action\AbstractAction->__run(…)
    15. C:\xampp\htdocs\lib\system\request\RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    16. C:\xampp\htdocs\acp\index.php (9): wcf\system\request\RequestHandler->handle(…)
    Error Message
    Unable to find template '__geekLabsUserSocialUser'
    Type
    wcf\system\exception\SystemException
    File (Line)
    C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (351)
    Stacktrace
    1. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (823): wcf\system\template\TemplateEngine->getSourceFilename(…)
    2. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    3. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    4. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    5. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    6. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    7. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    8. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    9. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    10. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (829): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    11. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (362): wcf\system\template\TemplateScriptingCompiler->compileIncludeTag(…)
    12. C:\xampp\htdocs\lib\system\template\TemplateScriptingCompiler.class.php (249): wcf\system\template\TemplateScriptingCompiler->compileTag(…)
    13. C:\xampp\htdocs\lib\system\template\TemplateCompiler.class.php (28): wcf\system\template\TemplateScriptingCompiler->compileString(…)
    14. C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (462): wcf\system\template\TemplateCompiler->compile(…)
    15. C:\xampp\htdocs\lib\system\template\TemplateEngine.class.php (314): wcf\system\template\TemplateEngine->compileTemplate(…)
    16. C:\xampp\htdocs\lib\system\request\RequestHandler.class.php (88): wcf\system\template\TemplateEngine->display(…)
    17. C:\xampp\htdocs\forum\index.php (9): wcf\system\request\RequestHandler->handle(…)


    Wenn wir es versuchen über localhost mit xampp upzudaten kommen dennoch bis 58% übern Webspace nur bis 33%

  • Frag doch mal direkt bei Cyperghost im Forum nach. Der kennt sein Plugin sicherlich am besten.

    Der Abbruch der Installation hat nichts mit meinem Plugin zu tun.

    Die Fehler von meinem Plugin sind eher folge Fehler durch ein gescheitertes update.

    Sondern das hier

    Code
    Could not compile SCSS: Undefined variable $apiVersion: failed at `} ` /home/elitegam/public_html/style/bootstrap/mixin/apiVersion.scss on line 4

    das ist ein Fehler seitens des Styles oder von Woltlab. ;)

    Da müsste Alexander Ebert dir besser weiterhelfen.

    Ich habe dies bei einige Updates so gemacht, das ist den in halt der Style.class.php aus dem WSC3.1 einfach in die aktuelle WSC3.0 Version gepackt habe und dann das Update gemacht habe.

    Hatte bis jetzt immer geholfen :)

  • Ich habe dies bei einige Updates so gemacht, das ist den in halt der Style.class.php aus dem WSC3.1 einfach in die aktuelle WSC3.0 Version gepackt habe und dann das Update gemacht habe.

    Die Datei gibt es erst ab WSC 3.1. Ich tippe einfach mal darauf, dass beim Wiederherstellen des Backups versäumt wurde, vorher den alten Dateibestand zu löschen. Dadurch bleiben entsprechende Dateien übrig, da diese logischerweise nicht im Backup enthalten waren.

  • Die Datei gibt es erst ab WSC 3.1. Ich tippe einfach mal darauf, dass beim Wiederherstellen des Backups versäumt wurde, vorher den alten Dateibestand zu löschen. Dadurch bleiben entsprechende Dateien übrig, da diese logischerweise nicht im Backup enthalten waren.

    Nein, und zwar kam dieser Fehler beim ersten Update, ohne das jemals ein Update vorher gemacht wurde.

    Und es würde der komplette Ordner geleert. Und danach erst das Backup eingespielt.

  • Haben den Fehler selbst behoben auf meinem Webspace ging es nicht haben es dann über XAMPP probiert ging anfangs nicht bis wir max_execution_time auf 3000 geändert hatten dann klappte das Update aufeinmal.

    LG kann closed werden.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!