Probs mit Import und Aktualisierung

  • Affected Version
    WoltLab Suite 3.0

    Hallo @all,


    Nachdem ich vor einigen Tagen die Suite gekauft habe, bin ich etwas verwirrt. Ich hatte die Beta`s alle laufen und alles funktionierte weshalb ich mich entschlossen habe den Schritt zu gehen.


    Leider ist es nicht möglich nach dem Datenimport ein funktionierendes Forum ans laufen zu bringen.


    Die Cronejob`s funktionieren nicht (also ich kann keine aktivieren oder deaktivieren oder ausführen) -- Deshalb habe ich alles wieder entfernt und neu aufgesetzt in der Hoffnung so funzt es weil irgendwo der Wurm drine war.


    Leider ist es mir nun auf einmal nicht mehr möglich nach dem Datenimport die Aktualisierung der Beiträge bis 100% durchzuführen --- (alles andere funktioniert bis 100%) -- bei 50% hängt sich alles immer wieder auf und es gibt (Internal Server Error)



    Nun bin ich etwas verwirrt, das es ja vorher einwandfrei funktioniert hat. Geändert hat sich nicht`s, weder an den Einstellungen noch durch andere Manipulationen.



    Hoffe jemand hat eine Gute Idee.


    lg Multi

  • Hallo,


    viele Dank für die Antwort.


    Da es sich hier um einen Root _Server handelt sind dort keine Limit`s die irgendwo etwas einschränken könnten.


    Alle Anforderungen sind mehr als ausreichen erfüllt. Mich stört an dieser Sache, dass es bei den Beta`s auch ähnliche Probleme gab bei der Aktualisierung von Beiträgen nach Datenimport. Dieser Fehler wurde aber behoben.


    Nun habe ich wieder Fehler nach Datenimport bei Aktualisierung Beiträge.


    Kurios ist auch das alles andere normal durchlaufen wird und nicht bei 50 oder 51 % stehen bleibt bis der Timeout erreicht ist.


    Die Beta`s haben auch alles ohne Fehler durchgezogen und das testboard lief ohne weitere Probleme -- Nicht nachvollziehbar ist für mich auch der plötzliche Fehler mit den cronejob`s (wie oben bereits beschrieben)


    Wenn ich jetztz wirklich hergehen muss und alles über putty usw erledigen muss, dann stelle ich mir die Frage ob es dann notwendig war diese Forensoft zu erwerben. Denn in diesem Falle werden viele an ihren Grenzen kommen und diese Software nicht mehr nutzen können. Der Vorteil lag oder liegt ja eigentlich in der Benutzerfreundlichkeit und Handhabung.


    Wenn ich dafür jetzt ans Eingemachte gehen muss um weiterhin meine Foren mit WBB laufen zu lassen, ziehe ich einen Schlußstrich und hake den letzten kauf als Pech gehabt ab, und nehme Produkte bei denen ich ohne viel trara ein Upgrade machen kann.


    Es kann ja nicht sein das ich bei der Forengröße schon über Konsole arbeiten muss weil die Forensoftware das selber nicht schafft über ACP.



    Ich hoffe trotzdem noch auf eine Lösung oder Info um das Problem zu lösen.


    lg

  • also nochmals,



    bei den Betaversionen der Suite, wurde die Aktualisierung immer erfolgreich abgeschlossen. Warum mit der finalen jetzt nicht?


    Ich befinde mich nicht einmal annähernd am Limit des php. Ich kann mir auch nicht vorstellen das eine Forensoftware entwickelt wurde die selbst die neuste php-version bei Kleinigkeiten an ihre Grenzen bringt. Ausser, es ist daran gelegen Support zu verkaufen.


    Ich hätte gerne mal etwas von den Entwicklern hier dazu gelesen.


    Lg

    • Official Post

    Internal Server Error ist auf einen Konfigurationsfehler des Servers zurückzuführen. Weitergehende Informationen zum genauen Fehler findest du in der error.log des Webservers.

    Beim Datenimport und beim Aktualisieren werden große Datenmengen verarbeitet. Je nachdem wie groß dein Forum ist, läuft PHP relativ schnell in den Timeout für die Scriptausführung. Daher empfiehlt sich bei großen Foren der Import via CLI, da hier schon mal die Einschränkungen des Webservers nicht dazwischen funken. Für die schnellere Verarbeitung empfiehlt es sich ebenfalls InnoDB zu optimieren. Das ist in der Grundinstallation von MySQL in der Regel nicht der Fall. Siehe hierzu auch: https://www.woltlab.com/article/26-innodb-optimieren/


    Wenn es sich beim alten Forum um eine Burning Board 4.1 handelt, dann empfehlen wir grundsätzlich das direkte Udpate da der Datenimport nur den kleinsten gemeinsamen Nenner übernimmt.

  • Ich nehme noch einmal kurz Stellung zu diesem Thema:


    Update funktioniert nicht von 4.1 auf die Suite obwohl alles an Plugins entfernt, und Änderungen an temp rückgängig gemacht wurden.


    Bei Neuinstall und Datemimport wird alles abgeschlossen bis auf die Aktualisierung der Beiträge (wo mir bis jetzt immer noch niemand erklären kann warum es bei den Beta immer funktioniert hat ohne Probleme). Ist ja nicht das erste WBB das ich erweitern will usw....denke das ich nach den Jahren, in denen ich mit Root - Servern und Wbb arbeite schon einschätzen kann was ich da mache.


    Ich hatte gerade letztmalig den Versuch gestartet das ganze über putty zu aktualisieren, was auch funktioniert hat. Nur leider ist dann wieder das problem mit den Cronejobs welche sich weder deaktiviern, aktivieren oder ausführen lassen. (Hatte ich am Anfang des ganzen schon einmal aufgeführt).


    Fakt für mich ist jetzt das es bei der 4.1 erst einmal bleibt und ich bei der Suite von meinem Rücktrittsrecht gebrauch mache.


    Wenn sich in der weiteren Entwicklung nichts in besagtem Falle ändern wird, war es das letzte WBB Produkt für mich. Denn so verrückt, dass ich mich Tagelang hinsetze um ein Upgrade usw einer Forensoftware auf den Server zu bringen bin ich nicht mehr. Mehr als mich an die hier angebotenen Anleitungen zu halten kann ich nicht.


    Aber ich denke auf einen oder 2 Kunden kommt es eh nicht drauf an.



    Lg M4F

    • Official Post

    Ohne detallierte Informationen kann leider niemand helfen.


    Welche Fehlermeldung kommt beim Update?

    Welche Cronjobs lassen sich nicht aktivieren? Standardmäßig sind alle Cronjobs aktiviert. Die Cronjobs werden nur dann nicht automatisch ausgeführt wenn sich das Forum im Wartungsmodus befindet. Wobei diese weder mit dem Update noch mit dem Datenimport etwas zu tun haben oder sind die Worker unter Anzeigen aktualisieren gemeint?

    Was sagt denn die error.log des Webservers bezüglich des Fehler 500?




    PS: Zwischen der Beta und der finalen Version hat sich bei dem Prozedere nichts geändert. Timeouts sind grundsätzlich ein Problem der Serverkonfiguration.

  • Tag zusammen,


    so, habe nochmals alles versucht um das Uprgrade ans rollen zu bringen --- funktioniert definitiv nicht.


    Das mit der Hilfe ist ja alles ganz nett, aber.....


    1: sehe ich nicht ein das ich für einen Support mal eben 149 Teuronen abdrücken soll nur weil man sich überlegt hat ein Upgrade auf den Markt zu bringen das ein Studium erfordert.


    Selbst wenn alles an Plugins entfernt wurde usw wird kein Upgrade bis zum Schluss ausgeführt.


    Für mich ist auch weiterhin nicht nachvollziehbar warum ich über cli alles machen muss wenn ich den Grenzwert dafür bei weitem noch nicht werreicht habe.


    Für mich ist vor dem Kauf der Software nicht ersichtlich gewesen das es Tage dauern kann, bis alles abgeschlossen ist und nicht auf üblichem Wege zu erledigen.


    Und ich habe immer noch keine Antwort warum es bei den Beta`s gelaufen ist ohne abbruch und die Finale das nicht mehr erfüllt. Denn wenn bei meinen Test`s das alles aufgetreten wäre, hätte ich kein Geld dafür ausgegeben.


    Im übrigen hat man mir unter die Arme gegriffen -- IT Fachmann mit Jahrelanger Erfahrung im Bereich Webseiten, Forensoftware usw ... selbst dieser hat es nicht geschafft die Aktualisierungen vollständig abzuschließen. --- Auch nicht über cli.php.


    Und ja, die Servereinstellungen wurden vorab auch noch einmal kontrolliert und etwas angepasst obwohl die Limit`s vorher auch ausreichend waren.


    cli wird zwar als abgeschlossen angezeigt, aber es fehlen weiterhin alle Beiträge und deren dazugehörigen images.


    Ich überlege ob ich ggf eine nackte 4.1 aufsetze und Datenimport laufen lasse --- danach die 5er nochmals auf den Server und von der neuen 4.1er den Datenimport laufen lasse weil ggf in der 4.1er Forensoft irgendwo ein Fehler ist. Ich bezweifel aber den Erfolg.

  • Das kann ich hier nicht nachvollziehen. Ich habe in dieser Woche ein Forum von Burning Board 4.1 auf WSC: Forum 5.0 umgestellt und ein weiteres auf Burning Board 3.1 importiert - das lief alles ohne nennenswerte Probleme.


    Würdest du genauere Angaben mit Fehlermeldung machen, kann man dir sicherlich weiterhelfen.


    cli wird zwar als abgeschlossen angezeigt, aber es fehlen weiterhin alle Beiträge und deren dazugehörigen images.

    Wenn die Dateianhänge / Bilder fehlen, konnten diese aus dem Quellsystem nicht kopiert werden. Bitte die Berechtigungen prüfen.

  • Tag. Ich will nur helfen. Bitte mich nicht töten, wenn ich etwas falsches sage :P


    Ich gehe mal davon aus, du hast ein WBB 4.1, da aktuell nichts anderes in den Beiträgen zu finden ist. Sicherlich hast du ja noch ein Backup des Forums, dass du auf setzen kannst.


    Am leichtesten ist noch immer das Update vom 4.1 zu 5. Wie ich gelesen habe, bekommst du aber einen 500-er Fehler, auch wnen ich nicht genau verstanden habe, an welcher Stelle dieser nun kommt. Hierzu solltest du dennoch dein error.log anschauen und uns die Fehlernachricht melden. Erst dann können wir präziser sagen, was für ein Problem bestehen könnte.


    Gruß

  • Ok, ich werde nachher alle Plugins entfernen aus dem 4.1er und versuchen das als Update laufen zu lassen -- diese Methode habe ich noch nicht versucht -- hoffentlich funzt das.


    Wenn nicht, baller ich hier alles an Error rein was mir angezeigt wird ;)


    lg



  • Alles entfernt ............... nur das nackte 4.1 er mit Inhalt.


    Jetzt setze ich die Server ein und gehe auf Update mal sehen was passiert



  • Und schon gehts los -- nix Update :(

  • Hallo noch einmal,


    ka wer das Thema als erledigt abgehakt hat, aber ich bin damit noch lange nicht durch.


    Oben ist der Fehler der mir angezeigt wird wenn ich es über Update versuche sowie über alle anderen Wege.


    Man hat mir ja mehrfach empfohlen die Error hier anzuzeigen was ich damit getan habe.


    Leider reagiert dann niemand darauf und das Thema wird als erledigt erklärt und versinkt im Nirwana.



    Falls sich jemand dazu berufen fühlt mir unter die Arme zu greifen (freiwillig) dem gebe ich gerne die Möglichkeit über Teamviewer alles über cli zu versuchen.


    vlt. sehe ich den Wald vor lauter Bäumen nicht mehr.


    Ich habe bis jetzt versucht:


    • über Update
    • über neuinstall und Datenimport
    • das 4.1 neu installiert und Datenimport in dieses und dann weiter zum 5er um ggf Fehler auszuschließen
    • cli hat ein Bekannter gemacht und hat auch nicht funktioniert


    lg

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!