Sammelthread: Kompatibilität von Erweiterungen unter WSC 3.0

  • Hallo,


    in diesem Thread sammeln wir gemeinsam alle Erweiterungen (Endanwendungen, Plugins, Stile), die zur WoltLab Suite nicht kompatibel und (teilweise) überflüssig sind. Auch von den Entwicklern selbst erstellte Listen, z.B. auf ihrer Webseite, werden hier verlinkt.


    Bitte gebt folgende Informationen über die Erweiterung an:

    • Name (bei Bedarf mit Link)
    • Entwickler
    • Versionsnummer

    Edited 26 times, last by Fendo ().

  • Fireball CMS (und damit alle abhängigen Plugins) laufen gegenwärtig nicht mit dem WSC 3.0.


    Das WYSIWYG-Paket hatte ich aber, glaube ich, bereits angepasst - aber einen umfassenden Test werde ich erst in den nächsten Tagen durchführen können. Wobei das Paket mit WSC 3.0 vermutlich nicht mehr benötigt wird.


    Mein Benutzerdefiniertes LESS ist nicht kompatibel bzw. wird keine Auswirkungen mehr haben. Entsprechender Code wird aber in das Nachfolgeplugin "Benutzerdefiniertes Scss" übernommen (sofern das alte Paket erst nach der Installation des neuen deinstalliert wird, aber dazu zu gegebener Zeit mehr).


    Ich nehme an, dass mein Plugin zum Ausblenden von Beiträgen ignorierter Personen keine Auswirkungen mehr haben wird, ist aber eh überflüssig, wenn ich das recht im Kopf habe.


    Aber bisher nur unverbindliche Einschätzungen, da ich noch zu nichts gekommen bin. ^^

  • Ich hatte noch nicht die Muse herauszufinden, welche meiner Erweiterungen mit dem WSC obsolet werden. Dürften einige sein. Ist ja nicht das Verkehrteste :P

  • Überflüssig:


    woltlab.com/pluginstore/file/1488/


    Im ACP hat man nun die Möglichkeit, Aktualisierungen im Frontend anzeigen zu lassen, oder nicht.

    Überflüssig würde ich nicht sagen, ein Hinweis im Frontpanel ist ja trotzdem schon, solange es keine dicke Infobox ist. Da es in der WCS nur ganz ausschaltbar oder wie vorher anzeigbar ist, halte ich es nicht für überflüssig :)

  • Kompatibel:

    • External Cronjob Execution API
    • Gäste zum Login umleiten
    • Warnhinweis bei veralteten Browsern
    • Google Analytics Integration
    • Globale Ankündigung (vermutlich, wenn ich denn mal die Optionen ändern könnte)


    Inkompatibel wegen Funktionsverlust:

    • (Custom LESS) >> Verursacht keinen Fehler, aber hat keine Auswirkungen mehr
      Nachfolger: https://update.mysterycode.de/package/46-custom-scss/
    • WoltLab Burning Board: Blockierte Benutzer ausblenden >> Anpassung an das WSF 5.0 erfolgt, wenn hier entsprechendes Interesse besteht
    • Elevator


    Inkompatibel mit Fehlermeldung:

    • WBB: Benutzerdefinierte Statistik
    • Virtuelle Grabstätte für Tiere & Menschen
    • TeamSpeak3 Viewer
    • MysteryCode Paketserver (bereits in Entwicklung)
    • ToDo-Liste (bereits in Entwicklung)
    • Spendenübersicht
    • Fireball CMS (bereits in Entwicklung)
    • Fireball CMS - Nachrichtensystem
    • Fireball CMS RSS Feed Poster
    • Fireball CMS - Burning Board Integration
    • MysteryCode Gästebuch (bereits in Entwicklung)
    • Online Friedhof inkl. Frontend-Plugins Mensch und Tier


    Durch Inkompatibilität von Plugins anderer Entwickler inkompatibel:

    • Infinite Filebase: Massenverschieben
    • Infinite Filebase: Downloadverlauf
    • Infinite Filebase: Sidebar-Orientierung bei Einträgen
    • Infinite Filebase: Lizenz-Übersicht
    • MysteryCode Paketserver: Infinite Filebase Integration

    Da von WCF Solutions keine Updates mehr zu erwarten sind, werden diese Plugins entsprechend nicht mehr weiterentwickelt.


    Bis auf weiteres unbekannt:

    • WoltLab Filebase: Downloadverlauf (sollte aber kompatibel sein)


    So weit mal der erste Test von mir.

  • Mir fehlt bislang noch eine Aussage von Woltlab ( @Alexander Ebert ), wie der Update von WCF auf WSC bei den geänderten Dingen (pages, menu, menuItem, box, objectTypes ...) ablaufen wird / soll und ob dafür seitens der Plugin-Entwickler Vorbereitungen getroffen werden müssen.

    Gruß, Udo

    • Official Post

    Hallo,


    • Push dürfte zwar in der Theorie noch funktionsfähig sein, erhält aber ein Update, welches alle Push-Consumer kaputt macht. Alle Plugins, die Push nutzen müssen aktualisiert werden. Die README.md u.Ä. werde ich noch anpassen.
    • nodePush ist in der Version im Pluginstore definitiv inkompatibel. Es hat im Git aber bereits ein Update erhalten, welches es mit der neuen Push-Version kompatibel macht. Dementsprechend funktioniert die neue Version erst, wenn alle Push-Consumer aktualisiert sind. Es wird voraussichtlich noch größere Änderungen an der technischen Struktur von nodePush geben, um die Performance auf Seiten des Servers zu verbessern.
    • Signer ist (ungetestet) kompatibel, aber obsolet, weil die Funktionalität jetzt direkt im WSC ist. Ich habe extra darauf geachtet den Signer dabei nicht kaputt zu machen, um davon abhängige Plugins nicht kaputt zu machen.
    • QR ist (ungetestet) kompatibel. Es gab am WSC keine für das Plugin relevanten Änderungen
    • Tims Chat ist inkompatibel und crasht bei der Installation. Was bei einem Upgrade passiert konnte ich natürlich nicht testen. Tims Chat wird einen kompletten Rewrite mit einigen neuen Features und entfernen Altlasten erarbeiten. Die Planung ist schon fertig und auch der erste Code existiert bereits (nicht-öffentlich).
    • Official Post

    Hallo,


    kleine Korrektur:


    nodePush ab Version 3.0.0 ist kompatibel, aber aus offensichtlichen Gründen nicht in den Pluginstore geladen. Die zusätzlichen, optionalen, Anpassungen, die ich noch machen wollte sind mittlerweile auch abgeschlossen.


    Es ist lediglich so, dass Plugins, die Push / nodePush nutzen keine Pushes mehr erhalten, bis diese kompatibel gemacht wurden.

  • @TimWolla wie sieht es damit aus?

    Linux: Born to Frag 8) :D

    • Official Post

    Hallo,

    @TimWolla wie sieht es damit aus?

    braucht in jedem Falle Änderungen an den Templates.

    • Official Post

    Hallo,


    das WBB-Plugin, was hier beiliegt:

    ist jetzt kompatibel mit WSC 3. Das Hauptplugin ist noch nicht aktualisiert.


    Für Plugin-Entwickler, die auf Push / NodePush aufbauen ist das Plugin vermutlich einen Blick wert: https://github.com/wbbaddons/pushNotification-WBB


    /cc @Christopher Walz

  • Folgende Erweiterungen für WCF 2.1 / WBB 4.1 laufen nicht mehr unter WSC / WSF:


    UZ Abwesenheiten
    UZ Aktivitätspunkte - Online
    UZ Aktivste Mitglieder
    UZ Benutzer-Karte
    UZ Beworbene Umfragen
    UZ Bilder-Wettbewerb
    UZ Community Bot 2
    UZ Dateianhänge
    UZ Einladung
    UZ Lesezeichen für WBB
    UZ Likes
    UZ Pflicht-Thema
    UZ Quiz
    UZ Spruch-Butler
    UZ Top-Poster des Monats
    UZ Tracker
    UZ Verwarnungen
    UZ Themen-Bewertung


    Tatsächlich habe ich bisher keine Erweiterung gefunden, die problemlos läuft. Im Wesentlichen daran schuld sind die Änderungen an Menüs und Boxen.
    Updates sind für die meisten Erweiterungen geplant und bereits in Arbeit.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!