Elasticsearch and PostSearchIndexRebuildDataWorker

  • Hi,

    We have recently installed the Elasticsearch plugin on our forum (5 million+ posts) and as such need to run PostSearchIndexRebuildDataWorker. I ran this command via the CLI and it ran fine until it hit 37% - at 37% the process just stopped. No error, it literally just stopped running.

    Any ideas?


  • Speaking of elasticsearch, I can't find any of the changes mentioned from this thread in the latest 2.1.2 es package.

    more elastissearch

    The only options for ES in the ACP are server address and index name.

    Where is the option for pre-wildcard support as mentioned in the above thread?

  • I'm now getting Out of Memory errors when trying to run the PostSearchIndexRebuildDataWorker. Here's the error:

    PHP Fatal error:  Out of memory (allocated 3130523648) (tried to allocate 758383985 bytes) in /var/www/zeldauniverse.net/forums/wcf/lib/system/search/elasticsearch/ElasticsearchSearchIndexManager.class.php on line 134
    PHP Fatal error:  Uncaught exception 'wcf\system\exception\SystemException' with message 'PHP warning in file phar:///var/www/zeldauniverse.net/forums/wcf/lib/system/api/phpline/phpline.phar/internal/TerminalLineSettings.php (151): shell_exec(): Unable to execute 'stty sane < /dev/tty'' in /var/www/zeldauniverse.net/forums/wcf/lib/system/WCF.class.php:309
    Stack trace:
    #0 [internal function]: wcf\system\WCF::handleError(2, 'shell_exec(): U...', 'phar:///var/www...', 151, Array)
    #1 phar:///var/www/zeldauniverse.net/forums/wcf/lib/system/api/phpline/phpline.phar/internal/TerminalLineSettings.php(151): shell_exec('stty sane < /de...')
    #2 phar:///var/www/zeldauniverse.net/forums/wcf/lib/system/api/phpline/phpline.phar/internal/TerminalLineSettings.php(56): phpline\internal\TerminalLineSettings->stty('sane')
    #3 phar:///var/www/zeldauniverse.net/forums/wcf/lib/system/api/phpline/phpline.phar/internal/TerminalLineSettings.php(48): phpline\internal\TerminalLineSettings->set('sane')
    #4 phar:///var/www/zeldauniverse.net/forums/wcf/lib/sy in /var/www/zeldauniverse.net/forums/wcf/lib/system/WCF.class.php on line 309

    I can't really increase PHP's memory limit any more - the server has no more memory available!

  • Hi,

    Sorry to bring a thread back from the dead, but I've only just gotten around to looking at this. I tried your above solution @TimWolla, but unfortunately it didn't work:

    >worker wbb\\system\\worker\\PostSearchIndexRebuildDataWorker
    21% [#############-----------------------------------------------] ETA 18:33:54
    PHP Fatal error:  Out of memory (allocated 3120562176) (tried to allocate 754450410 bytes) in /var/www/zeldauniverse.net/forums/wcf/lib/system/search/elasticsearch/ElasticsearchSearchIndexManager.class.php on line 133

    I don't think there is anything wrong with my server configuration, though I could be overlooking something simple.

    Any ideas?

    • Official Post

    @AndroidOS This sounds weirdly familiar, I think I have seen this issue once and fixed it back then. I'll need to go through some stuff to figure out why it still happens, hold on please.

    Edit: Yep, that bug is still around, send you a fixed version via conversation.

  • I just wanted to pop in and say we have now gotten elasticsearch to work.

    I want to thank everyone involved in getting this to work, especially @Alexander Ebert for providing the new versions of the elasticsearch plugin. Keep up the awesome support!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!