BBCode hinzufügen

  • Ich hoffe ich bin hier richtig und mir kann wer helfen!


    Ich stecke gerade bei der Erstellung eines BBCodes fest, bzw ich weiß echt nicht wie ich das eintragen muss.


    Mein Problem:
    Ich will ein bestimmtes Iframe als BBCode anbieten. Beim Link ändert sich immer nur die mittlere ID (farblich makiert).


    <iframe src="http://gigrawars.de/kb/qng7x~mf0o3o7lcx2075/board/" width="600" height="700" name="sprichwort_des_tages"></iframe>


    Der User sollte dann einfach [KB]qng7x~mf0o3o7lcx2075[/KB] eingeben und das Iframe sollte sich erstellen.



    Ich danke schon jetzt für die Hilfe!


    Lg Floh

  • Das kann man über einen Medienanbieter umsetzen.
    ich bastel dir was...warte ein paar min

    Das wäre ganz klasse. Natürlich warte ich.


    Versuche es mal so und ersetze das blabla durch das, was du brauchst - das %s% ersetzt dann das, was du als BB-Code eingibst

    Das geht leider nicht da hägt sich dann das Forum mit einem Fatal Error auf :S siehe Anhang

  • Hast Du den anderen Vorschlag zumindest mal ausprobiert?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • ... und wenn er es versucht, sollte er hinter sprichwort_des_tages ein schließendes " nicht vergessen, fehlt nämlich auf meinem Screenshot

    Liebe Grüße


    René

  • Ja das mit dem " ist mir aufgefallen den hab ich auch dazu gemacht, aber dann kommt eben der Fehler! Deaktiviere ich den BBCode dann gehts Forum wieder

  • Also die Lösung mit dem Medienanbieter wäre


    Name: Gigrawars.de
    RegEx:http://(?:.*?)?gigrawars.de/kb/(?<ID>.*)/
    HTML-Code:<iframe src="http://gigrawars.de/kb/{$ID}/board/" width="600" height="800"></iframe>

  • Da müsste man jetzt die entsprechende Fehlermeldung sehen, genauso setzte ich die Einbindung meines Amazon-iFrame ein. Und das funktioniert wunderbar!

    Liebe Grüße


    René

  • Da müsste man jetzt die entsprechende Fehlermeldung sehen, genauso setzte ich die Einbindung meines Amazon-iFrame ein. Und das funktioniert wunderbar!

    Oops - noch ein Fehler - das heißt %s und NICHT %s% !!!

    Liebe Grüße


    René

  • Da müsste man jetzt die entsprechende Fehlermeldung sehen, genauso setzte ich die Einbindung meines Amazon-iFrame ein. Und das funktioniert wunderbar!

    Die Fehlermeldung hab ich oben angehängt! Aber es lag am zweiten % Zeichen! Das weg und jetzt geht es! DANKE



    Ich schau mir auch noch die 2. Variante mit dem Medienanbieter an, muss aber erst suchen wie ich die einsetze, mit dem Thema Medienanbieter hab ich noch nie gearbeitet. Ich gebe dann auch bescheid wenn ich die 2. Variante getestet habe.


    Danke vielmals


    Lg Floh

  • Die Fehlermeldung hab ich oben angehängt!


    Für das nächste Mal: Das ist keine Fehlermeldung, sondern lediglich die ID einer solchen. Den dazugehörigen Meldungstext findest Du im ACP unter "Fehler" oder per FTP in der Datei ../wcf/log/aktuellesDatum.txt.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Für das nächste Mal: Das ist keine Fehlermeldung, sondern lediglich die ID einer solchen. Den dazugehörigen Meldungstext findest Du im ACP unter "Fehler" oder per FTP in der Datei ../wcf/log/aktuellesDatum.txt.

    Alles klar - Sorry wusste ich nicht. Aber beim nächsten mal.






    Also die Lösung mit dem Medienanbieter wäre


    Name: Gigrawars.de
    RegEx:http://(?:.*?)?gigrawars.de/kb/(?<ID>.*)/
    HTML-Code:<iframe src="http://gigrawars.de/kb/{$ID}/board/" width="600" height="800"></iframe>

    Zur Variante 2, das mit dem Medienanbieter funktioniert auch! Zum Medienanbieter noch eine Frage geht das mit der Seite (http://gigrawars.de/kb/.s645xe05xiape0j2052/) auch? Da gehts auch um die ID nur der Bericht wäre schöne!



    Ich Danke jeden für seine Hilfe! Echt Top und schnell.


    Danke


    Lg Floh

  • Würde ich an der Stelle abraten, da du damit auch das klimbim wie die Bilder drumherum anzeigen lässt.


    Die Browserconsole hat mir dann auch ein paar Fehler ausgeworfen, weil ein paar Quellen nicht geladen werden konnten.
    Ich würde die /board/-Zusammenfassung lassen

  • Alles klar, danke dir vielmals!


    Ich lasse das jetzt so wie du es geschrieben hast das funktioniert super!


    Danke nochmals Allen!


    Lg Floh

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!