Tapatalk


  • Wenn du das angehängte Bild via IMG BBCode einbindest, könnte ich mir gut vorstellen, dass das was mit den Rechten zu tun hat, also nicht von der einstellung her, sondern wie Tapatalk die interpretiert.


    Naja, eher nein. Schau Dir mal an was die Tapatalk APP aus einem Link macht:


    den Forennamen hab ich absichtlich geschwärzt, da sich das Forum noch im aufbau befindet.

  • @WhiteDragon1983
    Ich würde mir nicht einmal ein Apple-Gerät holen, wenn ich es im 10er-Pack geschenkt bekäme. Höchstens, um es danach zu verkaufen.


    @gine78


    Nun, in diesem Fall bringt es fast nichts, sich an den Support für das WBB-Plugin zu wenden. Das scheint ganz offensichtlich ein Softwarefehler zu sein.

  • Nun weis ich auch nicht weiter...


    wenn ich mit Tapatalk in unser altes Forum gehe, werden mir die Bilder im [img] Tag angezeigt. Also kann es in der Theorie nicht an der APP liegen.


    Weis einer von Euch in welcher Datei das Tapatalk Plugin die BBCodes interpretiert/anlegt?

  • Das hatte ich dir schon geschrieben ;) Wenn es jedoch unter Android funktioniert und unter iOS nicht, kann es auch nicht an der API liegen ;)


    Ok, Es liegt nicht an der API, es liegt nicht an der APP. - Woran zum Teufel soll es dann liegen? :D

  • Woran zum Teufel soll es dann liegen?


    An den Einstellungen der App?
    Mein Android Schmatzfon lädt Fotos und Co nur bei guter Internetverbindung.
    Ist die Verbindung zu langsam werden keine Fotos und Dateianhänge geladen.
    Dies kann man in den Einstellungen entsprechend angeben.

    Gruß Lega

  • Ja gibt es, daran liegt es aber nicht. Es muss eine Symbiose zwischen WCF und dem Tapatalkplugin sein oder ich seh den Wald vor lauter Bäumen nicht.


    Funktioniert: [code][img]http://url.zum/bild.jpg[/img][/code] (hier wird das Bild im Forum nicht angezeigt, sondern als Code interprtiert - in Tapatalk jedoch als Bild angezeigt)


    Wenn ich in der MbqRdEtForumPost.php den String:
    $post = preg_replace('/<img [^>]*?src="([^>]*?)"[^>]*?\/>/i', '[img]$1[/img]', $post);
    durch
    $post = preg_replace('/<img [^>]*?src="([^>]*?)"[^>]*?\/>/i', '[code][img]$1[/img][/code]', $post); ersetze, wird in Tapatalk plötzlich ein Codeblock angezeigt mit dem [img]-Tag drin... (welcher vorher nicht funktionierte)


    Funktioniert nicht: BBCode im Post deaktivieren, so dass der imagecode angezeigt wird.


    Ehrlich, das versteh ich irgendwie nicht mehr. Hat einer ne Idee?

  • Sorry @gine78 aber das was du da gerade versuchst ist doch Flickschusterei, darauf sollte das Plugin wirklich nicht basieren.


    Aktuell bist du der einzige, der ein solches Problem hat, bei @-=TOM=- scheint das ja nun zu funktionieren und auch bei mir im Forum hat sich noch keiner der Apfel Jünger beschwert (zumindest nicht über dieses Problem).

  • Naja, so richtig scheint das ja nirgends zu funktionieren. Wenn ich mir Deine TODO im Tapatalk Forum ansehe, hat das meiste mit den BBCodes zutun. Sicherlich ist es Flickschusterei, aber irgendwie muss es doch einen Ansatz geben das zu fixen.
    Von der Tapatalk Seite kommt ja nichts in Sachen WBB - da es keine andere Möglichkeit gibt - bleibt wohl nur "Selbst suchen" und den Developern zukommen lassen.

    • Official Post
    PHP
    $post = preg_replace('/<img [^>]*?src=(["\'])([^"\']+?)\1 style="float: (left|right)".*?>/i', '[img=\'$2\',$3][/img]', $post);
    $post = preg_replace('/<img [^>]*?src=(["\'])([^"\']+?)\1.*?>/i', '[img]$2[/img]', $post);
  • Jo der Code funktioniert besser- bringt aber keine besserung :)


    Ich werde das ganze nun einstellen und Tapatalk erst einmal nicht weiter anbieten, schade, aber sei es drum.
    Vielen Dank trotzdem an alle ;)

  • Tjo,
    ich kann es nicht lassen, weil es mir keine Ruhe lässt...


    Folgendes:
    Wenn ich in der MbqRdEtForumPost.php folgenden String ändere

    Code
    Zeile 265:
    $post = $var->getDecoratedObject()->getFormattedMessage();
    in 
    $post = $var->getDecoratedObject()->getMessage();


    @Frank Pabst
    Wenn Du das bei Dir änderst, siehst Du in Deiner App evtl. alle BBCodes?
    Wenn ich das ändere werden mir zwar immer noch keine Bilder angezeigt, aber ich bekomme einige mehr BBcodes zum laufen (Spoiler, code, quote)


    gibt es außer getMessage noch eine Möglichkeit an unformatierte Strings zu kommen?


    Vielen Dank!

  • Sorry @gine78 aber das was du da gerade versuchst ist doch Flickschusterei, darauf sollte das Plugin wirklich nicht basieren.


    Aktuell bist du der einzige, der ein solches Problem hat, bei @-=TOM=- scheint das ja nun zu funktionieren und auch bei mir im Forum hat sich noch keiner der Apfel Jünger beschwert (zumindest nicht über dieses Problem).


    @Frank Pabst
    bei Tapatalk gehts weiter - es gibt ein Update.

  • Hi,
    wie kann ich das neue Package instalieren? Wenn ich es über das ACP versuche, kommt immer:


    "Paket „Tapatalk“ kann mit dem angegebenen Archiv nicht aktualisiert werden."


    Gruss

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!