Fehlermeldung Exception ID nach Posten einer Antwort auf ein Thema

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Hallo.

    In meinen Forum (Woltlab Cloud 5.5.17) kommt dieser Fehler wenn ich oder andere User auf ein Thema im Forum antworte:

    Exception ID: f6addc07a52d82f9dd0f6041e73426f6c2d03904

    Drücke ich diese Meldung weg und aktualisiere ich mit F5 ist der Beitrag gepostet worden und der Entwurf ist gespeichert.

    Drücke ich nicht F5 sondern versuche nochmal zu posten erscheint der Beitrag zwei / drei Viermal ... je nach dem wie ich oft ich den Beitrag absende.

    Gruß Jan

  • Hallo,

    für die Referenz:

    Requested URL
    POST *snip* (0004-65116D921BF69)
    Referrer
    *snip*
    WoltLab Suite
    5.5.17
    PHP
    8.1.23
    Error Message
    Could not execute statement 'INSERT INTO wcf1_label_object (labelID, objectTypeID, objectID) VALUES (?, ?, ?)'
    Type
    wcf\system\database\exception\DatabaseQueryExecutionException
    File (Line)
    /customer-rw/www/lib/system/database/statement/PreparedStatement.class.php (144)
    Query Parameter 1
    '54'
    Query Parameter 2
    345
    Query Parameter 3
    5179
    Stacktrace
    1. /customer-rw/www/lib/system/label/LabelHandler.class.php (210): wcf\system\database\statement\PreparedStatement->execute(…)
    2. /customer-rw/www/lib/system/event/listener/AutoLabelPostActionListener.class.php (77): wcf\system\label\LabelHandler->setLabels(…)
    3. /customer-rw/www/lib/system/event/EventHandler.class.php (172): wcf\system\event\listener\AutoLabelPostActionListener->execute(…)
    4. /customer-rw/www/lib/system/event/EventHandler.class.php (125): wcf\system\event\EventHandler->executeListeners(…)
    5. /customer-rw/www/lib/system/event/EventHandler.class.php (216): wcf\system\event\EventHandler->executeInheritedActions(…)
    6. /customer-rw/www/lib/data/AbstractDatabaseObjectAction.class.php (224): wcf\system\event\EventHandler->fireAction(…)
    7. /customer-rw/www/forum/lib/data/post/PostAction.class.php (259): wcf\data\AbstractDatabaseObjectAction->executeAction(…)
    8. /customer-rw/www/lib/system/message/QuickReplyManager.class.php (244): wbb\data\post\PostAction->create(…)
    9. /customer-rw/www/forum/lib/data/post/PostAction.class.php (2304): wcf\system\message\QuickReplyManager->createMessage(…)
    10. /customer-rw/www/lib/data/AbstractDatabaseObjectAction.class.php (216): wbb\data\post\PostAction->quickReply(…)
    11. /customer-rw/www/lib/action/AJAXProxyAction.class.php (92): wcf\data\AbstractDatabaseObjectAction->executeAction(…)
    12. /customer-rw/www/lib/action/AJAXInvokeAction.class.php (111): wcf\action\AJAXProxyAction->invoke(…)
    13. /customer-rw/www/lib/action/AbstractAction.class.php (57): wcf\action\AJAXInvokeAction->execute(…)
    14. /customer-rw/www/lib/action/AJAXInvokeAction.class.php (65): wcf\action\AbstractAction->__run(…)
    15. /customer-rw/www/lib/system/request/Request.class.php (90): wcf\action\AJAXInvokeAction->__run(…)
    16. /customer-rw/www/lib/system/request/RequestHandler.class.php (107): wcf\system\request\Request->execute(…)
    17. /customer-rw/www/forum/index.php (11): wcf\system\request\RequestHandler->handle(…)
    Error Message
    SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails ("customer_e125898b"."wcf1_label_object", CONSTRAINT "2bda939b6f578831c3b50216201556fe_fk" FOREIGN KEY ("labelID") REFERENCES "wcf1_label" ("labelID") ON DELETE CASCADE)
    Type
    PDOException
    File (Line)
    /customer-rw/www/lib/system/database/statement/PreparedStatement.class.php (126)
    Stacktrace
    1. /customer-rw/www/lib/system/database/statement/PreparedStatement.class.php (126): PDOStatement->execute(…)
    2. /customer-rw/www/lib/system/label/LabelHandler.class.php (210): wcf\system\database\statement\PreparedStatement->execute(…)
    3. /customer-rw/www/lib/system/event/listener/AutoLabelPostActionListener.class.php (77): wcf\system\label\LabelHandler->setLabels(…)
    4. /customer-rw/www/lib/system/event/EventHandler.class.php (172): wcf\system\event\listener\AutoLabelPostActionListener->execute(…)
    5. /customer-rw/www/lib/system/event/EventHandler.class.php (125): wcf\system\event\EventHandler->executeListeners(…)
    6. /customer-rw/www/lib/system/event/EventHandler.class.php (216): wcf\system\event\EventHandler->executeInheritedActions(…)
    7. /customer-rw/www/lib/data/AbstractDatabaseObjectAction.class.php (224): wcf\system\event\EventHandler->fireAction(…)
    8. /customer-rw/www/forum/lib/data/post/PostAction.class.php (259): wcf\data\AbstractDatabaseObjectAction->executeAction(…)
    9. /customer-rw/www/lib/system/message/QuickReplyManager.class.php (244): wbb\data\post\PostAction->create(…)
    10. /customer-rw/www/forum/lib/data/post/PostAction.class.php (2304): wcf\system\message\QuickReplyManager->createMessage(…)
    11. /customer-rw/www/lib/data/AbstractDatabaseObjectAction.class.php (216): wbb\data\post\PostAction->quickReply(…)
    12. /customer-rw/www/lib/action/AJAXProxyAction.class.php (92): wcf\data\AbstractDatabaseObjectAction->executeAction(…)
    13. /customer-rw/www/lib/action/AJAXInvokeAction.class.php (111): wcf\action\AJAXProxyAction->invoke(…)
    14. /customer-rw/www/lib/action/AbstractAction.class.php (57): wcf\action\AJAXInvokeAction->execute(…)
    15. /customer-rw/www/lib/action/AJAXInvokeAction.class.php (65): wcf\action\AbstractAction->__run(…)
    16. /customer-rw/www/lib/system/request/Request.class.php (90): wcf\action\AJAXInvokeAction->__run(…)
    17. /customer-rw/www/lib/system/request/RequestHandler.class.php (107): wcf\system\request\Request->execute(…)
    18. /customer-rw/www/forum/index.php (11): wcf\system\request\RequestHandler->handle(…)


    Offenbar hängt der Fehler mit dem Auto-Label-Plugin von Hanashi zusammen. Zum Test habe ich gerade den Cache geleert. Funktioniert es jetzt?

  • Hallo Herr Düsterhus.

    Diese Fehlermeldung muss ich an den Entwickler der App "Auto-Label" weitergeben.

    Ich habe nun alle Felder in den betroffenen Foren von Auto-Label geleert, damit kein Label drin steht / gesetzt werden kann. Dennoch erscheint die Fehlermeldung erneut.

    Die App ist nun erstmal deinstalliert worden und ich wende mich direkt an Hanashi.

    Ich vermute, dass diese Fehlermeldung entstanden ist , weil ich gerade mehrere Labelgruppen und Label erstelle.

    Gruß Jan

  • Tim Düsterhus September 25, 2023 at 2:01 PM

    Added the Label Not a bug
  • Hallo,

    Hallo Herr Düsterhus.

    hier in den öffentlichen Bereichen (und auch im Ticket) geht von mir aus gerne auch einfach nur Tim :)

    Die App ist nun erstmal deinstalliert worden und ich wende mich direkt an Hanashi.

    Perfekt. Die Fehlermeldung oben kann einfach direkt weitergegeben werden, ich habe sie bereits um persönliche Daten bereinigt. Durch die Erwähnungen gehe ich aber davon aus, dass Hanashi das Thema auch selbst sehen wird.

  • hier in den öffentlichen Bereichen (und auch im Ticket) geht von mir aus gerne auch einfach nur Tim :)

    Alles klar Tim ... ist gespeichert :thumbup:;)

    Perfekt. Die Fehlermeldung oben kann einfach direkt weitergegeben werden, ich habe sie bereits um persönliche Daten bereinigt. Durch die Erwähnungen gehe ich aber davon aus, dass Hanashi das Thema auch selbst sehen wird.

    Vielen Dank , sehr gut! Ich kontaktiere Hanashi vorsichtshalber nochmal separat - lieber einmal zu viel als einmal zu wenig!

    Gruß Jan

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!