Beim Button "Originalversion aufrufen" kommt es zum lokalen Download der Grafikdatei anstatt zur reinen Browseransicht

  • Affected Version
    WoltLab Suite 5.4

    Hallo,


    meine User berichten davon, dass wenn man bei der Ansicht eines Bilds im Forum auf den Button klick "Originalversion aufrufen" es nun zu einem Download im Browser kommt.

    Gibt es hierfür eine Einstellungsmöglichkeit, dass das Bild nur angezeigt wird in der Originalversion?

    Die User wünschen sich kein lokalen Download.

    Gruß Elektron

  • Aufgrund deiner Meldung habe ich es eben in meinem Forum (WoltLab Suite 5.4.18/Firefox 100.0.2 getestet und kann dieses Verhalten nicht reproduzieren. Die "Originalversion" öffnet sich wie auch bisher direkt.

    Gruß Markus


    WoltLab Suite 5.4.25

    • Official Post

    Hallo,


    offenbar wird beim Upload von WebP-Dateien der falsche Content-Type image/x-webp statt image/webp ermittelt, welcher von WoltLab Suite nicht als „Inline“-Typ erkannt wird.


    Hier auf WoltLab.com funktioniert es mit dem spezifischen Anhang wie gewollt. Das deutet darauf hin, dass die Magic DB zur Ermittlung der Dateitypen auf dem Server veraltet ist bzw. fehlerhafte Daten enthält. Der richtige Ansprechpartner ist hier der Webhoster.

  • Das dürfte dann wohl an den .webp-Dateien liegen. Chrome (mobil) kann diese wohl nicht ohne Einbettung in eine Webseite anzeigen und lädt diese dann stattdessen runter.

  • In dem von dir geposteten Link erfolgt auch bei mir ein Download, wobei mich wundert, dass der Dateianhang bei dir als WebP gespeichert wird, während er bei mir (manueller Download) nach wie vor als JPG gespeichert wird.

    Gruß Markus


    WoltLab Suite 5.4.25

  • Das dürfte dann wohl an den .webp-Dateien liegen

    Werden denn als JPG vorliegende Dateianhänge nicht nach wie vor als JPG gespeichert?

    Gruß Markus


    WoltLab Suite 5.4.25

  • Sowohl hier, als auch in meinem Forum wird ein als JPG vorliegender Dateianhang stets als JPG gespeichert.

    Gruß Markus


    WoltLab Suite 5.4.25

  • SoftCreatR Ich denke das hat dein Update von TimyIMG (5.7.0) verursacht. Ich hab das Update am Dienstag eingespielt und seitdem habe ich

    image/x-webp

    als Mimetype in der DB.


    Tim Düsterhus

    kann ich als workaround das per DB Update korrigieren?


    Code
    update `wcf1_attachment` set fileType = 'image/webp' where fileType = 'image/x-webp'

    oder muss ich mehr beachten?

  • Chrome (mobil) kann diese wohl nicht ohne Einbettung in eine Webseite anzeigen und lädt diese dann stattdessen runter.


    Bei der von elektron verlinkten Datei erfolgt auch im FF am Laptop ein Download.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

    • Official Post

    Hallo,

    Bei der von elektron verlinkten Datei erfolgt auch im FF am Laptop ein Download.

    das passiert in jedem standardkonformen Client („Webbrowser“), da der Server den Client explizit zu einer Speicherung statt einer Anzeige anweist:


    Für eine direkte Anzeige muss die markierte Stelle auf inline lauten.

  • Das hatte ich schon so aus Deiner Erklärung herausgelesen. Der Hinweis bezog sich vorrangig auf die zitierte Annahme von ilou.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Danke für die Info und Unterstützung!
    Ich verstehe davon nur Bahnhof, da ich kein Programmierer bin. 8|
    Wir haben TinyImg5 von SoftCreatR im Einsatz, wo ein Update auf 5.7.0 am Dienstag kam und installiert wurde.

    Ich denke ich warte einfach mal seine Reaktion ab, ob es Grund dafür ist, wie von MrJoe freundlicherweise schon hingewiesen wurde.


    Gruß Elektron

  • ...das passiert in jedem standardkonformen Client („Webbrowser“), da der Server den Client explizit zu einer Speicherung statt einer Anzeige anweist:

    Dies erklärt aber zumindest für mich nicht, weshalb beim TE Dateianhänge als WebP gespeichert werden, was ja im Standard nicht der Fall ist.

    Gruß Markus


    WoltLab Suite 5.4.25

  • Dies erklärt aber zumindest für mich nicht, weshalb beim TE Dateianhänge als WebP gespeichert werden, was ja im Standard nicht der Fall ist.

    Vermutlich deshalb:

    Wir haben TinyImg5 von SoftCreatR im Einsatz, wo ein Update auf 5.7.0 am Dienstag kam und installiert wurde.

    Viele Grüße,

    smers

  • Ich habe dasselbe Phänomen bei mir feststellen können, nachdem die Bilder durch TinyImg in WebP konvertiert wurden. Das steht auf meiner To-Do, ich habe nur noch keine Ahnung, warum das so ist.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!