Update geht nicht

  • Affected Version
    WoltLab Suite 5.3

    Ich versuche nun schon seit Stunden das Testforum von 5.3.15 auf das 5.41 hoch zu kriegen. Fand dann raus das ich erst die weiteren die 5.3.... updaten muss. Jetzt ist es auf 5.3.17 aber wenn ich nun auf 5.4.0 gehen will klappt das nicht.

    Habe im ACP - Pakete ganz oben drin diese Meldung drin

    Neue Version verfügbar!
    Die neue WoltLab Suite 5.4 steht zur Installation bereit. Eine Anleitung zur Durchführung des Upgrades steht im Handbuch zur Verfügung.
    Systemvoraussetzungen prüfen, um das Upgrade freizugeben

    Habe dann erst mal über Update suchen geschaut ob da noch ein Updates wären die vorher gemacht werden sollten.

    Danach habe ich auf den Link "Systemvoraussetzungen prüfen..." geklickt, da Button auf ja gestellt, abgeschickt. Dann ging ich wieder auf Pakete, dort auf Update suchen. Soweit hat das auch geklappt, bekam Updates aufgelistet, aber damit hat es sich dann schon. Kriege heute immer wieder die Meldung das 5.3 ein Update auf 5.4 verhindert.

    Gestern kam an der stelle gleich die folgende Meldung, warum diese heute anders ist weiss ich nicht.

    Die folgenden installierten Pakete schließen die Installation aufgrund von Inkompatibilitäten aus:

    „WoltLab Suite Core: Konversationen“ (com.woltlab.wcf.conversation)

    „WoltLab Suite Core: Verwarnungen“ (com.woltlab.wcf.infraction)

    „WoltLab Suite Forum“ (com.woltlab.wbb)

    „WoltLab Suite Core: Moderierte Benutzergruppen“ (com.woltlab.wcf.moderatedUserGroup)

    „WoltLab Suite Core: Impressum“ (com.woltlab.wcf.legalNotice)

    „WoltLab Suite Core: Importer“ (com.woltlab.wcf.exporter)

    „DSGVO: Admin Export-Berechtigung“ (de.softcreatr.wsc.gdpr.adminExportPerms)

    „DSGVO Daten-Export-Frontend“ (de.softcreatr.wsc31.gdpr.dataExportFrontend)

    „Layout Expansion Kit“ (com.cls-design.wcf.layoutExpansionKit)

    „Style: Elements“ (com.bemananas.style.elements)


    Versuche ich nun z.B. Impressum von Hand hoch zu laden, kriege ich diese Meldung

    Das Paket „WoltLab Suite Core: Impressum“ (installierte Version: „5.3.1“) soll auf Version „5.4.9“ aktualisiert werden, ein Update wird jedoch nicht unterstützt.

    versuche ich es mit Impressum Version 5.4.0 statt der neusten 5.4.9 dann kommt die folgende Meldung

    Benötigt das Paket „WoltLab Suite Core“ in Version „5.4.0“ oder höher, es ist aber nur Version „5.3.17“ installiert.

    Diese Meldung kommt auch bei anderen Plugins, wie z.B. Importer, wenn ich sie von Hand hochladen will


    Meine Frage wie kriege ich diese Woltlab Suite Core von 5.3.17 auf die 5.4.... ? Finde dazu nix bei Downloads auch nicht im Kundenkonto.

    Ja, ich habe das 5.4 gekauft, kann ich auch aus Kundenkonto runterladen, wie man hier sieht

    Kann es an Paket Server liegen? Was ich mir nicht vorstellen kann weil ich habe die hier drin



    Sorry das ich so dummes Zeug frage, aber egal was ich versuche ich kriege das Update nicht rein wegen diesem fehlenden Suite Core Ding und ich weiss einfach nicht wo ich das herkriege oder muss ich das auch noch extra kaufen?

  • Danke ihr beiden.

    DSGVO: Admin Export-Berechtigung


    Die Erweiterung kann deinstalliert werden.

    Kann ich diese Erweiterung nach dem Update wieder Installieren oder muss ich neue Version kaufen oder braucht man diese Erweiterung nicht mehr, weil das im 5.4 integriert ist?

    die Aktualisierung auf die aktuelle Version erfolgt direkt über die Administrationsoberfläche. Die dafür notwendigen Schritte sind in unserem Handbuch beschrieben.

    ok werde mir das Teil nochmal durchlesen. Danke

  • Hallo,

    die Aktualisierung auf die aktuelle Version erfolgt direkt über die Administrationsoberfläche. Die dafür notwendigen Schritte sind in unserem Handbuch beschrieben. Zu keinem Zeitpunkt müssen manuell Dateien herunter- oder hochladen werden.

    Also ich habe es eben nochmal versucht und alles nach Handbuch abgearbeitet. Schritt für SChritt, oder Punkt für Punkt.

    Bis Punkt 8 ging alles ohne Probleme.

    Beim Punkt 8 kommt dann ja die Liste der Plugins

    Woltab Suite Core Version 5.4.12

    WoltLab Suite Core: Konversationen Version 5.4.10

    und auch Importer, Verwarnung, etc

    Alle haben ja automatisch den Hacken gesetzt, sprich ich muss nur noch unten auf Absenden klicken. Genau so habe ich es bisher gemacht, alles genau gleich gemacht, nur ohne dauernd auf Handbuch zu schauen.

    Die neue Meldung sagt wieder dass das WoltLab Suite Forum“ in Version „5.3.17 verhindert Aktuallsierung auf WoltLab Suite Core 5.4.6 und 5.4.7 bis hoch zu 5.4.12


    Hier die neueste Meldung die ich eben bekam

    Installierte Pakete

    Die folgenden installierten Pakete sind mit den zu installierenden Versionen nicht kompatibel

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.6“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.7“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.8“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.9“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.10“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.11“

    „WoltLab Suite Forum“ in Version „5.3.17“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.12“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.6“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.7“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.8“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.9“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.10“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.11“

    „DSGVO Daten-Export-Frontend“ in Version „5.3.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Suite Core“ auf Version „5.4.12“


    Beim "Daten-Export-Frontend" nehme ich an das ich auch das entfernen muss.

    Gibt es da ein Update oder ist das auch nicht mehr Nötig?

    Wenn irgendwer eine Idee hat wie man dem Update klar machen kann, dass es funktionieren soll, wäre das nett, wenn ihr mir das weitermeldet..

    Dankeschön

    Leandra

  • Danke ihr beiden.

    Dann bleibt nun nur noch dieses Problem

    Doch ich habe nun das Update abgebrochen weil ich nerve mich nur noch das da dauernd steht das ich updates habe, die es dann eh nicht annimmt.

    Werde dann nochmal nach Handbuch gehen, wenn ich weiss wie ich es anstellen muss, das ich von 5.3.17 z.B. Stufenweise höher komme, bis es das 5.4.12 endlich annimmt.

    Schaue die Tage dann wieder mal rein, weil dieses Wochenende werde ich eh nix mehr machen, was das update angeht.

  • Werde dann nochmal nach Handbuch gehen, wenn ich weiss wie ich es anstellen muss, das ich von 5.3.17 z.B. Stufenweise höher komme

    Einfach das Upgrade auf 5.4 abbrechen* und dann erst einmal das 5.3 auf Stand bringen.

    * = Dadurch sollten wieder die offiziellen Paketserver für 5.3 aktiv sein und dir die fehlenden WSC-Updates anbieten.

  • Das habe ich auch gemacht gehabt nachdem ich das Upgrade auf 5.4 abgebrochen hatte, klickte ich auf Update suchen und bekam die Meldung.

    Ihr System ist auf dem aktuellen Stand, es wurden keine ausstehenden Updates gefunden.

    Dachte dann das ich zu schnell auf Update suchen klickte und machte es eben nochmal, kommt aber die gleiche Meldung raus. Iéch verstehe das einfach nicht, es gibt keine Updates auf 5.3.... und das 5.4 will nicht rein, weil 5.3 das verhindert. Das ist mir zu hoch, nicht zu verstehen und darum habe das Upgrade auf 5.4 vorläufig gestrichen bis ich das Testboard irgendwann durch einen Fehler zerschiesse und dann eh neu machen muss.

    Wie ich es dann beim Forum machen werde weiss ich noch nicht, aber solange der Support für das 5.3 noch gegeben ist, mache ich da kein Upgrade auf 5.4 sonst mach ich das Teil noch kaputt und fast 11 Jahre Austausch mit Mitgliedern wäre dann futsch, das ist mir zu riskant.

    Kaufe dann lieber noch eine Lizenz und fange da neu an und hole dann alles vom Forum per Importer rein. Dann sind Beiträge, Mitglieder etc wenigstens nicht verloren. Das wird aber noch eine Weile dauern, aber eilt ja nicht für das 5.3 gibt es ja noch eine Weile Support, zu mindest habe ich bisher nix anderes gesehen, gelesen.

  • Warum soll das Vorgehen für Upgrades denn nicht mit Plugins ins Handbuch aufgenommen werden, WoltLab ? Diese Probleme liest man immer wieder im Forum, obwohl das eigentlich unnötig wäre, wenn es dort grob mit beschrieben wäre. Ich habe das ja schon mehrfach angeregt.

    Und hier nun Leandra ins Handbuch zu schicken, wo dort gar nicht zu finden ist, was sie tun muss, findet sie sicher noch unschöner als ich.

    Liebe Grüße
    Susi

  • Warum soll das Vorgehen für Upgrades denn nicht mit Plugins ins Handbuch aufgenommen werden, WoltLab ?

    Das Vorgehen ist bereits im Handbuch beschrieben: https://manual.woltlab.com/de/updates/#up…suite-53-auf-54

    Übrigens auch für die vorherigen Versionen, ab der 4.0.

    Edit: Zwar nicht explizit, aber geschrieben steht:

    Damit wären ja Plugins von Drittanbietern mit inkludiert.

    Quote
    1. Stellen Sie sicher, dass Sie die Anleitung für das Einspielen aller ausstehenden Updates durchgeführt haben.
  • Also, ich kann da nichts von Plugins lesen, aber vielleicht stehe ich ja genauso auf der Leitung wie Leandra. Dann wären wir schon zu zweit und man sollte das, was man erklären möchte, vielleicht klarer formulieren.

    Liebe Grüße
    Susi

  • In aller Regel (wie auch hier im Startthema) steht mindestens ein ausstehendes Update bereit. Von daher würde der oben zitierte Schritt m.M.n. ausreichen.

    Dass jetzt ein Plugin neu installiert werden muss, ist eher ein Einzelfall – in dem Fall hier, wurde im Laufe der Zeit der Paketbezeichner geändert. :saint:

  • Danke SoftCreatR für dein Angebot. Das ist sehr lieb von dir.

    Ist nun aber nicht mehr Nötig, weil es endlich klappte.


    Warum soll das Vorgehen für Upgrades denn nicht mit Plugins ins Handbuch aufgenommen werden, WoltLab ? Diese Probleme liest man immer wieder im Forum, obwohl das eigentlich unnötig wäre, wenn es dort grob mit beschrieben wäre. Ich habe das ja schon mehrfach angeregt.

    Und hier nun Leandra ins Handbuch zu schicken, wo dort gar nicht zu finden ist, was sie tun muss, findet sie sicher noch unschöner als ich.

    Also, mich hatte das schon genervt das ich auf Handbuch verwiesen wurde, weil ich hatte ja genau nach Anleitung gearbeitet und das mehrfach probiert. dachte dann ok fange nochmal an, mach Schritt für Schritt. Also Handbuch offen, 1. Schritt was ich tun soll gelesen und dann gemacht, darauf nochmal nachgelesen um zu sehen ob das wirklich richtig war was ich machte. War das gemacht ging es an 2. Punkt wo ich wieder gleich vorging, dann 3. Punkt etc. Ja das ist ein dauerndes hin und her hüpfen aber ich dachte wenn es so geht dann ist ja gut. Leider half auch das nichts.

    Mich hatte vor allem die Meldung das wsc 5.3 eun Update auf 5.4 verhindert, sehr irritiert. Dass dann bei der Meldung oben noch andere Plugins drin waren, war mir in dem Moment nicht so wichtig, weil ich ahnte ja das ich das ein oder andere Deinstallieren oder neuere Version holen muss, wie bei vorherigen Upgrades.

    Nachdem ich die anderen Plugins raus nahm oder ein Update davon einspielte, probierte ich es erneut nach Handbuch. Leider wieder ohne Erfolg, aber es kam dann wenigstens nur noch die Meldung das WSC 5.3 das Update auf 5.4 verhindert, keine anderen Plugins mehr. Danach gab ich auf. Dachte mir hat keinen Sinn verlierst eh nur die letzten Nerven, früher waren Upgrades ein einfaches Ding. neue Version hochladen, schauen ob Plugins was verhindern, diese dann löschen und später Update einspielen fertig. Heute muss man nebenbei das Handbuch studieren und soll keine Updates von Hand hochladen, etc.

    Naja wie auch immer, die Letzte Nacht (Sa auf So) erwachte ich so um 3 rum und hatte einen Gedanken. Tja was soll ich sagen, der führte mich zum Grund des Problems, den Authentifizierungs-Code. Da fehlten die letzten 2 oder 3 Ziffern warum auch immer, ich weiss es nicht.

    Habe daraus aber wieder etwas gelernt. Das nächste mal werde ich zuerst den Code prüfen, bevor ich versuche ein Upgrade zu machen. denn nochmal so viel Nerven schleissen, wie dieses mal, will ich sicher nicht mehr.

    Früher war das einfacher. Neue Update-Server eintragen, auf "Pakete suchen" klicken und los gings's. Wenn das ein oder andere Plugin nicht passte wurde das entsprechend gemeldet, dann hat man das entfernt und erneut Update suchen klicken und gut war's. Jetzt muss man erst das Handbuch studieren, das entweder auswendig lernen oder nebenbei öffnen und wie ein Idötchen hin und her hüpfen um Schritt für Schritt zu erledigen.

    Ich hoffe nur das dann, wenn ich das ganze beim Forum machen will, alles ohne die doofe Meldung dass das 5.3 update auf 5.4 verhindert, geht. Doch das wird vorläufig nicht ausprobiert, weil erst heisst es all das erledigen, was hier liegen blieb bei den xxx Std rumprobieren.


    Danke an alle die mit Tipps versuchten zu helfen.

    Lg Leadra

  • Hallo Leandra,

    tatsächlich scheinen in einigen Fällen Plugins die Updates des Core zu verhindern und umgekehrt. Ich hatte das ebenfalls in einem Fall, beim Upgrade auf 5.4 in einem der Foren.

    In dem Fall ging es um das Lexikon, das verhinderte das Upgrade von .3 auf .4 und umgekehrt ließ es sich aber auch nicht updaten, solange nicht 5.4 installiert war. Es war zum Verzweifeln.

    Eigentlich wollte ich das in Ruhe machen und hatte bis dahin nur das Upgrade auf 5.4 vorbereitet, aber die Betreiberin hatte noch ein anderes Update versucht und dabei aus Unwissenheit auch das Upgrade auf 5.4 angestoßen, da ich das bereits frei gegeben hatte.

    Das crashte dann mit ähnlichen Fehlermeldungen und sie wusste nicht weiter.

    Das Einzige was dann half, war tatsächlich die Deinstallation des VieCode-Lexikon (leider mit komplettem Datenverlust!). da man im WoltLab dummerweise die Plugins weder einzeln noch zentral deaktivieren kann, um eine Standard-Instanz zu testen und Fehler ausfindig zu machen (das ist wiederum im vBulletin besser gelöst). Es bleibt also bei Fehlern nur jeweils die komplette Deinstallation des bzw. der Plugins übrig.

    Danach konnte ich Core, Forum und Blog upgraden und anschließend dann die neue Version des Lexikons, natürlich ohne jegliche Daten.

    In anderen Fällen und mit anderen Plugins hatte ich dieses Problem allerdings noch nie.

    Oftmals erscheinen deren Updates sogar schon VOR einer neuen WL-Version und diese installiere ich dann sofort beim Erscheinen. Daher gab es da bisher nie Probleme bei "größeren" Updates.

    Da in beiden Foren jeweils etliche Plugins installiert sind, würde ich das eher als den "Normalfall" ansehen. Ich lasse auch keine "Lücken" zwischen den Updates, sondern gehe von Anfang an "step by step" vor und aktualisiere immer sehr zeitnah nach Release.

    Um nicht zu sagen: meist noch am selben Tag. Das erscheint mir als bester Weg, um problemlos und schnell arbeiten zu können.

    Diese eine "Negativ-Erfahrung" zwischendurch war mir ein Warnschuss, möglichst keine Betreiber dazwischenfummeln zu lassen. Das kann praktisch nur schief gehen wenn mehrere Leute (und Teile davon mir nur marginalen Kenntnissen) dasselbe tun, die berühmten "vielen Köche mit dem Brei" halt...

    Gruß

    Jörg

    (Jaydee)

  • Das Lexikon habe ich nicht, ist aber schon doof wenn man das Deinstallieren muss und dabei alle Daten verloren gehen. So etwas ist ärgerlich.

    Das einzelne Plugins mal ein Upgrade stören können, ist normal. Darum habe auch immer wieder Updates gemacht. Klicke immer wieder mal auf Update suchen, damit die Plugins dann ok sind. Doch es gab auch schon so Fälle wo das Update nicht ging, man das Plugin deinstallieren musste um dann die neueste Version über Hochladen rein holen musste.

    Diese eine "Negativ-Erfahrung" zwischendurch war mir ein Warnschuss, möglichst keine Betreiber dazwischenfummeln zu lassen. Das kann praktisch nur schief gehen wenn mehrere Leute (und Teile davon mir nur marginalen Kenntnissen) dasselbe tun, die berühmten "vielen Köche mit dem Brei" halt...

    Ohh ja das kann ich mir sehr gut vorstellen. Denn auch ich machte diese Erfahrung vor Jahren. Damals ging das ganze Forum, kurz nach dem ein "Helfer" im ACP was machte, nicht mehr. Es war einfach weg, alle kriegten die Meldung das Forum existiere nicht. Der Schock sass und ich suchte Hilfe weil ich das Problem nicht lösen konnte.

    Dann half mir jemand anderes, der wusste was er tat. Der fragte sofort nachdem er sich das ganze angeschaut hatte "was um alles in der Welt hast du da gemacht, in der Datenbank ist ja alles völlig verwurstelt. Da hilft nur noch komplette Neuinstallation, und die Hoffnung das man Benutzer, Benutzergruppen, Themen, Beiträge etc über Import rein kriegt. Diese Hilfe hat dann alles, zu unserer Freude, entsprechend erledigt.

    Ich lernte aus der ganzen Geschichte. Doch zuerst ging mein Vertrauen in die Menschen richtig den Bach runter. Hobbybastler, wie der wo mir damals alles kaputt machte, haben in meinem Forum, ACP etc. nichts mehr zu suchen.

    Heute gibt es 1 Profis dem ich 100% Vertraue und ihm ohne Bedenken die nötigen Daten von ACP und Datenbank geben kann, wenn ich Hilfe brauche. Dieser Profi hat uns das Upgrade von WBB 4.1 auf das WSC perfekt erledigt. Ohne seine grossartige Hilfe hätten wir das Forum heute noch auf WBB 4.1 weil ich das Upgrade nicht hinkriegte.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!