Entwickler-Werkzeuge finden Paketdateien nicht

  • Affected Version
    WoltLab Suite 5.4

    Folgendes steht in der (selbst erstellten) package.xml:


    Code
    <requiredpackage minversion="1.0.0" file="requirements/de.softcreatr.wsc.foo.tar.gz">de.softcreatr.wsc.foo</requiredpackage>


    Die dort genannte Datei existiert auch. Nehme ich nun mittels Entwickler-Werkzeuge Änderungen an der package.xml vor, wird dies mit einem Fehler quittiert:




    Die Fehlermeldung ist insofern korrekt, dass die gesuchte Datei nicht existiert. Denn offensichtlich setzen die Entwicklerwerkzeuge voraus, dass das Paket die Dateiendung .tar hat, unabhängig davon, was in der Anweisung steht.


    Von der doppelten Anzeige der Fehlermeldung mal gänzlich abgesehen.

    • Official Post

    Hallo,


    die enthaltenen Pakete für Abhängigkeiten bzw. optionale Pakete sollten immer als reines Tar-Archiv vorliegen. Das Paketsystem ist relativ tolerant bei der Verarbeitung von Paketen (.tar die eigentlich gz-komprimiert ist, .tar.gz das eigentlich nur ein .tar ist und ähnliche Späße), das ist allerdings nur ein Seiteneffekt der Implementierung und kein Feature.


    Die Entwicklerwerkzeuge sind bewusst darauf ausgelegt, einem einheitlichen Aufbau der Pakete zu fördern und somit die Fehleranfälligkeit zu reduzieren.

    Alexander Ebert
    Senior Developer WoltLab® GmbH