Nach Update auf 5.4.4 fatal error

  • Affected Version
    WoltLab Suite 5.4
    Affected App
    WoltLab Suite Forum

    Ich hab keinen Plan, was ich jetzt tun soll.


    Erst konnte ich noch ins acp und "nur" das Forum war mit einem Fatal error belegt.


    Leider ist es bei der Verarbeitung zu einem Fehler gekommen und die Ausführung wurde abgebrochen. Falls möglich, leiten Sie bitte den oben stehenden Fehlercode an den Administrator weiter.



    Meine Vermutung, war nun, dass sich eventuell ein zusätzliches Plugin nicht mit der aktuellen Version ver trägt.

    Daraufhin habe ich ein Plugin deinstalliert und nun erreiche ich auch das acp nicht mehr.



    Ich hab jetzt nicht wirklich viel Ahnung von dieser Programmiersprache. Eine einfache Erklärung wäre hilfreich. :(

  • Welches Plugin war das denn? Backup gibt es keins?


    unable to find class 'wcf\system\option\user\group\UserGroupOptionType'


    Da fehlt wohl diese Datei:


    UserGroupOptionType.class.php


    Muß auch von einem Plugin sein.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Doch Backup gibt es schon. Trotzdem würde mich ja jetzt erst auch noch interessieren, wieso und warum das so passierte.

    Denn das Prozedere dauernd wiederholen möchte ich nicht.


    Das deinstallierte Plugin war "beworbene Umfragen"

  • Nach dem verlinkten Thema ist das wohl ein Datenbankproblem. Am besten mal lesen was da drin steht.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Nach dem verlinkten Thema ist das wohl ein Datenbankproblem. Am besten mal lesen was da drin steht.

    Das Thema hab ich überflogen. Nachdem da scheinbar einiges im Programmierungsbereich bzw auch von irgendwelchen Keys die Rede war, musste ich aussteigen. Das verstehe ich einfach nicht.


    Deshalb bat ich um eine einfach Erklärung.

  • Ich hab auch kein Plan von sowas. Am besten spielt du das Backup ein und gehst dann im ACP auf die Systemüberprüfung und schaust ob da alles ok ist. In 5.4 ist ja mittlerweile eine Prüfung der Fremdschlüssel integriert.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

    • Official Post

    Braucht man die in 5.4 noch?

    Die Prüfung verwendet lediglich eine kleine Auswahl an Tabellen, da der Prozess je nach MySQL-Server sehr langsam ist. Der Test kann somit nicht erkennen, wenn bei einer anderen Tabelle die Keys fehlen. Üblicherweise sind aber auf Grund eines fehlerhaften SQL-Exports alle Keys weg, also wahrscheinlich ja.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Okay, per Backup ist jetzt erst einmal wieder alles da.


    Folgende Fehler habe ich jetzt erstmals feststellen müssen =O


    Allerdings, bin ich jetzt immer noch nicht schlauer. Was ist das für ein Key? Wo bekomme ich den her? :/

  • SO, Plugin hatte ich installiert. Vielen Dank noch mal dafür! :love:


    Unfassbar viele Schlüssel fehlten. Die wenigsten allerdings bei Plugins. Da ich nicht viel Ahnung davon habe, bin ich jetzt nur froh, dass es wieder läuft und auch das Update nun funktionierte. :thumbup:

    Für mich ist nur nicht verständlich, weshalb diese Schlüssel verschwinden.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!