Call to a member function getDecoratedObject() on null

  • Affected Version
    WoltLab Suite 5.4
    Affected App
    WoltLab Suite Core

    Ich hatte das Problem schon einmal in einer vorigen WSC-Version, allerdings kann das ja nicht so bleiben. Und zwar führen Aufrufe von nicht existenten Themen bei aktiviertem (und exzessiv verwendetem) Werbesystem zu folgendem Fehler (zumindest bei uns):



    Ich habe dann auch mal In das kompilierte Template geschaut, aber das hat für mich irgendwie nichts mit dem Fehler zu tun:



    Der Aufruf der betroffenen Seiten führt logischerweise zu einem 503er Fehler, was am Ende zu Recht auch von Google bemängelt wird.

  • Marcel Werk

    Set the Label from Confirmed to Fixed
  • Dieses Problem trifft zwar auf meine Konstellation (kein aktiviertes Werbesystem) nicht zu, aber wie ich bereits an anderer Stelle geschrieben habe, sind die Versionsangaben (für mich) manchmal verwirrend.


    Beispiel:


    Obwohl in der Fußnote der WoltLab Suite (5.3) bereits folgende Version steht:


    Mir ist durchaus bewusst, dass hier zwischen den Versionen von WSC und WSF unterschieden wird, doch wenn in der Fußnote steht: WoltLab Suite 5.3.12, geht man doch eigentlich davon aus, dass darin bereits die erwähnte 5.3.11 enthalten, bzw. durch 5.3.12 ersetzt worden ist.


    Wie gesagt verstehe ich durchaus den Hintergrund, halte es aber für wenig sinnvoll, dass über die Fußnote suggeriert wird, dass die gesamte SUITE bereits auf einer höheren Version läuft.

    Gruß Markus


    WoltLab Suite 5.4.25

  • Marcel Werk

    Set the Label from 5.3.11 to 5.3.13
    • Official Post

    Webmark Das war ist ein berechtigter Einwand, es wurde irrtümlich die falsche Version ausgewählt. Wir haben dies nun korrigiert.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!