Upgrade von 5.3.neuste Version auf 5.4 -> Smileys?!

  • Affected Version
    WoltLab Suite 5.4

    Hallo Zusammen


    Ich wollte auf die neuste Version von Woltlab updaten.

    Gleich vorneweg. Unser Forum ist eine plain vanilla Installation. Das heisst, der einzige Unterschied sind Smileys. Ansonsten ist alles aus den Original-Paketen von Woltlab. Keine zusätzlichen Add Ons oder sonstige, manuelle Veränderungen.


    Und wo fliegt die Installation auf die Fresse? Und das angeblich wegen einem doppelten Smiley Kurzcode-Eintrag (siehe Anhang). Irgendwie kann es das doch nicht sein.


    Jetzt muss ich die gesamte Datenbank restoren und wieder alle Dateien auf das Hosting hochladen und die Daumen drücken, dass alles wieder funktioniert, wie vor dem Update.


    In der Zwischenzeit habe ich alles wieder zurückgeladen und den Upgrade erneut versucht. Natürlich akribisch nach den Vorgaben. Die gleiche Fehlermeldung.


    Ob das irgend ein Folgefehler ist oder sich die Installation wirklich als so unrobust herausstellt, kann ich leider nicht beantworten.


    Bin für Hilfe dankbar
    Exi

    • Official Post

    Hallo,


    die Installation sollte sich grundsätzlich in einem ausreichend intakten Zustand befinden, dass man das Upgrade nach der Korrektur erneut starten kann. Seit der Version 5.2 setzen wir auf eine neue technische Basis für die Upgrades, die deutlich fehlertoleranter ist und i.d.R. eine Wiederholung zulässt.


    Mich irritiert aber ein wenig die Fehlermeldung, wurde der Original :)-Smiley gelöscht?

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Mit Verlaub, aber worauf stützt sich Deine Erwartungshaltung, dass der beanstandete Sachverhalt beim erneuten Versuch nicht wieder zu einer Fehlermeldung führt? Du hättest gut daran getan, den beanstandeten Smiliecode zu finden und zu korrigieren, bevor Du das Update wiederholst.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Hallo,


    die Installation sollte sich grundsätzlich in einem ausreichend intakten Zustand befinden, dass man das Upgrade nach der Korrektur erneut starten kann. Seit der Version 5.2 setzen wir auf eine neue technische Basis für die Upgrades, die deutlich fehlertoleranter ist und i.d.R. eine Wiederholung zulässt.


    Mich irritiert aber ein wenig die Fehlermeldung, wurde der Original :)-Smiley gelöscht?

    Ich konnte die Installation vor 5 Monaten von der Version 3.x auf 5.3 anheben. Es war nicht ganz reibungslos, da aber die Software einen Datenexport resp. Migration einer etwas älteren Version auf eine komplet neue Version nicht unterstützt, musste ich diesen Weg gehen. Ursprünglich bestand das Problem auf einer Attributsgrösse. Das konnte durch den Hostingprovider damals behoben werden. Danach lief der Upgrade auch anstandslos und wirklich smooth durch.


    Die Smileys sind Teil der customizable Teile des Forums. Es wurden komplett andere Smileys in das Forum importiert und mit den entsprechenden Keys versehen. Durch den Benutzer anpassbare Teile dürften durch einen Update eigentlich nicht angefasst, noch in Abhängigkeit zu einer Installation gebracht werden.

  • Das Backend lässt gleiche/doppelte Smiley codes gar nicht zu :rolleyes:

  • Dann wird sich die Fehlermeldung wohl geirrt haben oder wie soll es sonst dazu gekommen sein? Spaß beiseite: Ohne konkreten Anlass entsteht doch so eine Meldung nicht. Ich hätte mir das zumindest mal genauer angesehen.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!