WoltLab Suite Core: 5.4.0 RC 2 Update fehler

  • Affected Version
    WoltLab Suite 5.4

    Bekomme folgenden Fehler während der Install , die dann Natürlich auch Abricht .

    Requested URL
    POST /acp/index.php?install-package/&t=3fd485399c1f9316bf39f214100e2bf401264e043f7743d6b2d085a635420871-mZnnDIMc/5tETauPXX+SOg==
    Referrer
    https://roughnecks-germany.de/acp/index.php?package-update/
    Error Message
    Unterstützung für WebP-Grafiken in Imagick fehlt
    Type
    RuntimeException
    File (Line)
    /var/www/vhosts/roughnecks-germany.de/httpdocs/acp/update_com.woltlab.wcf_5.4_checkSystemRequirements.php (60)
    Stacktrace
    1. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (84): include(…)
    2. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (59): wcf\system\package\plugin\ScriptPackageInstallationPlugin->run(…)
    3. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (76): wcf\system\package\plugin\ScriptPackageInstallationPlugin->install(…)
    4. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/package/PackageInstallationDispatcher.class.php (792): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    5. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/package/PackageInstallationDispatcher.class.php (153): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    6. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/acp/action/InstallPackageAction.class.php (82): wcf\system\package\PackageInstallationDispatcher->install(…)
    7. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/action/AbstractDialogAction.class.php (73): wcf\acp\action\InstallPackageAction->stepInstall(…)
    8. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/action/AbstractAction.class.php (53): wcf\action\AbstractDialogAction->execute(…)
    9. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/Request.class.php (89): wcf\action\AbstractAction->__run(…)
    10. /var/www/vhosts/roughnecks-germany.de/httpdocs/lib/system/request/RequestHandler.class.php (119): wcf\system\request\Request->execute(…)
    11. /var/www/vhosts/roughnecks-germany.de/httpdocs/acp/index.php (11): wcf\system\request\RequestHandler->handle(…)

    Ist aber Aktiviert .

    • Official Post

    Hallo,


    die installierte ImageMagick-Erweiterung ist unvollständig und unterstützt das WebP-Grafikformat nicht. Bitte wende dich an deinen Anbieter, damit dieser die Bibliothek auf eine halbwegs aktuelle Version aktualisiert. ImageMagick unterstützt bereits seit Jahren WebP.

  • Da gibt es nichts zu verstehen. 5.4 setzt nunmal webp Unterstützung in gd oder imagick voraus

  • Da gibt es nichts zu verstehen. 5.4 setzt nunmal webp Unterstützung in gd oder imagick voraus

    ??? Was soll der Kommentar . Ich habe geschrieben Ich verstehe nicht da es vorher ja ging . z.b: bei der rc1 .

  • ??? Was soll der Kommentar . Ich habe geschrieben Ich verstehe nicht da es vorher ja ging . z.b: bei der rc1 .

    Es geht hier nirgend hervor, dass du vorher die RC1 installiert hattest.

    Es kann natürlich sein, dass die Kompatibilitätsprüfung angepasst wurde.

  • Also Ich hab folgende Version :

    Code
    imagick
    imagick module    enabled
    imagick module version     3.5.0
    imagick classes     Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
    Imagick compiled with ImageMagick version     ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    Imagick using ImageMagick library version     ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org 
  • Das heißt, dass du die 5.4 erst nutzen kannst, wenn gd oder imagick das format webp bei dir unterstützt wird. Entweder selbst ordentlich installieren oder bei Webspace beim Support nachfragen.

  • Also Ich hab folgende Version :

    Code
    imagick
    imagick module    enabled
    imagick module version     3.5.0
    imagick classes     Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
    Imagick compiled with ImageMagick version     ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    Imagick using ImageMagick library version     ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org 

    Das hilft nicht viel. Du musst bei imagick bei der Option ImageMagick supported formats oder bei gd nach WebP Support schauen.

    Bei ersterem muss das Dateiformat dabei stehen, bei gd muss enabled drinstehen.

    „The quieter you become, the more you are able to hear…“ – Kali Linux


    Community & Woltlab News: https://mightful-noobs.de/

    Edited once, last by Xopez ().

  • kann man ImageMagick z.B. in der php.ini irgendwie ausschalten ?


    Die GD Graphics Library unterstützt auf meinen Server WebP .


    Oder muss ImageMagick unbedingt installiert und eingeschaltet sein ?


    Ich habe im ACP unter Allgemein/System die GD Graphics Library (Standard) aktiviert , bringt aber beim Update auf RC2 auch nichts , Fehler bleibt .


    Die RC1 läuft .


    Ich habe erst mal den Provider angeschrieben , mal sehen ob die sich rühren und Imagemagick aktualisieren können. Ich bin bei Webgo .


    Gruß Martin


  • Die Prüfung ist leider unglücklich gebaut. Es wird geprüft, ob die Unterstützung vorhanden ist, wenn imagick oder gd installiert ist. Unabhängig von der Auswahl im ACP.

    Theoretisch musst du nur php-imagick entfernen oder deaktivieren. Dann wäre das Modul weg.

    • Official Post

    ??? Was soll der Kommentar . Ich habe geschrieben Ich verstehe nicht da es vorher ja ging . z.b: bei der rc1 .

    Der Fehler war, dass dies beim Upgrade nicht korrekt geprüft wurde, sondern nur bei der Neuinstallation bzw. der Systemüberprüfung. Mit der RC 2 haben wir die fehlende Prüfung beim Upgrade ergänzt.


    ImageMagick 6.9.7-4 Q16 x86_64 20170114

    Die Version stammt also vom 14. Januar 2017, das ist ziemlich alt.


    kann man ImageMagick z.B. in der php.ini irgendwie ausschalten ?


    Die GD Graphics Library unterstützt auf meinen Server WebP .

    Es würde ausreichen, die PHP-Erweiterung "imagick" zu deaktivieren, diese stellt ImageMagick bereit.

  • Das hilft nicht viel. Du musst bei imagick bei der Option ImageMagick supported formats oder bei gd nach webp support schauen.

    Bei ersterem muss das Dateiformat dabei stehen, bei gd muss enabled drinstehen.


    Also irgendwie ....