PHP Registrierung geht nicht, Kontaktformular und anderes schon

  • Okay Google mit dem wir unsere Mails versenden wollen, hat ja sicher dies DMARC SPif und wird es richtig machen.

    Im Moment kann ich sowieso nichts machen, auf dem anderen Rechner ist meine C: Platte defekt, da sind alle meine Passwörter drauf.

    3 x 2 Terrorbyte Platten sind drin, ausgerechnet C: geht kaputt.

    Komme nur in Endloschleife in Tastaturlayout auswählen und das immer so weiter.

    Firefox habe ich natürlich regelmäßig gesichert, Sicherung ist aber auch auf C:.

    KeePass ist auch auf C:, natürlich auch mit Sicherungen.

  • Mit diesen Einträgen autorisierst du Google überhaupt erst, in deinem Namen irgendwelche Nachrichten zu verschicken, diese Einträge musst du anpassen und nicht etwa Google.

    ich glaub er nutzt einfach stumpf die gmail adresse und keine custom domain. Das ist dann Googles Part.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Mit diesen Einträgen autorisierst du Google überhaupt erst, in deinem Namen irgendwelche Nachrichten zu verschicken, diese Einträge musst du anpassen und nicht etwa Google.

    Ich kann doch nicht in Googles Einstellungen rummachen, ich habe auch gar kein Passwort von Google bekommen. Das würde ich ja mindestens brauchen, wenn ich google neu einstellen soll bei denen.

    Wahrscheinlich gibt es die auch nur in Englisch, da kann ich sowieso nichts mit anfangen.

    ich glaub er nutzt einfach stumpf die gmail adresse und keine custom domain. Das ist dann Googles Part.

    Ich nutze eine neu angelegte gmail adresse, extra für das Forum.

    Funktioniert aber nicht.

    Also funktioniert schon, ich kann von da was schicken und auch von anderen Mail empfangen, aber nicht vom Forum.

    Sowas krieg ich immer, keine Ahnung.

    Bei Namecheap habe ich für die Domain als MX Eintrag. smtp.googlemail.com eingetragen, im ACP unter SMTP auch.

    Name und alles stimmt, was will das Ding jetzt?

    Code
     Enabling TLS failed - Remote SMTP server reported permanent error code: 535 (auth failure.) in reply to '*redacted*' 

    Edited once, last by WH2018 ().

  • Wie sehen denn deine aktuellen Einstellungen im ACP genau aus?


    Mal damit versucht?


    Greetz

    Dark


    Nach dem Update ist vor dem Update. :S

    Edited once, last by Darklord ().

  • Wie sehen denn deine aktuellen Einstellungen im ACP genau aus?


    Mal damit versucht?


    Gerade probiert, Verbindungstest ist erfolgreich, im ACP.

    Ansonsten wie immer, keine Mail kommt an.

    Diese Fehlermeldungen gibt es im ACP, ist von gestern, heute sind noch keine, aber die kommen sicher noch.


    Mon, 03 May 2021 06:22:45 +0000

    Message: Enabling TLS failed

    PHP version: 7.4.16

    WoltLab Suite version: 5.3.7

    Request URI: POST /forum/background-queue-perform/

    Referrer: https://www.xxxxxxxxx.org/forum/

    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15

    Peak Memory Usage: 3060048/134217728

    ======

    Error Class: wcf\system\email\transport\exception\TransientFailure

    Error Message: Enabling TLS failed

    Error Code: 0

    File: /var/www/vhosts/xxxxxxxxx.org/httpdocs/lib/system/email/transport/SmtpEmailTransport.class.php (299)

    Extra Information: -

    Stack Trace: [{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/email\/transport\/SmtpEmailTransport.class.php","line":266,"function":"starttls","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/email\/transport\/SmtpEmailTransport.class.php","line":404,"function":"connect","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/job\/EmailDeliveryBackgroundJob.class.php","line":112,"function":"deliver","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/BackgroundQueueHandler.class.php","line":99,"function":"perform","class":"wcf\\system\\background\\job\\EmailDeliveryBackgroundJob","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/BackgroundQueueHandler.class.php","line":189,"function":"performJob","class":"wcf\\system\\background\\BackgroundQueueHandler","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/action\/BackgroundQueuePerformAction.class.php","line":30,"function":"performNextJob","class":"wcf\\system\\background\\BackgroundQueueHandler","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/action\/AbstractAction.class.php","line":47,"function":"execute","class":"wcf\\action\\BackgroundQueuePerformAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/request\/Request.class.php","line":83,"function":"__run","class":"wcf\\action\\AbstractAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/request\/RequestHandler.class.php","line":107,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/forum\/index.php","line":9,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":[]}]

    ======

    Error Class: wcf\system\exception\ErrorException

    Error Message: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed

    Error Code: 0

    File: /var/www/vhosts/xxxxxxxxx.org/httpdocs/lib/system/WCF.class.php (343)

    Extra Information: -

    Stack Trace: [{"function":"handleError","class":"wcf\\system\\WCF","type":"::","file":"[internal function]","line":"?","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/io\/RemoteFile.class.php","line":119,"function":"stream_socket_enable_crypto","class":"","type":"","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/email\/transport\/SmtpEmailTransport.class.php","line":294,"function":"setTLS","class":"wcf\\system\\io\\RemoteFile","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/email\/transport\/SmtpEmailTransport.class.php","line":266,"function":"starttls","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/email\/transport\/SmtpEmailTransport.class.php","line":404,"function":"connect","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/job\/EmailDeliveryBackgroundJob.class.php","line":112,"function":"deliver","class":"wcf\\system\\email\\transport\\SmtpEmailTransport","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/BackgroundQueueHandler.class.php","line":99,"function":"perform","class":"wcf\\system\\background\\job\\EmailDeliveryBackgroundJob","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/background\/BackgroundQueueHandler.class.php","line":189,"function":"performJob","class":"wcf\\system\\background\\BackgroundQueueHandler","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/action\/BackgroundQueuePerformAction.class.php","line":30,"function":"performNextJob","class":"wcf\\system\\background\\BackgroundQueueHandler","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/action\/AbstractAction.class.php","line":47,"function":"execute","class":"wcf\\action\\BackgroundQueuePerformAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/request\/Request.class.php","line":83,"function":"__run","class":"wcf\\action\\AbstractAction","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/lib\/system\/request\/RequestHandler.class.php","line":107,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxx.org\/httpdocs\/forum\/index.php","line":9,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":[]}]

  • Gerade probiert, Verbindungstest ist erfolgreich, im ACP.

    Ansonsten wie immer, keine Mail kommt an.

    Hast du in deinem GMail Account den IMAP Zugriff überhaupt aktiviert?

    Greetz

    Dark


    Nach dem Update ist vor dem Update. :S

  • Ich wollte mir jetzt von Plesk mit der Passwort vergessen Funktion ein neues Passwort zuschicken lassen.

    Kommt auch nicht an, geht nicht auf eine Mailadresse die irgendwas mit dem Forum zu tun hat.

    Normaler Anbieter, auch kein Google.

    Also scheint der Server nichts zu verschicken, ausser Kontaktformular und Passwort vergessen für Forenmitglieder.


    Nachtrag, Plesk Passwort zuschicken funktioniert aus Plesk direkt heraus, ohne Umweg. Macht aber keinen Sinn, wenn man schon in Plesk eingeloggt ist.

    Als ich gestern keinen Zugriff hatte, wegen verlorener Passwörter funktioniert es ab Einloggseite in Plesk nicht.


    mail.error log sieht so aus.

    Meine Anfrage ist nicht dabei, bei den geblockten.


    May 4 20:11:31 hxxxxxxxx smtp_auth[4307]: Invalid mail address 'barbara'

    May 4 20:11:44 hxxxxxxxx smtp_auth[4309]: Invalid mail address 'vincent'

    May 4 20:14:17 hxxxxxxxx smtp_auth[4324]: Invalid mail address 'direct'

    May 4 20:45:35 hxxxxxxxx smtp_auth[4595]: Invalid mail address 'viper'

    May 4 20:46:58 hxxxxxxxx smtp_auth[4605]: Invalid mail address 'barcode'

    May 4 20:49:15 hxxxxxxxx smtp_auth[4636]: Invalid mail address 'direttore'

    May 4 21:19:36 hxxxxxxxx smtp_auth[5102]: Invalid mail address 'virgil'

    May 4 21:22:27 hxxxxxxxx smtp_auth[5123]: Invalid mail address 'barney'

    May 4 21:24:14 hxxxxxxxx smtp_auth[5131]: Invalid mail address 'dispatch'

    May 4 21:53:53 hxxxxxxxx smtp_auth[5615]: Invalid mail address 'virginie'

    May 4 21:57:53 hxxxxxxxx smtp_auth[5634]: Invalid mail address 'barrie'

    May 4 21:59:08 hxxxxxxxx smtp_auth[5640]: Invalid mail address 'doc'

    May 4 22:28:10 hxxxxxxxx smtp_auth[5913]: Invalid mail address 'visia'

    May 4 22:33:22 hxxxxxxxx smtp_auth[5936]: Invalid mail address 'batman'

    May 4 22:34:05 hxxxxxxxx smtp_auth[5943]: Invalid mail address 'docs'

    Edited 2 times, last by WH2018: Nachtrag hinzugefügt. ().

    • Official Post

    Hallo,

    Error Message: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed

    das Zertifikat des SMTP-Servers konnte nicht validiert werden. Entweder weil das Zertifikat tatsächlich nicht passt oder weil auf dem System kein Zertifikats-Store installiert ist.

  • Also das sind meine Zertifikate.

    Ist für alles eines da.

    Domain ist bei Namecheap.com gehostet, dortiger MX Eintrag ist mail.xxxxxx.org.

    Der _acme_challenge TXT Eintrag von Plesk/LetsEncrypt ist ebenfalls vorhanden.


  • Vielleicht mal bei der SMTP-Verschlüsselung auf "Wenn unterstützt" stellen und den SMTP-Port 465 probieren

    Greetz

    Dark


    Nach dem Update ist vor dem Update. :S

  • Port 465 mit ssl://davor habe ich schon probiert, wird schon im ACP beim Test rot.

    Mehr Zeit will ich damit auch nicht verschwenden, führt ja zu nichts.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!