Emails über eigenen SMTP funktionieren plötzlich nicht mehr

  • Affected Version
    WoltLab Suite 5.2

    Servus,

    der Titel erklärt schon unser Problem. Wir haben als Versandmethode für Emails SMTP eingestellt und nutzen für das Forum einen eigenen Webserver und einen seperaten eigenen Mailserver mit Mailcow. Bis dato funktionierte auch alles einwandfrei.

    Wir haben NIX in den Einstellungen geändert, allerdings kommen vom Forum garkeine Emails mehr an. Weder automatische, noch manuelle.

    Das Senden der Emails mit der dort angegebenen Email Adresse werden sofort gesendet und kommen an. Der Umweg übers Forum funktioniert dann aber halt nicht.

    Ports sind auf beiden Servern freigegeben und der Mailserver funktioniert wie gesagt tadelos. Demnach sind auch alle Records und der Reverse DNS richtig eingerichtet. Es funktionierte ja auch wie gesagt.

    Fehlermeldungen im Forum oder auf dem Mailserver gibt es nicht. Sonst wüsste ich nicht wo. Der Webserver braucht dann ja auch keine Versandmöglichkeiten denke ich ja.

    Das ist halt dieses typische Ding: Es funktioniert, man macht nix, es geht nicht mehr ;(

    Hier die Einstellungen:

    EDIT: Ich habe schon bei Google und hier selbst gesucht, aber keine Lösungen in ähnlichen Beiträgen gefunden. :|

    Falls sonst noch was gebraucht wird, gerne anmerken, dann sende ich das nach.

    Ich danke schon mal für jede Hilfe.

    Mit freundlichen Grüßen

    TheRockZzDe

  • Go to Best Answer
  • Dein Port stimmt? Vielleicht mal einen anderen ausprobieren.

    Oder mal das neue update von Mailcow einspielen habe ich heute auch gemacht. Und ggf. einen reboot des Mailserver...

  • Wird die Warteschlange für Aufgaben im Hintergrund denn abgearbeitet, also hat die Tabelle wcfX_background_job gegebenfalls noch Inhalt?

    Das System versucht E-Mails im Fehlerfall mehrfach an den konfigurierten Mailserver zuzustellen. Solange die Versuche noch nicht alle durch sind, wird auch kein Fehler geloggt soweit es mir bekannt ist.

  • Oha, danke für die ganzen Antworten, ich versuche mal auf alles einzugehen.

    Zu Anfang gesagt, ich habe alles selbst aufgesetzt und pflege auch alles selbst. Da ich mir aber alles selber durch probieren oder durch Online Beiträge beibringen musste, bin ich nicht der erfahrenste in den Bereichen. Hab halt, kann man so sagen, etwas erweitertes Basiswissen. ^^

    Dein Port stimmt? Vielleicht mal einen anderen ausprobieren.

    Oder mal das neue update von Mailcow einspielen habe ich heute auch gemacht. Und ggf. einen reboot des Mailserver...

    Port stimmt, habe 25, 587 und 465 inkls. keiner Verschlüsselung, wenn unterstützt und aktiviert ausprobiert. Die Settings sind so, wie Sie funktionieren. Andere Settings funktionieren bei mir nicht. Nur mit den Settings funktioniert der Verbindungstest.

    Mailcow ist jetzt Up-to-date und neugestartet, aber dennoch keine Lösung dadurch.

    Wird die Warteschlange für Aufgaben im Hintergrund denn abgearbeitet, also hat die Tabelle wcfX_background_job gegebenfalls noch Inhalt?

    Das System versucht E-Mails im Fehlerfall mehrfach an den konfigurierten Mailserver zuzustellen. Solange die Versuche noch nicht alle durch sind, wird auch kein Fehler geloggt soweit es mir bekannt ist.

    Das kann ich nicht ganz nachvollziehen. Die Ausgabe ider verdammt lang. Dort steht aber auch sowas wie "wcf\system\background\job\EmailDeliveryBackgroundJob". Bin aber mit MySQL auch nicht soo erfahren.

    Hast du php8 im Einsatz und eventuell ein bearbeitete Email template?

    Wenn ja könnte ein Fehler im template sein (war bei mir auch so):

    PHP8 - Mailversand

    Nein, auf dem Webserver läuft PHP 7.3.25 und auf dem Mailserver kann ich es nicht sagen. Ich denke aber nicht, dass es php8 ist. Ist mailcow mit docker containern, leider bin ich mit docker nicht so erfahren.

    Template ist bearbeitet aber halt nur der HTML Code im Footer Bereich. Hab die Texte und ein Bild geändert. Mehr nicht, Rest ist gleich geblieben.

  • Mailcow nutzt aktuell noch kein php8 aber das hier auch nicht wichtig.

    Versuch mal im Email template das Standart zu nutzen, vielleicht geht's dann wieder war bei mir nämlich ähnlich, falls es dann nicht funktioniert kannst das wenigstens ausschliessen 😉

    Was sagt der SMTP test im ACP?

    ┌П┐(◉_◉)┌П┐

  • Hast du denn was an deinem Mailserver umgestellt? Bei mir läuft alles.

    Sonst starte Mailcow doch mal neu. ocker-compose down oder docker-compose restart nginx-mailcow und dann noch ein docker-compose up -d

  • Mailcow nutzt aktuell noch kein php8 aber das hier auch nicht wichtig.

    Versuch mal im Email template das Standart zu nutzen, vielleicht geht's dann wieder war bei mir nämlich ähnlich, falls es dann nicht funktioniert kannst das wenigstens ausschliessen 😉

    Was sagt der SMTP test im ACP?

    Uh da muss ich erstmal das Standard Template aus der Downloaddatei raussuchen. Hab das Template nicht kopiert sondern in den Dateien selbst bearbeitet und halt Texte im Footer eingefügt. Aber ich probier es mal.

    Der SMTP Verbindungstest funktioniert einwandfrei und verbindet sofort.

    Hast du denn was an deinem Mailserver umgestellt? Bei mir läuft alles.

    Sonst starte Mailcow doch mal neu. ocker-compose down oder docker-compose restart nginx-mailcow und dann noch ein docker-compose up -d

    Neugestartet habe ich bereits mehrfach. Nach dem Update hatte ich aber noch ein Problem mit dem Mailserver. Der zeigt mir das Webinterface nicht mehr an sondern nur den Text "2021". Kam da noch nicht weiter. Bedeutet aktuell kann ich da nicht rein.

  • Update: Es lag am Template.
    Zur Info: Ich habe wie gesagt das HTML Email Template manuell in den Dateien bearbeitet und nicht per ACP eine Kopie bearbeitet. Hab das jetzt so gemacht und funktioniert mit dem über ACP bearbeiteten Template.
    Danke TeRRible__KHONS für den Tipp und danke euch allen für die Hilfe! <3

  • sondern in den Dateien selbst bearbeitet

    Das sollte man unter anderem wegen solchen Gründen nicht machen :) am besten immer im ACP in templategruppe kopieren und bearbeitet dann kann man auch besser vergleichen :)

    Bitte, hatte wie gesagt das gleiche Problem und war ratlos ☺️

    ┌П┐(◉_◉)┌П┐

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!