Mehrsprachigkeit nachträglich aktivieren

  • Guten Abend,

    Nach längeren überlegungen wurde sich dazu entschieden die Webseite sowohl in Deutsch, und nun neu auch in Englisch anzubieten.

    Also eine zweite Installation aufgesetzt in der die Englische sprache von anfang an vorhanden ist und alle Plugins, die auch im live system vorhanden sind, installieren.

    Anschliessend die Englische Sprache exportieren und im live system importieren.



    Merkwürdigerweise gibt es wesendlich mehr Englische als Deutsche Sprachvariablen nach dem import..

    Neugierigerweise mal die Englische sprache exportiert und mit der gerade importierten sprache verglichen..

    Für den zahlen unterschied irrelevant, aber ich habe sehr schnell erkannt, dass sehr viele Texte auf Deutsch vorhanden waren.. Kategorie namen und Beschreibungen, Optionen, Felder etc.

    Fauler Admin denkt sich, kannst die beiden Sprachdaten mal weiterleiten, damit diese übersetzt werden, brauchste im ACP nicht so viel rumhantieren zum übersetzen.


    Mal 20-30 Texte angepasst, Sprache reimportiert und etwas verdattert festgestellt, scheinbar nix passiert, keine neue Sprache aufgetaucht.

    Bestehende englische Sprache stichprobenartig überprüft, die Geänderten sachen wurde überschrieben, dass ich ja toll!!


    Nachdem die gesammte Sprachdatei übersetzt und reimportiert wurde, haben wir im Frontend kaum Änderungen festgestellt...

    Für mache sachen wurden die geänderten Variablen übernommen, für mache nicht.


    Nochmal fauler Admin denkt sich, lösche die Englische sprache halt noch mal und importierst sie -> keine Änderungen festgestellt, selbes spielchen wie davor.

    Nun im ACP mal ein wenig umhergeguckt und verschiedenes Festgestellt:


    In den Kategorien des Forums gibt es Kategorien, die noch auf monolingual stehen, andere sind auf Deutsch und Englisch vorhanden. (Wie in der sprachdatei angegeben)

    In der Gallery waren zwei Beschreibungen leer, Editor stand auf monolingual in den sprachvariablen waren jedoch beide sprachen gepflegt...

    Menupunkte, wie die Foren Kategorien, manche sind übersetzt, manche nicht..


    Quer durch alle Plugins ist sowas aufgefallen...

    ---

    In diesem Bugreport geht es hauptsächlich um das Reimportieren von sprachdaten..

    Beim importieren einer Sprache die bereits vorhanden ist, werden die Sprachvariabelen scheinbar nur "sporalisch" überschrieben, andere bleiben wie sie sind...


    Ein besserer ablauf wäre meiner Meinung nach:

    Es sollte eine trennung zwischen Sprache importieren und Sprache reimportieren geben.

    Wird beim Importieren einer neuen sprache festgestellt, dass diese bereits vorhanden ist, sollte es eine Meldung geben, dass in so einem fall innerhalb der sprache eine reimport funktion benutzt werden soll. Entsprechend sollte in der Sprache ein reimport vorhanden sein, in dem prozess werden dann alle Variablen bedingungslos überschrieben... Eventuell noch eine option, dass der import als Custom Content importiert werden soll..


    Fazit:

    Wenn es die IDs von Usern, Posts, Threads und allen anderen Plugins nicht zerhauen würde, hätte ich einen Import in eine Neuinstallation hinterhergeschoben, System hatte ich ja eh schon für die Sprachvariablen aufgesetzt gehabt.

    Ich empfehle niemanden die Mehrsprachigkeit im nachinein zu aktivieren...

    Let's Mine Minecraft Community Server Projektleiter
    KleinCrafter