Fehler „ Array and string offset access syntax with curly braces is deprecated“

  • Affected Version
    WoltLab Suite 3.0

    Ich habe seit heute auch folgenden Fehler:


    Error

    • Error Type:

      wcf\system\exception\ErrorException

    • Error Message:

      Array and string offset access syntax with curly braces is deprecated

    • File:

      */lib/system/WCF.class.php (335)

    Mein Hoster (Hosteurope) hat heute auf PHP 7.4 umgestellt von 7.2, kann es sein das hier das Problem liegt? Hab ehrlich gesagt keine Update gemacht, weil alles gut gelaufen ist.

    Edited 2 times, last by Saar-Kai ().

  • Gibt es einen Grund dafür, dass Du nicht die aktuelle Version 3.0.24 verwendest?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Nö eigentlich nicht. Hatte halt damals nach der Installation nichts mehr an der SW gemacht, weil soweit alles gut funktioniert hatte.

    Kann meine Aktuelle Version kein PHP7.4?

    Wenn ja gibt es eine Möglichkeit es nachträglich noch upzudaten?

  • Sofern sein Hoster dir nicht temporär PHP 7.2 wieder aktivieren kann, ginge es nur, wenn du das beispielsweise lokal machst (oder machen lässt).

  • Jo danke für dein Angebot, hab aber eben festgestellt das meine Seite doch wieder erreichbar war durch umstellen auf alternativ PHP 7.3, hatte scheinbar bissel gedauert.

    Hab es jetzt auf 3.0.25 upgedatet.

    Das scheint ja auf 7.4 zu laufen. Jedenfalls ist die Seite noch erreichbar obwohl ich wieder auf 7.4 umgestellt habe im KIS.

  • Würde das ähnlich ablaufen wie ein Update?

    Welche Version wäre ratsam?

    Wenn du die bald erscheinende Version 5.3 mitnehmen willst, dann wäre ein Upgrade auf die Version ratsam.

  • Naja ich brauch nix besonderes, bin mit der 3.0 so auch zufrieden, nur die rasenden PHP Versionen machen mir da sorgen.

    • Official Post

    Hallo,


    mit neuen Versionen kommem nicht nur neue Funktionen, sondern wir pflegen die Software auch aktiv und passen diese an neue PHP- und MySQL/MariaDB-Versionen an. Die Versionen 3.1, 5.2 und die in diesem Monat erscheinende Version 5.3 sind alle technisch mit der Version 3.0 verwandt, der Umstieg ist somit relativ einfach.


    Im Handbuch haben wir im Abschnitt Updates die einzelnen Schritte erläutert, in deinem Fall erst von 3.0 auf 3.1 und dann von 3.1 auf 5.2.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!