Trying to get property 'className' of non-object - Durch löschen des Caches ist der Fehler wieder weg

  • Affected App
    WoltLab Suite Core
    Requested URL
    /
    Referrer
    https://www.trlevel.de/forum/index.php?board/10-tomb-editor-levelbau/
    WoltLab Suite
    5.2.6
    PHP
    7.4.5
    Error Message
    Trying to get property 'className' of non-object
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /www/htdocs/ORDNER/lib/system/WCF.class.php (341)
    Stacktrace
    1. /www/htdocs/ORDNER/lib/data/user/activity/event/ViewableUserActivityEventList.class.php (67): wcf\system\WCF::handleError(…)
    2. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (352): wcf\data\user\activity\event\ViewableUserActivityEventList->readObjects(…)
    3. /www/htdocs/ORDNER/lib/system/box/RecentActivityListBoxController.class.php (164): wcf\system\box\AbstractDatabaseObjectListBoxController->readObjects(…)
    4. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (326): wcf\system\box\RecentActivityListBoxController->readObjects(…)
    5. /www/htdocs/ORDNER/lib/system/box/AbstractDatabaseObjectListBoxController.class.php (293): wcf\system\box\AbstractDatabaseObjectListBoxController->loadContent(…)
    6. /www/htdocs/ORDNER/lib/system/box/RecentActivityListBoxController.class.php (131): wcf\system\box\AbstractDatabaseObjectListBoxController->hasContent(…)
    7. /www/htdocs/ORDNER/lib/data/box/Box.class.php (291): wcf\system\box\RecentActivityListBoxController->hasContent(…)
    8. /www/htdocs/ORDNER/lib/data/box/Box.class.php (276): wcf\data\box\Box->hasContent(…)
    9. /www/htdocs/ORDNER/templates/compiled/0_wcf_1_cms.php (1895): wcf\data\box\Box->render(…)
    10. /www/htdocs/ORDNER/lib/system/template/TemplateEngine.class.php (334): include(…)
    11. /www/htdocs/ORDNER/lib/page/AbstractPage.class.php (323): wcf\system\template\TemplateEngine->display(…)
    12. /www/htdocs/ORDNER/lib/page/AbstractPage.class.php (114): wcf\page\AbstractPage->show(…)
    13. /www/htdocs/ORDNER/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    14. /www/htdocs/ORDNER/lib/system/request/RequestHandler.class.php (107): wcf\system\request\Request->execute(…)
    15. /www/htdocs/ORDNER/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Diese Meldung kam gerade, ist aber durchs löschen des Cachs auch wieder verschwunden. Ist wie ich der Fehlermeldung entnehmen kann auch kein Problem eines Plugins, sondern vom WCF selber -> RecentActivity etc.

    Evtl. steht für WoltLab etwas wichtiges mit in der Fehlermeldung, weshalb dies auftritt, damit man das ggf fixen kann.


    Edit: Irgend was ist gerade im Busch bei mir. Jetzt hagelt es laufen weiter Fehlermeldungen, auch zu der WL Filebase usw ( 

    Use of undefined constant FILEBASE_ENABLE_SELLING - assumed 'FILEBASE_ENABLE_SELLING' (this will throw an Error in a future version of PHP)), aber auch da konnte man was dagegen tun, durch das löschen der "options.inc.php" Datei.

    Edited 2 times, last by illyaine (June 3, 2020 at 9:23 AM).

  • illyaine June 3, 2020 at 9:11 AM

    Changed the title of the thread from “Trying to get property 'className' of non-object” to “Trying to get property 'className' of non-object - Durch löschen des Caches ist der Fehler wieder weg”.
  • Die Fehlermeldung impliziert, dass eine Aktivität gab, für die kein dazugehöriger Objekt-Typen vorlag. Abseits von defekten Fremdschlüsseln kann dies auch durch veraltete Caches entstehen, verwendest du den Cache über das Dateisystem oder memcached/Redis?

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Alexander Ebert June 5, 2020 at 12:51 PM

    Added the Label Feedback required
  • Standard Einstellung -> Dateisystem

    Der Cache wird bei mir eigentlich alle paar Tage mal geleert.

    Installiert an Plugins wurde schon länger nicht mehr, als letztes war es die WoltLab Filebase.

  • Ließe sich ggf. über den Support von all-inkl erfragen.

    Manchmal sind tatsächlich auch nicht-kommunizierte Änderungen an Server-Settings für Effekte verantwortlich, die man sich auf den ersten Blick nicht erklären kann.

    Wenn Du (außer der Filebase) tatsächlich keinerlei Veränderungen an Core bzw. Forum vorgenommen und auch keine neuen Plugins installiert hast, bleibt für mich fast nur diese Begründung.

    Denn entgegen anders lautender Gerüchte haben ja Computer/Foren/Server etc. eigentlich kein Eigenleben und ändern auch nicht selbsttätig ihre Settings. Malware jetzt mal außen vor, aber selbst das wäre ja schon wieder ein kontrollierter Eingriff und kein "Eigenleben".

    Gruß

    Jörg

    (Jaydee)

  • Alexander Ebert June 30, 2020 at 4:36 PM

    Set the Label from Feedback required to Cannot reproduce

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!