Fehler beim Update vom Core

  • Affected Version
    WoltLab Suite 5.2

    Servus @all

    Ich nutze den Videcode Shop mit der Woltlab Core. Zurerst habe ich den Shop auf die neuste Version hochgezogen. Danach habe ich die Woltlab Core Version versucht auf die neuste hochzuziehen. Leider bekomme ich dabei einen Fehler. Der Shop geht nicht mehr bzw. die komplette Seite samt ACP.

    Requested URL
    /acp/index.php?install-package/&t=73655e5951cdec4585468eec9546b3b4cc3fa633
    Referrer
    https://stick2bike.de/acp/index.php?package-update/
    WoltLab Suite
    5.2.0
    PHP
    7.3.12-1+0~20191128.49+debian10~1.gbp24559b
    Error Message
    Infinite loop detected while trying to retrieve object for 'wcf\system\request\ControllerMap'
    Type
    wcf\system\exception\SystemException
    File (Line)
    /var/customers/webs/stick2bike/lib/system/SingletonFactory.class.php (60)
    Stacktrace
    1. /var/customers/webs/stick2bike/lib/system/request/LinkHandler.class.php (217): wcf\system\SingletonFactory::getInstance(…)
    2. /var/customers/webs/stick2bike/lib/data/user/User.class.php (556): wcf\system\request\LinkHandler->getLink(…)
    3. /var/customers/webs/stick2bike/acp/templates/compiled/0_wcf_1_userException.php (230): wcf\data\user\User->getLink(…)
    4. /var/customers/webs/stick2bike/lib/system/template/TemplateEngine.class.php (334): include(…)
    5. /var/customers/webs/stick2bike/lib/system/exception/NamedUserException.class.php (39): wcf\system\template\TemplateEngine->display(…)
    6. /var/customers/webs/stick2bike/lib/system/exception/IllegalLinkException.class.php (31): wcf\system\exception\NamedUserException->show(…)
    7. /var/customers/webs/stick2bike/lib/system/request/RequestHandler.class.php (110): wcf\system\exception\IllegalLinkException->show(…)
    8. /var/customers/webs/stick2bike/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Kann mir da jemand helfen?

    VIele Grüßen und Danke

    jason

  • Guten Tag,

    am besten erstellst du mal ein Ticket hier, weil du kommst ja nicht mehr auf deine Seite sowie auf das ACP und ich denke, dass WoltLab da die Zugangsdaten vom FTP / deinem Server anfordern wird, da sie sich das bestimmt genauer anschauen müssten...

  • Mhh,

    wenn man sich nicht ernsthaft viel damit beschäftigt hat stellen solche Dinge echte Hindernisse da.

    Bei mir kommt ebenso nur ein Haufen Fehler

    Nun habe ich einige Erweiterungen von WoltLab und die meisten Plugins auch hier über den store gekauft. Da steht so eine gewisse Erwartung, dass jenes etwas mehr out of the box flutscht.

    Ich sehe eine Anleitung:

    RE: WoltLab Suite 5.2 Veröffentlichung

    OK

    Jedoch wäre es schön zu sehen was man am besten machen sollte, wenn über den eigenen Store Plugins installiert wurden.


    Vielleicht stehe ich ja etwas auf dem Schlauch, aber eine Aktuelisierung des WoltLab Suite Core's wurde nicht angeboten.

    Frank

  • Die Fehlermeldung besagt, dass das Plugin noch nicht kompatibel ist. Einfach warten bis der Plugin Autor dad nachgezogen hat, dann steht dem Update nichts im Wege.

    Du willst ja nicht, dass du einen neuen Core hast, aber das deine Erweiterungen nicht gehen... Deswegen einfach etwas gedulden...

  • Die Fehlermeldung besagt, dass die Version 5.2.0 des Bots kein direktes Update von der Version 3.1.6 pl1 unterstützt. Erstaunlich daran ist, dass anscheinend weder im hiesigen Pluginstore noch direkt bei Udo auf der Seite eine neuere Version als die 3.1.6 pl1 angeboten wird.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Erstaunlich daran ist, dass anscheinend weder im hiesigen Pluginstore noch direkt bei Udo auf der Seite eine neuere Version als die 3.1.6 pl1 angeboten wird.

    Es gibt eine im Shop 'unsichtbare' 5.2.0 RC 1 auf meinem Update-Server. Aber warum in der Fehlermeldung 5.2.0 auftaucht, verstehe ich auch nicht wirklich.

    Egal, das Update wird nachher noch in den Store hochgeladen.

    Gruß, Udo

  • Moin moin!

    Der Fehler wird vermutlich vor dem Schreibtisch sitzen :)

    Ich habe die 2019er Update Server mal deaktiviert, da sonst weiter die obige Fehlermeldung erscheint.


    Nun kommt natürlich folgende Fehlermeldung mit dem Updateversuch der UZ Plugins

    Wenn ich die aktuellen update Server drin lasse bleibt bei obiger Fehlermeldung mit dem Update von der Version 3.1.6 pl1 ....

    Ich kann mich gerne noch Tage / Wochen gedulden.

    Alternativ die Frage ob ich vielleicht etwas falsch mache ;)


    Gruß und Dank

    Frank

  • Liftboy Du stehst nicht alleine da, habe nun erfahren das es nicht an UdoZ liegt sondern am WSC selber....Finde aber hier kein Hinweis von @WL um eine Lösung zu finden?!

    Ich habe noch so einige Paket-Server die trotz neuem Kennwort bei 0 stehen,..... usw.

  • Leider bekomme ich dabei einen Fehler. Der Shop geht nicht mehr bzw. die komplette Seite samt ACP.

    Ich hatte beim Testen einen ähnlichen Fehler und habe ewig nach Ursachen gesucht. Letztlich habe ich dann festgestellt, dass es für den Update-Prozess absolut wichtig war bzw. ist, dass in der Datenbank keine Spuren von vorherigen Versuchen vorhanden sein durften.

    Warum sage ich das? Weil mein Script für das Wiederherstellen (eines vorherigen Backups) von Datenbank + Dateien in der Test-Installation bisher immer nur die vorhandenen Tabellen in der zugehörigen Datenbank geleert hat. Dies war nicht ausreichend. Die Datenbank musste absolut "sauber" sein. Dann lief das Update ohne Probleme durch. Dieses Problem hatte ich so früher noch nicht.

    Gruß aus Südhessen

  • Servus Donner

    vielen Dank für deine Antwort und ebenfalls Grüße aus dem Osten des Rhein-Main-Gebiets^^.

    Ich habe via Konsole sämtliche Dateien gelöscht. Die Datenbank habe ich ebenfalls komplett geleert bzw. alle Tabellen gelöscht. Vorher hatte ich noch nie ein Backup eingespielt.

  • Vielleicht wurde es ja jetzt mit dem Update auf WSC 5.2.1 verbessert. Wurde ja vorhin auf Woltlab gemacht.

    Oh cool. Gleich mal schauen ob das Core auch ein Update bekommen hat und der Fehler somit behoben ist.

    //edit: Core hat noch kein Update bekommen

    Edited once, last by jason84 (January 9, 2020 at 7:14 AM).

  • Es dauert für den Durchschnittsbürger wie mich immer etwas bis verstanden wird wie der Hase in Ansätzen läuft ;)

    Nachdem ich ein paar Plugins deinstalliert habe, steht noch etwas Wartezeit für den Multihunter aus.

    Ich war mal so frei und habe die "alten" update Server raus geworfen:

    den cache gelöscht...

    Dennoch kommt weiter jene Fehlermeldung:

    Mit den aktuellen update Servern:

    Was erzeugt denn so diese obige Fehlermeldung?

    VG

    Frank

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!