Fehler bei Update von 4.0 auf 4.1

  • Hallo,

    ich bekomme bei einem Update folgende Fehlermeldung

    Meine bisherige Installation ist

    Burning Board 4.0.13

    Community Framework 2.0.15 pl1

    PHP ist 7.2

    MySQL Version 5.6.45-86.1-log

    Das Paket das installiert werden soll ist

    4.1.21

    Ich habe das Update als .gz heruntergeladen und wollte es so installieren.

    Ein Versuch es direkt über die "Paket-Aktualisierung" zu machen ist ebenfalls gescheitert. Die Fehlermeldung dazu habe ich nicht mehr, aber ich musste ein Restore der Datenbank und aller Dateien machen um alles überhaupot wieder zum laufen zu bringen.

    Für eure Hilfe wäre ich sehr dankbar.

  • PHP 7.2 ist zu neu, für das Update muss mindestens auf PHP 7.1 zurückgestellt werden:

    • Burning Board 4.0: PHP <= 7.1
    • Burning Board 4.1: PHP <= 7.2
    • WoltLab Suite 3.0 oder neuer: PHP 7.3+

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Ich kann aber nicht auf 7.1 zurück stellen weil mein Hoster 7.1 komplett abgestellt hat.

    Weil das Forum deshalb nicht mehr richtig funktioniert wollte ich ja jetzt das Update machen.

  • OK.

    Da ich sowieso dann weiter auf das Forum 5.0 updaten wollte, werde ich wohl gleich dieses Installieren.

    Können dort dann ohne Probleme die Foren, Themen und Mitglieder vom BB 4.0 importiert werden?

  • Man sollte aber erwähnen, dass ein Import mit Datenverlust verbunden ist. Es werden nur ausgewählte Inhalte importiert. Als Beispiel können Likes von Forenbeiträgen importiert werden. Likes von Pinnwand Kommentaren dagegen nicht. Es gibt im Zweifelsfall immer Daten, die bei einem Import verloren gehen. Darüber sollte man sich vorher im Klaren sein.

    Edited once, last by ReeN (November 3, 2019 at 8:22 PM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!