Problem mit Navigationspfade-Markup

  • Affected Version
    WoltLab Suite 3.1

    Grüßt Euch,

    mittels Google Console habe ich gerade folgenden Hinweis bekommen, so dass ich Euch fragen möchte, wie man dieses beheben kann.

    Es dreht sich dabei um die Seite 3DFans.de


    Code
    Die Systeme von Google zeigen, dass Ihre Website von 53 Instanzen mit Navigationspfade Markup-Problemen. betroffen ist. Das bedeutet, dass Ihre Navigationspfade-Seiten nicht als Rich-Suchergebnisse in der Google-Suche angezeigt werden.
    
    Search Console hat einen neuen Bericht für ausschließlich diesen Rich-Suchergebnistyp erstellt. Mithilfe des neuen Berichts können Sie die betroffenen Seiten identifizieren, die Fehler auf ihnen korrigieren und die Seiten dann noch einmal an Google senden, sodass sie wieder als Rich-Suchergebnisse angezeigt werden.
  • Hallo,

    genau dazu wollte ich auch gerade ein Thema eröffnen.
    Seit ein paar Tagen scheint es ein Problem mit den "navigationspfaden" zu geben. Laut Google Search Console gibt es ein Problem mit

    Quote

    Feld "position" fehlt

    Bei genauem Check wird folgender Code farblich hinterlegt angezeigt:

    Code
    <li title="TT-Modellbahnforum" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
                                <a href="https://tt-modellbahnforum.de/" itemprop="item"><span itemprop="name">TT-Modellbahnforum</span></a>
                            </li>

    Dieser Code steht im Kontext mit der Breadcrumbanzeige. Dabei ist bei uns (denke ich mal) auffällig, dass es im Quelltext 2 hintereinander liegende Navigationspfade gibt durch Nutzung des Plugins "PowerSettings"?
    Ich setze hier mal den Quelltext der Breadcrumbsachen rein:

    Alle Listenpunkte unterhalb der gestrichelten Linie werden von der GoogleSearchConsole angemeckert, alles darüber liegende nicht.
    Kann da jemand einen Tip geben, was da los ist, vielen Dank.

  • Hm, würde das nicht eine Update-Fähigkeit der 3.1 verhindern. Es ist noch nicht raus, dass wir umstellen auf 5.2, von daher wäre mir eine passende Lösung, zur entsprechenden Version lieber. Oder habe ich da jetzt etwas falsch verstanden?


    Andere Frage, da Du scheinbar so schnell eine Lösung schreiben kannst, ist das ein bereits bekanntes Problem?

  • Habe es heute früh mal so geändert, Einschränkungen in den Funktionen scheinen keine zu sein. Mal schauen was Tante G nun dazu meint.

  • Ich hab die Templateänderung aus dem PR von Softcreatr übernommen, der Test verlief positiv und gerade rattert die Fehlerbehebung durch :)

  • Hallo,


    gibt es von WoltLab selbst schon eine Aussage zum bestehenden Problem?
    Oder muss man sich in der Sache selbst behelfen und den Code abändern?

    Gruß Elektron

  • Ich gehe einfach Mal davon aus, dass WoltLab die vorgeschlagenen Änderungen anstandslos übernehmen wird, da diese keine negativen Seiteneffekte hervorrufen. Bis dahin kann man einfach die Änderungen von mir 1:1 übernehmen.

  • Ich möchte auch nicht selbst irgendwo etwas am Code ändern.

    Am Original Template musst du ja nichts ändern. Du müsstest ja nur für deinen Stil eine Kopie des Templates erstellen und dort die Änderung einfügen. Diese Kopie kannst du dann jederzeit wieder löschen. Also kaputtmachen kannst du damit nichts. Falls es Fehler gibt -> Kopie des Templates löschen und alles ist wieder so wie es vorher war.


    Siehe auch hier:

    Anpassung von Templates

  • Ich gehe mal von aus dass das Thema einfach unter den Tisch gekehrt wird? Die Fehler sind weiterhin vorhanden...

    Warum? Wenn es ein Fehler in der Software ist, sollte man es auch im entsprechenden Fehlerforum melden oder das Thema dorthin verschieben lassen. Hier ist der falsche Bereich.

  • Ach, alles klar. Ich wusste nicht das Woltlab nur reagiert wenn das Thema im richtigen Bereich ist. Zumal ich nicht mal weiß ob es ein Fehler von der Software ist oder Google sich einfach nur anstellt. Wenn es also kein Fehler der Software ist, wäre man jetzt auch im richtigen Bereich? Vielleicht sollte man das erstmal abklären bevor man das als Fehler mit einem neuen Thema, im richtigen Bereich, deklariert.


    Man lernt halt nie aus. Deshalb hatte Marcel Werk auch nicht geantwortet als ich ihn quasi direkt hier im Thema angeschrieben habe.


    Nun gut, ich bin damit raus.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!