Login mit Google

  • Nutzerkonto war früher mit Google verbunden. Verbindung wurde irgendwann gelöst und das Passwort gewechselt.

    Jetzt wollte der Nutzer sein Konto wieder mit Google verbinden. (Bei Facebook geht das.)

    Unten ist ein Auswahlkasten "Mit Google verbinden". Der Reiter wird ausgewählt.

    Software will noch das alte, aktuelle Passwort wissen (ganz oben)

    Nach dem Absenden wird folgender Fehler!


    Requested URL
    /facebook-auth/?code=AQDkh2X81TrC7uMldlpkEgvkWpZv92qoM0oRtRzZKxWfTjuOi937J9qBFv0OXIrZ32Khxn-RGsPUmdRDJ_9aQ0pCTrEfN5vqkuCEu-N5LbJUD2O5JXUNHqahzLbXe-e4ABIW5Xa7us_DG49CNKEgyKURKr0-OsRPzP-7UbXiIxDebsAlKp2Qwgkkow_3URdCx3h9rJsBpKk893i0C15zHKUMP4DJgfmYBMrmjpYgOUNSvbsJxMOPMNNQBGD31deEw-JoEYCIAa9kJn4xIkmlDbQGozJFRffIrCCE-8LMukNwzFOHy2kBUtfG2ukkDk-_V6ieMM0whSi6EX3ab1rK6QXnRIxPUHSd_SYi4bPW8_dQ8A&state=a97632bcd586f2d232715b53c62ae6af03da98a7
    Referrer
    Error Message
    Received unhandled status code '400' from server
    Type
    wcf\util\exception\HTTPException
    File (Line)
    /var/www/vhosts/domain.info/httpdocs/lib/util/HTTPRequest.class.php (579)
    Body
    {"error":{"message":"This authorization code has been used.","type":"OAuthException","code":100,"fbtrace_id":"EUKhMle6N6X"}}
    Status Code
    400
    Stacktrace
    1. /var/www/vhosts/domain.info/httpdocs/lib/util/HTTPRequest.class.php (390): wcf\util\HTTPRequest->parseReply(…)
    2. /var/www/vhosts/domain.info/httpdocs/lib/action/FacebookAuthAction.class.php (49): wcf\util\HTTPRequest->execute(…)
    3. /var/www/vhosts/domain.info/httpdocs/lib/action/AbstractAction.class.php (47): wcf\action\FacebookAuthAction->execute(…)
    4. /var/www/vhosts/domain.info/httpdocs/lib/system/request/Request.class.php (83): wcf\action\AbstractAction->__run(…)
    5. /var/www/vhosts/domain.info/httpdocs/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    6. /var/www/vhosts/domain.info/httpdocs/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Edited once, last by Bourbon ().

  • In Fehlermeldung steht Facebook komischerweise, obwohl es um Google geht.

    Bzw. es steht oben Google-Mediapartners und im Fehler /facebook-auth/

    ???? Wurden hier vielleicht Google und Facebook vermischt?

  • Ein User bzw. Bot mit dem User-Agent "Mediapartners-Google" hat versucht, sich via Facebook zu authentifizieren. Deswegen die Verwirrung.


    Einen Fehler in der Google-Authentifizierung gab bzw. gibt es dennoch, allerdings nicht im Login-Prozess, sondern in der Account-Verwaltung.

  • Marcel Werk

    Added the Label 2.1.24 pl 2
  • Marcel Werk

    Added the Label 3.0.20 pl 1
  • Funktioniert gut jetzt. Danke.

    Hätte noch eine kurze Frage zu der Funktion hier.


    Der User hat jetzt sein Konto erfolgreich mit Google-Login verbunden.

    Er hatte zuvor vor längerer Zeit sein Passwort gewechselt. Jetzt sagt er, dass er sich mit Google anmelden kann und auch mit seinem Passwort.

    Nur fürs Verständnis: Das Konto hat jetzt 2 verschiedene Passwörter:

    1. Das von Google, das man nur bei Google bearbeiten kann.

    2. Das von Woltlab, bzw von meinem Forum.

    Ist nicht schlimm, das ist sogar eine coole Sache. :thumbup:

    1. Account und zwei PW. :)

    Edited 3 times, last by Bourbon ().

  • Dann wäre es noch ein Fehler ;)

    Weiss das schon länger und empfand es als positiv, weil man sich so auch mal schnell einloggen kann.

    Soviel ich weiss, ist das auch bei Facebook so und eventuell bei Twitter.

    Dann ist es ein globaler Fehler. Habs hier mal als neuen Fehler eingestellt.

    Schade, wenn es weg ist. :(

    Edited 2 times, last by Bourbon ().

  • Das ist kein Fehler, sondern bewusst so umgesetzt. Das Kennwort wird bei jedem Login via Drittanbieter automatisch per Zufall neu generiert.

  • Ja, das ist das eine.

    Das andere ist, dass man sich trotzdem noch mit altem PW einloggen kann.

    Dann können sie es als "gewollt" canceln.