Hilfe beim anpassen eines Paketes/Plugin

  • Affected Version
    WoltLab Suite 3.1

    Hallo leute,


    ich benötige Hilfe beim anpassen eines älteren Pakets. Es handelt sich um ein Plugin welches die Dedicated Server im Forum anzeigt, ob Online und diverse Statistiken, etc. Der Spielentwickler hat diese selbst mal geschrieben im Jahre 2014 und seitdem nicht wieder weiterentwickelt / angepasst X/


    Ich hatte zuletzt noch etwas Hand angelegt um Kleinigkeiten zu verbessern. Nun jedoch mit der Core 3.1.6 klappt die installation nicht mehr (Testumgebung). Es kommt dann gleich


    Code
    Das Paket verfügt über keine Angaben zur API-Kompatibilität, eine Installation mit aktivierten Entwickler-Werkzeugen ist daher nicht möglich.

    Ich habe dann in der package.xml folgendes hinzugefügt


    XML: package.xml
    <compatibility>
            <api version="2018" />
    </compatibility>

    Nun installiert er das Plugin auch, jedoch nur bis zum folgenden Error



    Würde mir da jemand weiterhelfen und das ggf. anpassen? Der Entwickler kümmert sich nicht mehr drum laut deren Aussage :rolleyes:


    Besten Dank vorab 8)

  • Nun installiert er das Plugin auch, jedoch nur bis zum folgenden Error

    An sich bleibt dir nur, dass der Entwickler das Ding umschreibt und kompatibel macht (was ja wohl nicht der Fall sein wird), oder du findest jemand, der das Plugin umschreibt (sofern das die Nutzungslizenz des Plugins zulässt) bzw. ein neues entwickelt.


    P.S.

    Peak Memory Usage:

    36.311/5120 MiB

    5GB als memory_limit erscheinen mir doch etwas viel, auch wenn es "nur" eine Test-Umgebung ist. :)

  • An sich bleibt dir nur, dass der Entwickler das Ding umschreibt und kompatibel macht (was ja wohl nicht der Fall sein wird), oder du findest jemand, der das Plugin umschreibt (sofern das die Nutzungslizenz des Plugins zulässt) bzw. ein neues entwickelt.

    Eine Nutzungslizenz ist dort meines Wissens nicht drauf, kann aber nochmal nachfragen.

    5GB als memory_limit erscheinen mir doch etwas viel, auch wenn es "nur" eine Test-Umgebung ist. :)

    Hat alles so seine Richtigkeit ;)

    Aber PHP Version: 7.3.0 ist viel Schlimmer. Das ist noch nicht mit Woltlab Kompatibel.

    Um welches Plugin geht es? Dir bringt das einfügen in der package.xml nichts, da das Plugin ein Menüeintrag erzeugt. Und das hat sich im WSC geändert.

    Ja die PHP Version hab ich erst mal die gewählt da ich die Testumgebung frisch installiert hatte. Es handelt sich um folgendes Plugin


    com.giants-software.dedicatedserverstats-1.0.1.tar


    Dieses zeigt die Serverinformationen an wie zb. hier auf meiner alten WBB 4.1er version

  • LS 17 und 19. Also funktioniert für beide. Hatte mir das Plugin letztens angepasst. Da ich aber keine Info über die Lizenz habe, kann ich es auch nicht weitergeben..

    Ich selbst nutze es ja auch schon sehr lange auf meiner Website (unter der Shoutbox) Dennoch möchte ich das Plugin etwas anpassen umbauen und so machen das es sich eben auf der aktuellsten Core Version installieren lässt :)


    Und mipu glaube auch :D


    Irgendwo gabs dazu hier schonmal ein Thema.

    Mipu hatte sich grad bei mir gemeldet, das war es schon aber eben noch die version die sich eben nicht auf der aktuellsten Core Version installieren lässt 8o

  • Julius Cesar hast du bereits schon Infos darüber gefunden, welche Lizenz bei dem Plugin genutzt wird (falls überhaupt eine vorhanden)? Ich habe GIANTS Software mal vor ca. 2 Wochen angeschrieben, bisher allerdings noch keine Antwort.

  • Julius Cesar hast du bereits schon Infos darüber gefunden, welche Lizenz bei dem Plugin genutzt wird (falls überhaupt eine vorhanden)? Ich habe GIANTS Software mal vor ca. 2 Wochen angeschrieben, bisher allerdings noch keine Antwort.

    Ganz genau das gleiche, keine Antwort von GIANTS. Weiß nicht was man da nun machen kann :/

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!