Update problem

  • Affected Version
    WoltLab Suite 3.1

    What happened?

    An error has occured while trying to handle your request and execution has been terminated. Please forward the above error code to the site administrator.


    The error code can be used by an administrator to lookup the full error message in the Administration Control Panel via “Logs » Errors”. In addition the error has been written to the log file located at */log/2018-04-24.txt and can be accessed with a FTP program or similar.


    Notice: The error code was randomly generated and has no use beyond looking up the full message.

    System Information

    • PHP Version:

      5.6.30

    • WoltLab Suite Core:

      3.0.14 pl 1

    • Peak Memory Usage:

      52.23/256 MiB

    • Request URI:

      /acp/index.php?install-package/&t=9f65223d2a485853a901be969c9304594121762a

    • Referrer:

      https://www.trkulup.com/acp/index.php?package-update/

    • User Agent:

      Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15

    Final Error

    • Error Type:

      wcf\system\database\exception\DatabaseQueryExecutionException

    • Error Message:

      Could not execute statement 'SELECT pageContentID, pageID, languageID, content FROM wcf1_page_content WHERE languageID IN (?) AND pageID = (SELECT pageID FROM wcf1_page WHERE identifier = ?)'

    • Error Code:

      0

    • File:

      */lib/system/database/statement/PreparedStatement.class.php (105)

    • Query Parameter 1:

      com.woltlab.wcf.PrivacyPolicy

    • Stack Trace:
      • #0 */acp/update_com.woltlab.wcf_3.0.14.php (134):
      • wcf\system\database\statement\PreparedStatement->execute([ 0 => ])
      • #1 */lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72):
      • include('*/acp/update_com.woltlab.wcf_3.0.14.php')
      • #2 */lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50):
      • wcf\system\package\plugin\ScriptPackageInstallationPlugin->run('*/acp/update_com.woltlab.wcf_3.0.14.php')
      • #3 */lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70):
      • wcf\system\package\plugin\ScriptPackageInstallationPlugin->install()
      • #4 */lib/system/package/PackageInstallationDispatcher.class.php (603):
      • wcf\system\package\plugin\AbstractPackageInstallationPlugin->update()
      • #5 */lib/system/package/PackageInstallationDispatcher.class.php (141):
      • wcf\system\package\PackageInstallationDispatcher->executePIP([ attributes => , pip => , value => ])
      • #6 */lib/acp/action/InstallPackageAction.class.php (72):
      • wcf\system\package\PackageInstallationDispatcher->install('02ee3f5a')
      • #7 */lib/action/AbstractDialogAction.class.php (68):
      • wcf\acp\action\InstallPackageAction->stepInstall()
      • #8 */lib/action/AbstractAction.class.php (47):
      • wcf\action\AbstractDialogAction->execute()
      • #9 */lib/system/request/Request.class.php (83):
      • wcf\action\AbstractAction->__run()
      • #10 */lib/system/request/RequestHandler.class.php (94):
      • wcf\system\request\Request->execute()
      • #11 */acp/index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf', true)

    Original Error

    • Error Type:

      PDOException

    • Error Message:

      SQLSTATE[HY093]: Invalid parameter number

    • Error Code:

      0

    • File:

      */lib/system/database/statement/PreparedStatement.class.php (93)

    • Stack Trace:
      • #0 */lib/system/database/statement/PreparedStatement.class.php (93):
      • PDOStatement->execute([ 0 => ])
      • #1 */acp/update_com.woltlab.wcf_3.0.14.php (134):
      • wcf\system\database\statement\PreparedStatement->execute([ 0 => ])
      • #2 */lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72):
      • include('*/acp/update_com.woltlab.wcf_3.0.14.php')
      • #3 */lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50):
      • wcf\system\package\plugin\ScriptPackageInstallationPlugin->run('*/acp/update_com.woltlab.wcf_3.0.14.php')
      • #4 */lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70):
      • wcf\system\package\plugin\ScriptPackageInstallationPlugin->install()
      • #5 */lib/system/package/PackageInstallationDispatcher.class.php (603):
      • wcf\system\package\plugin\AbstractPackageInstallationPlugin->update()
      • #6 */lib/system/package/PackageInstallationDispatcher.class.php (141):
      • wcf\system\package\PackageInstallationDispatcher->executePIP([ attributes => , pip => , value => ])
      • #7 */lib/acp/action/InstallPackageAction.class.php (72):
      • wcf\system\package\PackageInstallationDispatcher->install('02ee3f5a')
      • #8 */lib/action/AbstractDialogAction.class.php (68):
      • wcf\acp\action\InstallPackageAction->stepInstall()
      • #9 */lib/action/AbstractAction.class.php (47):
      • wcf\action\AbstractDialogAction->execute()
      • #10 */lib/system/request/Request.class.php (83):
      • wcf\action\AbstractAction->__run()
      • #11 */lib/system/request/RequestHandler.class.php (94):
      • wcf\system\request\Request->execute()
      • #12 */acp/index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf', true)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!