In .XML-Dateien die XSDs definieren

  • Ich bin gerade dabei ein paar Korrekturen in meinen Files einzustellen.

    Unter anderem die XSDs sollte ja auf den laufenden Stand sein.

    Ich habe zum Beispiel dieses Data-Tag:

    <language xmlns="http://www.woltlab.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.woltlab.com http://www.woltlab.com/XSD/tornado/language.xsd" languagecode="de" languagename="Deutsch" countrycode="de">

    Allerdings zeigt mir PHPStorm immer einen Fehler an:

    Cannot resolve symbol...

    siehe auch Bild1.png

    Ich habe schon einige Varianten in der entsprechenden Einstellung versucht, aber er findet da anscheinend nichts und PHP macht immer einen ERROR.

    Egal in welcher XML ich mich befinde, immer der gleiche Fehler... ist da etwas falsch eingestellt bei mir oder wo liegt der Fehler?

    Was muss ich in den Settings in PHPStorm denn da einstellen? Alexander Ebert ... vielleicht eine kurze Hilfe dazu? Danke sehr... ;)

  • Ich habe jetzt einiges probiert... In den Settings versucht was mit einzutragen, keine Änderung, Als Libary mit hinzugefügt mit verschiedensten Varianten... keine Änderung.

    Kann mir bitte einer mal zeigen, wie man es korrekt in PHPStorm (neuste Version) eintragen muss, damit es keine Fehlermeldungen gibt? Irgendwie schaffe ich das nicht...

  • Kann denn hier keiner helfen? Es ist echt nervig bei JEDEM GitHub-Push diese Warnung weg zu klicken, dass ERRORs noch vorhanden wären, denn diese nicht zuordnbare XSDs werden als rote ERRORs deklariert...

    Irgendwie mache ich da noch was falsch.... ;)

  • WCF-Repository als Dependency in deinem Projekt einbinden

    Du meinst den Ordner von der WSC-Installation (lokal auf dem gleichen Rechner im XAMPP-httpdocs-Ordner) in die PHP-Libary für das Projekt integrieren? Das habe ich schon gemacht. Er findet zum Beispiel alle WSC-Klassen...

    Oder wo soll ich das einstellen? In den Settings?

  • In der Konfiguration funktioniert

    Du meinst in der Konfiguration die du hier mal zur Verfügung gestellt hast?!? Damit geht es nicht.

    Hast du eventuell irgendeine alte Version, ich habe hier PhpStorm 2017.3.4 im Einsatz?

    Die neuste Version (2017.3.4) nutze ich ebenfalls... und auch ich habe immer noch ein zwei Dateien, die diesen Fehler auswerfen... Alexander Ebert ....

    Komisch ....

  • Was hältst du denn davon, wenn du diese beiden Dateien einmal nennst? Deine bisherigen Aussagen klangen nämlich so, sodass bei dir alle XSDs nicht funktionieren.

    Edited once, last by Fighter456: Rechtschreibung korrigiert (February 6, 2018 at 8:46 AM).

  • Jap... sind Sie... Genauso wie ich es oben geschrieben habe aus #16 ... als Beispiel...

    Aber bei package.xml gibt es ja keine Großbuchstaben im Namen und auch hier kommt der Fehler.... oder muss der erste Letter groß sein?

  • Dann habe ich da keinen Fehler... ist alles korrekt angegeben... Ich verstehe das nicht... Warum zeigt er in einigen Dateien diesen Fehler und bei anderen nicht...

    Das komische ist auch, ich habe mal die alte URL angegeben mit mealstorm... und auch vortex ... keiner der URLs funktioniert... obwohl wenn ich ein anderes Projekt öffne und dort diese URLs verwendet werden, kommt kein Fehler...

    Merkwürdig das Ganze...

  • Also jetzt zeigt PHPStorm es in ALLEN .xml-Dateien an...

    Da ist doch bestimmt irgendwas total falsch eingestellt...

    Aber kann es sein, dass PHPStorm nicht permanent sondern in irgendwelchen Intervallen die URL überprüft? Denn ich habe gesehen, dass erst die Zeie mit dem DATA-Tag nicht rot markiert war... aber ein Auge oben rechts in der Ecke zu sehen war... Kurze Zeit später wurde das Auge durch ein anderes Icon ersetzt und dann wurde die Zeile rot und dieser Rote Punkt mit dem Ausrufezeichen erschien mit dem Hinweis, das irgendwas nicht geladen werden kann...

    Und nun ist es in JEDER XML-Datei, die mit einem DATA-Tag versehen ist...

    Ich dreh durch hier....

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!