Installation des wbb4.1.14 auf XAMPP Server schlägt fehl

  • Hallo Community,


    heute habe ich versucht ein wbb4.1.14 auf einem XAMPP Server bei mir auf der Maschine zu installieren und erhalte folgende Fehlermeldung:




    Was ich bisher getan habe:


    • XAMPP in der neusten Version installiert
    • WBB4.1.14 neu heruntergeladen
    • Rechte des Verzeichnisses und der Dateien überprüft (upload, test.php, install.php und WCFSetup.tar.gz)
    • Spaßeshalber mal das WSF 5.0.5 installiert (funktionierte einwandfrei!)


    Danke für jede weitere Hilfe im Voraus.

  • Bitte Fehlermeldungen nicht als Bild sondern im Klartext im CODE-Tag posten. Sonst haben Suchmaschinen und Leute mit kleinen Displays keine Chance. Danke.


    Erstelle unter e:\xampp ein Verzeichnis "tmp" und sorge dafür, dass Jeder volle Rechte darauf hat. Dann versuche es erneut.

  • Bitte Fehlermeldungen nicht als Bild sondern im Klartext im CODE-Tag posten.

    Erstelle unter e:\xampp ein Verzeichnis "tmp" und sorge dafür, dass Jeder volle Rechte darauf hat. Dann versuche es erneut.

    Fehlermeldung in Codebox eingefügt. Check.

    tmp Ordner ist bzw. war schon angelegt und alle Nutzer haben Vollzugriffsrechte.

    Während der Installation legt die Installationsroutine auch folgende Ordner an:

    Code
    - install
        - files
            - acp
            - font
            - icon
            - lib

    dann bricht er mit der obigen Fehlermeldung die Installation ab.

  • Sorry wenn ich jetzt so blöd frag. Nach dem Bild sieht es mir eher nach einem wbb 3.x aus :/

    Hmm woran machst du das fest?

    Es ist aber die aktuelle Version wbb4.1.14.zip hier aus dem Kundenbereich^^

  • Den Gedanken hatte ich auch. Von der Farbgebung her schaut es nach einem 3.1 aus.

    Ich mache keine Fehler.......

    Ich erschaffe Katastrophen

  • Unter Windows sind alle Rechte gesetzt.

    Auf den Dateien kann man nur den Schreibschutz aufheben, da Windows kein CHMOD kennt.

  • Genau das ist gemeint... Ich hatte solche Probleme auch mit der aktuellsten XAMPP-Installation und nutze unter WIN 7 nun eine ältere Version (5.6.14).

    - Wenn bei Dummheit & Arroganz Federn wachsen sollten, so würden hier einige wie Vögel durch die Luft fliegen -

    - Powerstylez.de -

    • Official Post

    Verwende mal die install.php aus dem Dateianhang, die stammt zwar von der aktuellen Version, aber abseits von einem kaputten Logo in der Installation sollte alles passen. Ich habe da so einen Verdacht bezüglich PHP 7.1, denn der Klassenname in der Fehlermeldung im Startbeitrag ist merkwürdig abgeschnitten.

  • Alexander Ebert


    Habe jetzt einmal die angehängte install.php benutzt und die Installation läuft einwandfrei durch. Danke.


    Jetzt frage ich mich natürlich wo der Fehler lag?

    Wird es noch im Kundenbereich mit eingefügt?


    MfG

    M.Schmitz

    • Official Post

    Jetzt frage ich mich natürlich wo der Fehler lag?

    Wird es noch im Kundenbereich mit eingefügt?

    Ich hatte mal ein ähnliches Problem mit PHP 7.1, konnte es aber nicht erneut reproduzieren. Mir bleibt nichts anderes übrig, als es entsprechend nochmal auszuprobieren. Die oben angehängte install.php läuft unter PHP < 5.5 nicht korrekt, weshalb man diese Version nicht unverändert nutzen kann.

  • Okay.

    Wenn ich es richtig verstanden habe muss ich diese install.php immer dann nutzen wenn PHP 5.6 und höher verwende?

    • Official Post

    Das kann ich pauschal nicht sagen, im Zweifel immer die zugehörige install.php ausprobieren und im Falle dieses Fehlers die andere verwenden. Üblicherweise installiert man wenigstens nicht jeden Tag neu ;)

  • Das stimmt, es ging in meinem Fall ja auch um eine lokale Installation um neue Plugins und oder Styles zu testen um nicht im Produktivsystem etwas zu zerschießen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!