Last Unread Post not working on most threads

  • Affected Version
    WoltLab Suite 3.0

    Most threads no longer take me or my users to the last unread post in a thread. Works on some threads and not others. It seems to work on older threads.

    What should I be looking for as a cause?

    The only thing I have done different recently is force HTTPS through .htaccess, but that was several days before anyone pointed this problem out to me.

  • I just cleared my cookies and browser cache and then tested a thread that I had read before. The very first time I went back to the thread after clearing cookies it took me to the last unread post but then every other time it did not - it just took me to the first post in the thread.

    So it worked properly one time after clearing the browser and then every other time after that it did not work again.

  • Or maybe I'm not getting how this feature worked before?

    I guess after all posts in a thread are read, the next time you click the thread is it supposed to take you back to the first post or the last post? I thought it was supposed to take you back to the last post, but maybe I'm remembering wrong? Did this feature change recently?

  • This can't be the way it worked before, I would have remembered that.

    The way this works now is if there are unread posts it will take you to the first unread post, say in the middle of a 5 page thread. Then after you've read the thread if you click on it again it takes you to the first post on the first page and you have to go find the last page again.

    I do not like that at all. I know that you can go to the last post by clicking the icon of the last poster, but it didn't work that way before and this is very bad now.

  • I just want to know if it's normal.

    If you click on a thread that you have visited before, when there is a new post you are taken to that post when you click on the thread, right? In other words you are taken to the first NEW post - say it's on page 6 of a long thread.

    Now after you have seen that post and click on the thread again, you are taken to page ONE and the very first post of the six page thread.

    Is that a new change? My users are asking me and they think it is something wrong with their browser or cookies.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!