Deutsch auf Englisch wechseln, Zurück geht nicht mehr

  • Hab mir mal wieder eine zweisprachige Startseite zusammengebaut.

    Ich kann einmal mit dem Sprachbutton neben dem "Seite bearbeiten" Button auf Englisch wechseln, aber dann nicht mehr auf Deutsch zurück - es bleibt die englische Variante.

    Auch ein manueller wechsel, indem ich die URL von home-en auf home-de ändere wird mit Zurückleitung auf home-en und damit die englische Version quittiert. Man kommt erst wieder auf die Deutsche, indem man sich ausloggt und wieder einloggt.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Es ist auch als Gast nicht möglich von der Englischen auf die Deutsche Variante zu wechseln (mittels Languagechooser im Menü), wenn man mit dieser gestartet ist (weil englisches OS) oder man darauf gewechselt ist.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Hatte damit auch mal ein merkwürdiges Verhalten. Letztendlich hink es damals bei mir wirklich irgendwie, mittlerweile gibt es die Probleme (bei mir) auch nicht mehr. Es wird immer fröhlich hin und her gewechselt, wenn ich die Sprache ändere oder als Gast per Flagge oben in der Leiste.


    Eventuell auch ein Cache-Problem bei Dir!? ?(:/

  • Leider nein, da auch von meinen beiden Testern reproduzierbar.


    Nach Englisch gehts, aber nicht mehr zurück.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Die Fehlerbeschreibung dort trifft es übrigens exakt. Ich hatte das auch in der Beta schonmal gehabt und gemeldet und es hatte ein Behoben bekommen.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Ich habe das Problem bei meiner Installation nicht nachstellen können. Wenn ich einen englischen Browser habe, wird mein User / Gast auf Englisch gestellt und der Content einer Seite auf Englisch angezeigt. Alle Bedienmittel und Systemfunktionen (z. B. das Impressum, dass dann legal notice heißt) sind ebenfalls auf Englisch.


    Schalte ich als Gast im Benutzermenü die Sprache um, ändert sich sowohl die Conent-Sprache, als auch die Systemsprache.


    Das gleiche auch mit einem eingeloggten Benutzer, nur mit dem Unterschied, dass ich oben keinen globalen Sprachwechsler habe, sondern nur einen im Contentbereich, um die Sprache der aktuellen Seite / des aktuellen Artikels zu wechseln. Die Systemelemente bleiben in dem Fall unberührt. Habe ich als einen deutschen Account und lasse mir die den Content auf Englisch ausgeben, steht unten weiterhin Impressum.


    Ich finde das verwirrend, dass immer nur die Content-Sprache gewechselt wird.....scheint aber so vorgesehen zu sein.

  • Eingeloggt wechselst du die Sprache ja auch im Benutzermenü. Den Wechsler bei den Seiten sieht man doch nur als Admin?


    Das Wechseln det Sprache schlägt auch nur bei der selbsterstellten Startseite fehl, im Impressum oder anderen Systemseiten funktioniert er einwandfrei.


    Alexander Ebert  Tim Düsterhus


    Könnt ihr das in Fehler verschieben? Auch wenn es gleich als nicht reproduzierbar getaggt wird, so kann ich es doch ums verrecken bicht beheben und das Verhalten ist nicht nur nach Löschen von Cache und Co sondern auch in einem neuinstallierten Browser reproduzierbar.


    Beachten:

    Seite ist Startseite und wird über Root aufgerufen. URL für deutsche Version lautet /home-de/, englische Version lautet /home-en/, URL Unschreibungen aktiviert. Wenn man auf Englisch stellt landet man bei /home-en/?l=1. Zurück geht es auf dieser Seite nicht mehr. Nur über eine andere Seite.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

    Edited 4 times, last by D3nnis3n ().

  • Update:

    Chrome komplett geleert - hilft nix. ("Seit Beginn an")

    Chrome komplett geleert, deinstalliert und neuinstalliert. - Funktioniert jetzt am Desktop.

    Allerdings kann ich weiterhin als eingeloggter Admin auf der Seite nicht über die Schaltfläche Deutsch / Englisch die Sprache wechseln, der Text ändert sich einfach nicht, auch wenn die andere Flagge angezeigt wird.

    Ausgeloggt über den Wechsler geht es jetzt am Desktop.


    Selber Versuch mobil:

    Chrome komplett geleert - hilft nix. ("Seit Beginn an")

    Chrome komplett geleert, deinstalliert und neuinstalliert. Hilft bedingt.

    Jetzt ist die Seite immer in Englisch (vom ersten Aufruf an!) und lässt sich außer durch Login nicht auf Deutsch umstellen. Ich nutze aber einen deutschen Chrome Mobile. Ob ich die deutsche URL, ?l=1 oder am Wechsler umstelle - es bleibt englisch und ich bekomme nichts anderes.


    Probieren wir einen frisch installierten mobile Firefox:

    Seite aufrufen - ist Deutsch.

    Auf Englisch stellen - wird Englisch.

    Auf Deutsch stellen - bleibt Englisch.

    Rückkehr nicht mehr möglich, außer durch Login.


    Was auch immer die Browser damit zu tun haben sollen, irgendwie mögen die euer Cache-Verhalten nicht.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

    • Official Post

    Chrome liebt es Redirects zu Cachen und das geht so weit, dass dir unter der selben URL der Content der anderen URL angezeigt wird. Öffne einfach die Developer Tools (F12), geh auf Network und setze den Haken bei Disable Cache. Bedenke, dass (a) diese Option nur wirkt, solange die Developer Tools offen sind und (b) dadurch in dem Tab der Cache komplett deaktiviert ist, einschließlich Bilder, JavaScript und Fonts.


    Im Übrigen ist dein Setup nichts ungewöhnliches, die Startseite von woltlab.com ist auch eine mehrsprachige CMS-Seite. Hast du eigentlich daran gedacht, die individuelle URL bei der gewünschten Startseiten-Sprachversion leer zu lassen? Konkret bedeutet das:

    • Englische Version: Individuelle URL leer (lies: keine Angabe)
    • Deutsche Version: Individuelle URL steht auf de (oder home-de um bei deinem Beispiel zu bleiben)

    Das Ganze geht natürlich auch umgekehrt.

  • Und wie zum Geier mach ich das mobil und in mobilem Firefox? Das muss schließlich auch dort funktionieren ...

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Also bei mir sieht das z. B. so aus:


    Deutsch: https://jakoblicina.com/de/projects/

    Englisch: https://jakoblicina.com/en/projects/


    Diese Links sind bei mir immer eindeutig, alle Inhalte weisen zuerst dieses Sprachenkürzel auf, bevor der eigentliche Link kommt. Die URL https://jakoblicina.com/projects/ würde somit nicht funktionieren (ich denke darüber nach, dies später mal irgendwie zu verbessern.


    Vorteil an der Sache ist, dass ich einem Nutzer / Leser / Freund daher immer genau die Sprachvariante einer Seite ausliefern kann, die ich ihm geben möchte.


    Das Ganze geht natürlich auch umgekehrt.

    Wie würde das denn bei Artikeln gehen? Die haben ja immer die gleiche URL, die ja immer anhand der ID des Artikels geformt wird. Das Anhängen von ?l=1 bzw. ?l=2 am Ende der URL haben hier leider nicht geholfen. Ich hatte das so aus WCF 2.x in Erinnerung.

  • D3nnis3n Hattest du die individuellen URLs entsprechend meines Hinweises angepasst?

    Nein, das stand auch noch nicht dort als och geantwortet habe.


    Dennoch erschliesst sich mir nicht, warum die Startseite nicht auch zwei URLs haben kann und warum ich eine Variante aussuchen muss (will ich nämlich nicht!) - die Browsersprache sollte die Startseite automatisch bestimmen. Aber ich pass das mal nachher so an, vermutlich gehts dann. Wäre ich von selbst aber nie drauf gekommen, sag ich dir ganz ehrlich. Absolut unerwartetes Verhalten. Für den Engländer ist nunmal /en die Startseite und für den Deutschen /de. Ich will halt eigentlich nicht festlegen, dass / für DE steht und /en für EN. Meine anderen Seiten haben ja auch jeweils einen eigenen Link pro Sprache. Muss ich dem Inhalt überhaupt einen eigenen Link je Sprache geben?

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

    Edited once, last by D3nnis3n ().

  • Es hilft aber auch nicht:

    Startseite Deutsch: / (Keine URL festgelegt)

    Startseite Englisch: /en (en als URL festgelegt)


    Seite mobil nach Cache löschen betreten:

    Sehe / und Deutsch


    Wechsel auf Englisch:

    Sehe /en und Englisch


    Wechsel auf Deutsch:

    Sehe /en?l=1 und Englisch


    Funzt einfach net, muss zu doof für euer CMS sein :O

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Alexander Ebert

    Ich machs mal interessant:

    Geht auch auf Woltlab nicht.


    Rufe auf: woltlab.com

    Bekomme: woltlab.com/de (Deutsch)


    Wechsle auf Englisch.

    Bekomme: woltlab.com/de?l=2 (Text weiterhin Deutsch, Flagge auch.)


    Famos.

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Hab jetzt eingeloggt auf englisch in der Benutzerverwaltung gestellt. Forum ist englisch lokalisiert. Drücke dann im Menü auf Woltlab Suite.


    Sehe eure CMS Startseite:

    Bleibt Deutsch. (Auch das Nutzermenü dort)


    Lustig. Sorry. Mobile Chrome sagt nein zu dem System. Wenn ihr also eine englische Seite haben solltet: Ich komme nicht drauf.


    Im Anhang vier Bilder, nach jedem Klick.

    (Das dritte - von eurer Startseite auf Deutsch ist leider zu gross, musst dir bildlich vorstellen)


    Ich kann übrigens Cache löschen wie ich lustig bin. Ich komme nicht auf eure englische Seite. Nie. Nieeeee.

  • Ich geb auf. Meine beiden Mittester können hier auf Woltlab auch keine englische Seite betreten.


    MysteryCode

    Fireball? Gibts schon ne RC?


    Neuer Fehler:

    Gebe ein: @Mystery

    Wähle aus: MysteryCode

    Erhalte: @MysteryMysteryCode


    Eigenes Thema? Das war doch schon behoben ...

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • "Cannot reproduce"

    Es stört euch also nicht, dass mindestens 3 Leute eure Präsentationsseite nicht auf Englisch ansehen können? Echt jetzt?

    Meine Beiträge stellen - sofern nicht ausdrücklich anders gekennzeichnet - ausschließlich meine subjektive und aus Erfahrung und / oder Reflexion gewonnene Meinung dar und sind nicht als Fakten zu verstehen. Meinungen sind persönliche Ansichten und benötigen keine Belege. In Deutschland gilt nach Artikel 5 des Grundgesetzes Meinungsfreiheit. Meine Beiträge stellen keine Rechtsberatung dar, hierzu bin ich nicht befugt.

  • Frisch installierter Firefox:

    Öffnen woltlab.com

    Auf Englisch stellen

    Bleibt Deutsch


    Echt nicht reproduzierbar? Wat?


    Sorry für den zehnfachpost, ist so aber übersichtlicher und mobil zu editieren ist ein graus.

  • Frisch installierter Firefox:

    Öffnen woltlab.com

    Auf Englisch stellen

    Bleibt Deutsch


    Echt nicht reproduzierbar? Wat?

    Der Fehler ist definitv reproduzierbar, Seite bleibt auf Deutsch.