Kompatibel mit PHP 5.5, 5.6 oder 7.0?

  • Hallo, ich habe von unserem Hoster (all-inkl) eine Mail erhalten, dass mein PHP 5.3 veraltet sei und dass ich diese umstellen müsse. Wie das funktioniert ist mir klar doch welche Version von den dreien muss ich auswählen und mit welcher ist das WBB 4.1 kompatibel? Bzw. gehe ich richtig in der Annahme, dass ich auf die aktuellste Version - in diesem Fall 7.0 - umstellen muss? Und wie sieht es mit den Plugins aus?

    Fragen über Fragen...

  • Danke dir, scheint alles reibungslos geklappt zu haben, so viele Plugins hab ich auch gar nicht installiert. Nur der MySQLDumper funktioniert bedauerlicherweise nicht mehr.

  • Schau mal hier nach. Das ganze wird von enem anderen Team anscheinend weiterentwickelt. Ich hab es mit php5.6 und php7 getestet und es läuft bis jetzt gut.

    Hab's gefunden MyOOSDumper nennt sich das jetzt und es läuft mit PHP7.

    MYOOSDUMPER

    Edited 3 times, last by DER DUKE: Hab's gefunden,hier der Link zu MyOOSDumper läuft mit PHP7 MyOOSDumper​ (December 2, 2016 at 9:55 AM).

  • Hallo Zusammen,

    ich hätte die gleiche Frage wie der Threadersteller, da ich jedoch nichts von PHP verstehe, muss ich sie Euch nochmals zumuten. Mein Provider (1&1) schreibt, ich hätte meine PHP-Version nun endlich auf 7.0 zu aktualisieren, sonst kostet's.

    Benutze wbb 4.1.12 und wcf 2.1.12

    WCF 2.1 / WBB 4.1 ist bis mindestens 7.0 lauffähig.

    Bedeutet das, ich kann "einfach so" auf PHP 7 umstellen und habe keine Probleme zu erwarten? Plugins sind ausser den Ordner-icons keine installiert.

    Besten Dank für Hilfe!
    jakob

  • Hab mal die SQL Datenbank PHP7 von all-inkl.com mit Script und Cronjob gesichert,Mega einfach und eine Info über Mail gibt es auch..


    Hab das auch mal ausprobiert und es klappt wunderbar. Doch komischerweise ist die Datenbank etwa 5% kleiner, als mit dem Dumper, obwohl beide gz komprimiert sind. Ist das ein Grund zur Besorgnis oder woran könnte das liegen?

    Bedeutet das, ich kann "einfach so" auf PHP 7 umstellen und habe keine Probleme zu erwarten? Plugins sind ausser den Ordner-icons keine installiert.


    Bei mir gab es keinerlei Probleme, auch mit den gängigen Plugins nicht (Shoutbox, Chat, etc.), ausser wie gesagt beim MySQLDumper aber der gehört ja nicht zum WBB.

  • Hallo, ich habe von unserem Hoster (all-inkl) eine Mail erhalten, dass mein PHP 5.3 veraltet sei und dass ich diese umstellen müsse. Wie das funktioniert ist mir klar doch welche Version von den dreien muss ich auswählen und mit welcher ist das WBB 4.1 kompatibel? Bzw. gehe ich richtig in der Annahme, dass ich auf die aktuellste Version - in diesem Fall 7.0 - umstellen muss? Und wie sieht es mit den Plugins aus?

    Fragen über Fragen...

    selbiges Problem haben wir auch im Forum. Jetzt hat all-inkl das alte PHP bis 5.4 abgeschaltet.

    Im kas von all-inkl sind jetzt die Version 5.5 (modul) eingestellt, aber die Seite wird nicht aufgebaut, bzw. bleibt komplett weiss. Keine Fehlermeldung.

    Was muss ich einstellen um das WBB3 (tempest) wieder zum laufen zu bekommen? Vorher war dort 5.4 (modul) eingestellt

    Installiert sind die Versionen

    php version: 5.5.38-nmm2

    wcf version: 1.1.10 pl 2 (Tempest)

  • was ich gelesen habe, soll die Version wbb3 3.1.8 mit php 5.5 oder höher umgehen können. Wie bekomme ich nun raus, welche Version ich habe? In welcher Datei müsste ich nachschauen?

    Mir ist klar, das es für wbb3 3.x keinen Support mehr gibt und die Version 4 ist auch schon bezahlt, aber ich würde da gerne einen geordneten Übergang durchführen.

    Wie bekomme ich also mein Forum wieder zu laufen?

    gruss

  • oder höher umgehen können.

    PHP 5.5 ja, aber höher würde ich bezweifeln. Spätestens mit PHP 7.1 dürfte Schluss sein.

    Wie bekomme ich nun raus, welche Version ich habe?

    Auf der ACP-Startseite wird dir im System-Tab die PHP-Version angezeigt. Das war, wenn ich mich nicht irre, bereits zu WCF 1.1-Zeiten so

    Wie bekomme ich also mein Forum wieder zu laufen?

    Was läuft denn nicht?

  • PHP 5.5 ja, aber höher würde ich bezweifeln. Spätestens mit PHP 7.1 dürfte Schluss sein.

    Auf der ACP-Startseite wird dir im System-Tab die PHP-Version angezeigt. Das war, wenn ich mich nicht irre, bereits zu WCF 1.1-Zeiten so

    Was läuft denn nicht?

    ich habe die 3.1.8 installiert. komischerweise funktioniert der link auf das /acp . Also geht das php 5.5 wohl grundsätzlich.

    Es läuft deswegen nicht, weil wie ich bereits geschrieben habe, all-inkl das php 5.4 (und ältere) abgestellt hat und ich eigentlich dachte die Version php 5.5 getestet zu haben. Seit heute habe ich einen weissen Bildschirm. Es erscheinen keine Fehler.

    Die Seite bleibt weiß mit oder ohne .htaccess und mit oder ohne AddType Einträge darin.

    Wenn nun die Version 5.5 unterstützt wird von der wbb 3.1.8, warum läuft das hier nicht?

    gruss

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!